Ask Your Question
0

Turtlebot not appearing on RViz during mapping

asked 2011-11-06 21:47:32 -0500

apalomer gravatar image

updated 2015-07-14 09:42:03 -0500

130s gravatar image

Hi,

I'm trying to follow this tutorial to build a map with the turtlebot. The thing is that I can not see anything on the rviz. If I look at the topics on the left column I see that it has two problems: Pose Array and Path. Both have the same problem: No message received. When I have a look at the diagnostics on turtlebot dashboard I get this message:

name: /slam_gmapping msg: Transform from base_link to odom failed

file: /tmp/buildd/ros-diamondback-slam-gmapping-1.2.3/debian/ros-diamondback-slam-gmapping/opt/ros/diamondback/stacks/slam_gmapping/gmapping/src/slam_gmapping.cpp function: laserCallback line: 496 topics[] topics[0]: /rosout topics[1]: /tf topics[2]: /slam_gmapping/entropy topics[3]: /map topics[4]: /map_metadata

My turtlebot doesn't have a gyro. Can this be the problem?

Thanks

edit retag flag offensive close merge delete

7 Answers

Sort by ยป oldest newest most voted
3

answered 2011-11-09 18:07:04 -0500

Atom gravatar image

From my experience Gmapping without the gyro will give the same results as you mentioned. Turtlebot doesn't move around the map. I believe this is due to the fact it obviously needs the gyro data to localize it self properly . I assume you could use RXGraph to find where the missing data link in gmapping is and possibly write your own code to create data to determine your robots location but, if I were you I would just invest in the recommended gyro.

edit flag offensive delete link more
1

answered 2011-11-10 22:43:29 -0500

MichiReip gravatar image

checkout http://www.ros.org/wiki/roomba_500_series. You will find a roomba560_node.cpp. For mapping you have to add a joint state publisher, just like turtlebot_node does.

edit flag offensive delete link more
0

answered 2011-11-08 22:03:24 -0500

apalomer gravatar image

I've solved part of the problem and I only get the first half of what I posted. It only happends that nobody is publishing at the topics Pose Array and Path. I set the gyro as false, because I don't have one, useing: rosparam set turtlebot_node/has_gyro false

What are this topics which I have the problem? I realised that when I run rviz the robot doesn't move arround the enviroment as it's suposed to do. What I mean is tat when I try to create a new map the robot only tourns and prints the map all at the same point so at the end I get a mess not a map. I think this has to do with one of the topics which is suposed to "know" where the turtlebot is.

What would you recomend me to cheeck to see why is nobody publishing?

Thanks

edit flag offensive delete link more
0

answered 2011-11-15 01:09:03 -0500

apalomer gravatar image

Problem almost solve, I've changed the odometry in turtlebot_node.py for the one in roomba560.cpp and it's working quite well. Now it only needs a little bit of calibration...

edit flag offensive delete link more
0

answered 2011-11-10 21:43:29 -0500

apalomer gravatar image

I've solved the problems. The two topics are not supposed to be published while mapping, they're only for the autonomous navigation. The other thing is that I'm still not able to create maps, that's because of the odometry calculated on turtlebot_node.py is not correct for the roomba564. We're working on a new odometry for that model of robot, and hopefully when the new odometry works the mappgin will also work.

edit flag offensive delete link more
0

answered 2012-02-24 01:29:22 -0500

osuairt gravatar image

Hi,

I get the same transform problem and I have been scratching my head for some time to find out why. I have a gyro, it is present on the turtlebot_dashboard etc. I don't have a roomba base like in your case, I have the actual Create base.

It remains a mystery.

edit flag offensive delete link more

Comments

Have you tried using rxgraph to look for any broken links? Are you sure your gyro is fully functional and installed correctly? Are you receiving any data from the gyro ?

Atom gravatar image Atom  ( 2012-02-25 18:27:29 -0500 )edit

Dashboard says so, also when running minimal.launch it specifies measurement rate of 150. It is all there. I'm getting a lot of skipping, http://imgur.com/3NJZ0 . http://imgur.com/nsQ9X graph is complete. I've swapped out the Create base with another and still get the problem.

osuairt gravatar image osuairt  ( 2012-02-27 04:11:53 -0500 )edit

Looking back at some of your other posts I noticed you were using a Samsung NC110. I think this netbook might not be enough power to run gmapping along with rviz together. Are you running gmapping and rviz on this one machine? Your cpu might be lagging and causing some problems.

Atom gravatar image Atom  ( 2012-02-27 19:20:43 -0500 )edit

Hi, Rviz is running on a workstation like it should. Point cloud throttling is set to 10.0 and I get a load average of 0.8 to 1.5 on the netbook, it is a dual core Atom N570, meaning no system overload.

osuairt gravatar image osuairt  ( 2012-02-27 22:06:15 -0500 )edit
0

answered 2011-11-11 00:27:38 -0500

apalomer gravatar image

MichiReip, I have this package and I know it's working. but I can not work with both at the same time. They can't read both from the same USB port. that's why we want to change the odometry on the turtlebot_node.py for the one on the roomba560.cpp

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-11-06 21:47:32 -0500

Seen: 1,786 times

Last updated: Jul 14 '15