Ask Your Question
0

how to capture data from Velodyne32, network setting?

asked 2014-01-14 01:59:24 -0600

marilia15 gravatar image

updated 2014-02-27 02:11:39 -0600

I'm using ubuntu 13.04 64b with ROS Groovy and I'm trying to use velodyne 32.

I've followed the tutorial [Getting Started with the Velodyne HDL-32E] and rviz is not showing the scenes.

  1. sudo ifconfig eth0 192.168.3.100 <-- IP for my PC
  2. sudo route add 192.168.18.108 eth0 <-- velodyne IP
  3. roslaunch velodyne_pointcloud 32e_points.launch calibration:=/home/vic/32db.yaml
  4. rosrun rviz rviz -f velodyne > configure as the tutorial said.

Rviz shows a message: "no tf data. Actual error: Fixed frame [/velodyne] does not exist ".

tcpdump and wireshark has captured no package, so my network is not properly set.

What is wrong in my network configuration? Thanks in advance.


Updated: I fixed a wire inside Velodyne and now everything is fine . But I want to understand the network setting.

If I connect velodyne to my PC, with wireshark I detect ethernet packages from velodyne (.18.108) to broadcast (.3.255).

So, I do step 1 ( sudo ifconfig eth0 192.168.3.100) and my PC should "listen" these packages because it is now the receiver.

If I don't do step2, when I do step3 the /velodyne_points is an active topic (rostopic list) but with no data (rostopic echo /velodyne_points).

So, Why do I need step 2? (sudo route add 192.168.18.108 eth0 ). What does? I think is to say "admit packages from this IP". But, is it not the default option? to admit these?

Thanks in advance.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-01-15 03:57:37 -0600

Vincent R gravatar image

updated 2014-01-16 02:40:40 -0600

It seems that the topic /velodyne_points is not published.

You can check at first that you received data from the velodyne with this command in a terminal :

sudo tcpdump -i eth0 port 2368

If no packet are received then your network connection is not set properly. In the velodyne documentation, it says that for "HDL-32E units, the destination IP address remains fixed at 192.168.3.255." So I just set my PC address to 192.168.3.255 and the mask to 255.255.255.0.

If it works, in a second time you can check that raw packets are published in ROS :

rostopic hz /velodyne_packets
edit flag offensive delete link more

Comments

Thanks. I used your commands to check that no topic was published. A wire inside Velodyne was disconnected, I fixed and it's allright.

marilia15 gravatar imagemarilia15 ( 2014-02-16 22:03:46 -0600 )edit
-1

answered 2014-01-15 22:49:19 -0600

marilia15 gravatar image

updated 2014-01-15 23:29:00 -0600

update my first post with my network configuration

edit flag offensive delete link more

Comments

Our Velodyne has (after upgrade) address in 192.168.1.0 network (btw there is now web interface). And please, don't add answers - update your original question or add comments. This is not discussion board :-)

ZdenekM gravatar imageZdenekM ( 2014-01-15 23:03:14 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-01-14 01:59:24 -0600

Seen: 1,232 times

Last updated: Feb 27 '14