Ask Your Question
0

roslaunch ocl deployer node does not recognize '-s foo.ops --'

asked 2011-11-01 08:19:46 -0500

brianw1 gravatar image

When I run:

rosrun ocl deployer-gnulinux -s foo.ops

This works just fine, however when I try this from within a *.launch file

(documented here: http://www.ros.org/wiki/ocl)

<launch> <node name="orocos" pkg="ocl" type="deployer-gnulinux" launch-prefix="gnome-terminal -e" args=" -s $(find orocos)/foo.ops --"> </node>
</launch>

I get:

Failed to parse arguments: Unknown option -s

It looks like the arguments are being treated differently when called this way.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-11-03 21:25:22 -0500

Hey Brian,

you are definitively using the correct syntax. All I can think of is something goes wrong with combining it with the gnome-terminal command. I'm using very similar syntax, but with the x-terminal instead, so maybe you could try that one and see if that gives you any better results:

< node name="orocos" pkg="ocl" type="deployer-gnulinux" launch-prefix="xterm -e" args="-s $(find orocos)/system.ops -- ">
</node>

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-11-01 08:19:46 -0500

Seen: 470 times

Last updated: Nov 03 '11