Ask Your Question
0

errors installing orocos_toolchain_ros on electric

asked 2011-10-13 23:18:05 -0500

MioRos gravatar image

updated 2011-10-23 05:26:36 -0500

kwc gravatar image

Hi,

I'm trying to install orocos_toolchain_ros on electric release following the instructions on your web page: sudo aptitude install ros-electric-orocos-toolchain ros-electric-rtt-ros-integration ros-electric-rtt-ros-comm ros-electric-rtt-common-msgs ros-electric-rtt-geometry

and the first error that I find is that the ros-electric -rtt-geometry package can't be found.

If I follow with the instructions avoiding this package, when I'm trying to do:

sudo git clone http://git.mech.kuleuven.be/robotics/rtt_ros_integration.git

I get the following errors: error: inflate: data stream error (incorrect header check) error: File 318458b05854f9a89b044e010a1738351bd6244a (http://git.mech.kuleuven.be/robotics/rtt_ros_integration.git/objects/a8/18ccadb911aa86a9120d25981d64abf102dd30) corrupt

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2011-10-20 22:09:40 -0500

MioRos gravatar image

updated 2011-11-18 05:37:17 -0500

Wim gravatar image

After running "sudo apt-get update" first, I can successfully install the Ubuntu packages running " sudo aptitude install ros-electric-orocos-toolchain ros-electric-rtt-ros-integration ros-electric-rtt-ros-comm ros-electric-rtt-common-msgs ros-electric-rtt-geometry"

However, I still can't install orocos_toolchain_ros from source using "sudo git clone http://git.mech.kuleuven.be/robotics/rtt_ros_integration.git"

Any idea ...?

edit flag offensive delete link more

Comments

I have the same problem when trying to install orocos_toolchain_ros from source. The best thing to do is to file a ticket on bugs.orocos.org.
Wim gravatar image Wim  ( 2011-11-18 05:38:48 -0500 )edit
Can you describe the problem in more detail? The 'data stream error' makes the git repository not check out correctly? Is it empty, or only partially there? Do you get any other error messages from git?
Steven Bellens gravatar image Steven Bellens  ( 2011-11-18 20:58:17 -0500 )edit
1

answered 2011-10-17 11:58:34 -0500

kwc gravatar image

Have you tried running "sudo apt-get update" first? The new rtt packages were only recently released and require an up-to-date apt index.

edit flag offensive delete link more

Comments

Ok. After running "sudo apt-get update" first, the first error is solved but not the second one. Any idea ...?
MioRos gravatar image MioRos  ( 2011-10-27 23:02:42 -0500 )edit
1

answered 2011-11-03 21:43:55 -0500

You can safely ignore this second error (inflate data stream), the GIT repository should be checkout out correctly anyway.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-10-13 23:18:05 -0500

Seen: 193 times

Last updated: Nov 18 '11