Ask Your Question
1

Ubuntu Lucid, cannot install ROS electric

asked 2011-10-07 23:57:15 -0500

Shiqian gravatar image

updated 2014-01-28 17:10:32 -0500

ngrennan gravatar image

the error message is like this:

Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  ros-electric-desktop-full: Depends: ros-electric-ros-tutorials (= 0.2.6-s1313715256~lucid) but it is not going to be installed
                             Depends: ros-electric-nodelet-core (= 1.6.0-s1313699788~lucid) but it is not going to be installed
                             Depends: ros-electric-geometry-tutorials (= 0.1.3-s1313715382~lucid) but it is not going to be installed
                             Depends: ros-electric-filters (= 1.6.0-s1313699862~lucid) but it is not going to be installed
                             Depends: ros-electric-slam-gmapping (= 1.2.3-s1317342644~lucid) but it is not going to be installed
                             Depends: ros-electric-stage (= 1.4.0-s1313712377~lucid) but it is not going to be installed
                             Depends: ros-electric-documentation (= 1.4.2-s1314918935~lucid) but it is not going to be installed
                             Depends: ros-electric-visualization (= 1.6.4-s1316797656~lucid) but it is not going to be installed
                             Depends: ros-electric-vision-opencv (= 1.6.1-s1313700748~lucid) but it is not going to be installed
                             Depends: ros-electric-perception-pcl (= 1.0.1-s1315517480~lucid) but it is not going to be installed
                             Depends: ros-electric-geometry-experimental (= 0.2.2-s1313712024~lucid) but it is not going to be installed
                             Depends: ros-electric-robot-model-visualization (= 0.1.2-s1313720142~lucid) but it is not going to be installed
                             Depends: ros-electric-rx (= 1.6.1-s1314995568~lucid) but it is not going to be installed
                             Depends: ros-electric-image-pipeline (= 1.6.1-s1314697348~lucid) but it is not going to be installed
                             Depends: ros-electric-simulator-gazebo (= 1.4.5-s1316581134~lucid) but it is not going to be installed
                             Depends: ros-electric-diagnostics-monitors (= 1.4.0-s1315002762~lucid) but it is not going to be installed
                             Depends: ros-electric-simulator-stage (= 1.4.0-s1313712506~lucid) but it is not going to be installed
                             Depends: ros-electric-geometry-visualization (= 0.1.1-s1315018274~lucid) but it is not going to be installed
                             Depends: ros-electric-image-common (= 1.6.0-s1313700642~lucid) but it is not going to be installed
                             Depends: ros-electric-bond-core (= 1.6.0-s1313699727~lucid) but it is not going to be installed
                             Depends: ros-electric-common-tutorials (= 0.1.2-s1313726273~lucid) but it is not going to be installed
                             Depends: ros-electric-ros-comm (= 1.6.2-s1313697791~lucid) but it is not going to be installed
                             Depends: ros-electric-visualization-common (= 1.6.2-s1316578083~lucid) but it is not going to be installed
                             Depends: ros-electric-driver-common (= 1.2.3-s1313700560~lucid) but it is not going to be installed
                             Depends: ros-electric-executive-smach (= 1.0.2-s1313706613~lucid) but it is not going to be installed
                             Depends: ros-electric-common-msgs (= 1.6.0-s1313699542~lucid) but it is not going to be installed
                             Depends: ros-electric-image-transport-plugins (= 1.4.1-s1313700830~lucid) but it is not going to be installed
                             Depends: ros-electric-xacro (= 1.6.0-s1313699925~lucid) but it is not going to be installed
                             Depends: ros-electric-robot-model (= 1.6.1-s1315358505~lucid) but it is not going to be installed
                             Depends: ros-electric-bullet (= 2.76.3-s1313700087~lucid) but it is not going to be installed
                             Depends: ros-electric-visualization-tutorials (= 0.2.3-s1316934842~lucid) but it is not going to be installed
                             Depends ...
(more)
edit retag flag offensive close merge delete

Comments

I am getting similar results trying to install Electric in 64 bit Natty. Thought it was just my machine configuration. Diamondback install correctly.
Thomas D gravatar imageThomas D ( 2011-10-08 02:49:59 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
2

answered 2011-10-08 04:09:27 -0500

joq gravatar image

Your configuration looks valid to me.

Sometimes the ROS Ubuntu package repository gets into an invalid state while being updated. If so, it should work again fairly soon. Be sure to update the package descriptions when retrying:

$ sudo apt-get update && sudo apt-get install ros-electric-desktop-full
edit flag offensive delete link more

Comments

now, i.e., 8 hours later, I still get the same error. Is it possible that in my system some packages are missing?
Shiqian gravatar imageShiqian ( 2011-10-08 08:41:10 -0500 )edit
I installed Ubuntu 2 days ago. so it is really a clean OS.
Shiqian gravatar imageShiqian ( 2011-10-08 08:42:58 -0500 )edit
I think you are right. the repository were "in a invalid state". Just now I tried it again and it works now. Great. Thanks.
Shiqian gravatar imageShiqian ( 2011-10-08 21:55:59 -0500 )edit
1

answered 2011-10-08 14:15:12 -0500

tfoote gravatar image
edit flag offensive delete link more

Comments

not really. the error message are different. mine starts from missing ros_tutorial; his error msg. starts from electric-eigen; and I don't have libpcl-1.1 libeigen3-dev packages installed at all. but thanks anyway.
Shiqian gravatar imageShiqian ( 2011-10-08 21:46:27 -0500 )edit
-1

answered 2011-10-08 21:57:13 -0500

Shiqian gravatar image

I guess we just need some more patient and wait until the repository is stable.

edit flag offensive delete link more

Comments

The repos are used regularly by many people. In particular Lucid Electric is one of our main development targets and is used regularly by many users.
tfoote gravatar imagetfoote ( 2011-10-10 10:47:26 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-10-07 23:57:15 -0500

Seen: 759 times

Last updated: Oct 08 '11