Ask Your Question
1

Depthimage-to-laser issue with scan output [closed]

asked 2013-12-27 06:48:03 -0500

rnunziata gravatar image

updated 2013-12-27 06:53:16 -0500

I am using depthimage-to-laser. Running as simulation in gazebo with kinetic plug-in. I get the following error. Any thoughts on the nature of this error and if this is a parameter issue.

Would I be better off using: pointcloud-to-laserscan?

[ WARN] [1388168330.681229897, 962.989000000]: Laser has to be mounted planar! Z-coordinate has to be 1 or -1, but gave: 0.20080
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by rnunziata
close date 2013-12-27 07:48:19

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-12-27 07:12:31 -0500

Athoesen gravatar image

I am unfamiliar with this particular device but it sounds like "Laser has to be mounted planar" is telling you that you've managed to locate it in an "illegal" location. It wants the scanner location somewhere in the z=1 or z=-1 plane and you've managed to simulate it elsewhere. Any way you can adjust?

edit flag offensive delete link more

Comments

Thanks ... I had the wrong frame specified

rnunziata gravatar image rnunziata  ( 2013-12-27 07:47:54 -0500 )edit

Where have you gone wrong in frame, how you fixed it, can you please elaborate.

Kishore Kumar gravatar image Kishore Kumar  ( 2016-01-21 10:02:08 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2013-12-27 06:48:03 -0500

Seen: 213 times

Last updated: Dec 27 '13