Ask Your Question
1

rviz sensor data does not rotate

asked 2011-09-12 06:34:43 -0500

redbaron148 gravatar image

updated 2011-09-14 05:41:21 -0500

kwc gravatar image

Hello, I've been using ROS for quite a while now, and I recently upgraded from cturtle to electric (skipped diamondback). I started with a fresh install of 11.04 64 bit on an i7 iMac 2010 model. I followed the instructions for a generic install, using apt-get with ros.

rviz does not let me rotate any of the sensor data I have access too in it's window, it shows the data, but rotating the display does not rotate the data itself. My transforms are setup correctly (the most basic of transforms from base_link to laser, 0,0,0,0,0,0). I'm viewing just a laser scan data type. Another odd behavior I viewed was the first time I started rviz on two different installs of ros it had no grid by default (which was not the case on cturtle) and when I tried to add a grid, there were no data types listed as available. Once I restarted rviz the data types showed up in the data types list. Possibly related.

The same happens for Kinect data, I can view the point cloud in the rviz window, but I cannot change the orientation of the point cloud.

I tried reinstalling ros, installing diamondback, installing via svn.

If I had more karma I would upload some screen captures.

I have no idea what the problem is and I would appreciate any help I could get. Please let me know if I need to include more information.

edit retag flag offensive close merge delete

Comments

Does anything rotate? Does the grid rotate? Does a robot model rotate? Point clouds are rendered a bit differently than other data types, so I need to know if you are failing to rotate at all or just point clouds. What happens when you rotate? Does new point cloud data show up rotated?
hersh gravatar imagehersh ( 2011-09-12 08:32:05 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2011-09-13 07:20:10 -0500

hersh gravatar image

This question is a duplicate of http://answers.ros.org/question/2041/openni_kinect-rviz-display-error-pointcloud2-is which you asked a month ago.

This looks like a bug in rviz and/or a lack of support for your graphics hardware. You should probably file a bug against rviz. Use this wiki section for info on how to make a usable bug report: how to make a usable bug report.

Thanks.

edit flag offensive delete link more
0

answered 2011-09-13 08:21:06 -0500

redbaron148 gravatar image

OK, Thanks, I posted it under different tags because I realized it was an rviz issue and not a kinect issue and thought it needed different background. I'll take my other post down.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-09-12 06:34:43 -0500

Seen: 361 times

Last updated: Sep 13 '11