ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
0

Kinect Openni build errors - XnDeviceSensorV2

asked 2011-10-07 15:12:44 -0500

Vinayak gravatar image

updated 2016-10-24 09:03:29 -0500

ngrennan gravatar image

Hey,

When I was trying to install the Openni for kinect, I ran into a build error

make[3]: * [../../Bin/Release/libXnDeviceSensorV2.so] Error 1 make[3]: Leaving directory /home/vin/drivers/ps_engine/build/ps_engine/Platform/Linux-x86/Build/XnDeviceSensorV2' make[2]: * [XnDeviceSensorV2] Error 2 make[2]: Leaving directory/home/vin/drivers/ps_engine/build/ps_engine/Platform/Linux-x86/Build' make[1]: [installed] Error 2 make[1]: Leaving directory `/home/vin/drivers/ps_engine' make: ** [ps_engine_lib] Error 2

Could somebody help me with this? I've asked this before a couple of days back but received no reply!

Thanks a lot!

edit retag flag offensive close merge delete

Comments

Hi, pls mention how you are trying to install the openni and links that you followed. Also post the errors in code format, which makes it easy to analyse. The errors in the above case are incomplete, it just tells that the make has failed but not y. So pls post the line that describes the error.
karthik gravatar imagekarthik ( 2011-10-08 00:14:11 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2011-10-12 22:47:35 -0500

karthik gravatar image

updated 2011-10-13 08:22:06 -0500

Hi Vinayak, I got this issue resolved when i removed

fix-mac-arch

(Just comment it #fix-mac-arch)

in the Makefiles of both openni and ps_engine in the drivers folder. It should work. This is the fix done for the Mac OS, so not used in Ubuntu version (Hoping you are working on ubuntu).

After this you might get an error in making nite. Where it might fail because of the proxy config in your wgetrc. Solution for that would be to set the proxy or to download the package mentioned in the nite's Makefile manually and compile it.

Hope this helps. Karthik

edit flag offensive delete link more
0

answered 2016-06-20 00:11:18 -0500

vinmean gravatar image

I also had this problem. Initially I was trying to use the driver from avin2 repository. But this one worked for me.

git clone git://github.com/ph4m/SensorKinect.git

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-10-07 15:12:44 -0500

Seen: 1,362 times

Last updated: Jun 20 '16