Ask Your Question
0

getting type error on nav topic from move base.

asked 2013-12-13 07:55:25 -0500

rnunziata gravatar image

updated 2013-12-14 08:25:00 -0500

Update: So I think my question is if ekf is a combined odometry why does move base not accept it in its published type , as a pose. How would I use the combined odometry if not in move base. Is this what the RoadMap part of the ekf webpage is talking about,yes?

Any ideas on what this error is means? Is this ekf node?

[ERROR] [1386956256.093192603, 0.774000000]: Client [/move_base] wants topic /rrbot_combined_odom/odom to have datatype/md5sum [nav_msgs/Odometry/cd5e73d190d741a2f92e81eda573aca7], but our version has [geometry_msgs/PoseWithCovarianceStamped/953b798c0f514ff060a53a3498ce6246]. Dropping connection.

my launch file is:

<launch>

  <!-- Use simulation time from gazebo -->
  <rosparam param="use_sim_time=true"/>

  <!-- Load robot description here ; used by rviz / rqt_gui -->
  <param name="robot_description" 
              command="$(find xacro)/xacro.py '$(find rrbot_description)/urdf/rrbot.xacro'" />

  <node pkg="tf" type="static_transform_publisher" name="link1_broadcaster" 
                 args="-.1 0 .1 0 0 0  base_link tower_link 10" />
  <node pkg="tf" type="static_transform_publisher" name="link2_broadcaster" 
                 args="-.1 0 .2 0 0 0  tower_link hokuyo_frame 10" />
  <node pkg="tf" type="static_transform_publisher" name="link3_broadcaster" 
                 args="-.1 0 .2 -1.57 0 -1.57  tower_link camera_frame 10" />
  <node pkg="tf" type="static_transform_publisher" name="link4_broadcaster" 
                 args="-.13 -.13 .1 0 0 0  base_link left_wheel 10" />
  <node pkg="tf" type="static_transform_publisher" name="link5_broadcaster" 
                 args="-.13  .13 .1 0 0 0  base_link right_wheel 10" />



  <!-- Start rqt : note rrbot.rviz file must reside in launch dir -->
  <node name="rqt_gui" pkg="rqt_gui" type="rqt_gui" respawn="true">
  </node>

  <!-- load the controllers -->
  <!-- and Load joint controller configurations from YAML file to parameter server -->
  <rosparam file="$(find rrbot_control)/config/rrbot_control.yaml" command="load"/>
  <node name="controller_spawner" pkg="controller_manager" type="spawner" respawn="true"
    output="screen" ns="/rrbot" args="--namespace=/rrbot
                      joint1_position_controller
                      joint2_position_controller"/>

  <!-- ******************************************************************************************** -->



  <!-- start mapping server and  pass odom frame : creates map from laser -->
  <node name="gmapping_node" pkg="gmapping" type="slam_gmapping"  output="screen" respawn="true">
   <param name="occ_thresh"  value="0.05"/>
   <param name="map_update_interval"  value="0.05"/> 
  </node>


  <!-- Moves robot based on goal command : Listen for goals posted as twist to robot base -->
  <node pkg="move_base" type="move_base" name="move_base" output="screen" respawn="true">
    <param name="controller_frequency" type="double" value="50.0" />
    <rosparam file="$(find rrbot_control)/config/move_base/costmap_common_params.yaml" 
              command="load" ns="global_costmap" />
    <rosparam file="$(find rrbot_control)/config/move_base/costmap_common_params.yaml" 
              command="load" ns="local_costmap" />
    <rosparam file="$(find rrbot_control)/config/move_base/local_costmap_params.yaml" 
              command="load"/>
    <rosparam file="$(find rrbot_control)/config/move_base/global_costmap_params.yaml" 
              command="load"/>
    <rosparam file="$(find rrbot_control)/config/move_base/base_local_planner_params.yaml" 
              command="load"/>
    <remap from="odom" to="/rrbot_combined_odom/odom"/>
  </node>

  <!-- Take gazebo model state and setup map-odom-base_link-senors transforms -->
  <node pkg="rrbot_control" type="robot_odometry" name="rrbot_odometry" output="screen" respawn="true"/>

  <node pkg="robot_pose_ekf" type="robot_pose_ekf" name="rrbot_combined_odom">
    <param name="output_frame" value="odom"/>
    <param name="freq" value="10.0"/>
    <param name="sensor_timeout" value="1.0"/>
    <param name="odom_used" value="true"/>
    <param name="vo_used" value="false"/>
    <param name="imu_used" value="true"/>
    <param name="debug" value="true"/>
    <param name="self_diagnose" value="true"/>
    <remap from="imu_data" to="/rrbot/imu_data"/>
  </node>

</launch>
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-12-15 02:23:22 -0500

rnunziata gravatar image

I added a translation of the odom_combined from a PoseWithCovarienceStamped to navigation odometry.

edit flag offensive delete link more

Comments

Hi munziata, can you tell us how do you add a translation of the odom_combined from a PoseWithCovarienceStamped to sensor_msgs/Odometry? Thanks in advance and best regards.

yalan gravatar imageyalan ( 2017-10-16 07:41:45 -0500 )edit

Sorry .... that project is long gone now....I did not save the code.

rnunziata gravatar imagernunziata ( 2017-10-16 14:15:04 -0500 )edit
-1

answered 2014-11-04 02:30:22 -0500

ASoriano gravatar image

Hi munziata, can you tell us how do you add a translation of the odom_combined from a PoseWithCovarienceStamped to sensor_msgs/Odometry? Thanks in advance and best regards.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-12-13 07:55:25 -0500

Seen: 370 times

Last updated: Dec 15 '13