Ask Your Question
0

Failed to display hokuyo node message on Rviz in Virtual machine.

asked 2011-08-22 16:49:55 -0500

sam gravatar image

updated 2011-09-14 05:41:46 -0500

kwc gravatar image

I use parallel Desktop 6.0 on macbook to install ubuntu 11.04.

I run the following instructions:

  rosrun hokuyo_node hokuyo_node
  rosrun rviz rviz -d `rospack find hokuyo_node`/hokuyo_test.vcg

result:

image description

Orbit views:

image description image description

Obviously it is not correct. Because the laser data point is not only a line.

When I try the same laser range finder at the other computer,it works normal.

Like this screen shot:

image description

How to fixed it?

Thank you~

edit retag flag offensive close merge delete

Comments

Can you clarify what exactly is incorrect about what you see? I'm having trouble from the screenshot.
mjcarroll gravatar image mjcarroll  ( 2011-08-23 09:36:28 -0500 )edit
I have updated the original post to add the normal picture of laser range finder.
sam gravatar image sam  ( 2011-08-23 13:50:02 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2011-09-13 07:56:43 -0500

hersh gravatar image

This looks to me like an instance of the bug described here, where point clouds are not being rotated correctly.

The other reporter was also running Ubuntu on a Mac.

edit flag offensive delete link more
1

answered 2011-08-23 13:53:17 -0500

Eric Perko gravatar image

Try changing the view dropdown to "orbit" and rotating the camera around the laser's origin. Looks to me like in your first image the camera is in the same plane as the laser, but in the second the camera is giving you a top down view of the data. "Orbit" mode will let you change the camera angles and see if that makes a difference.

edit flag offensive delete link more

Comments

Ah, okay, I see what he was referring to as "wrong" now. I think that it's just an orbit issue as well. I have had no issues with Parallels/Natty/Snow Leopard that I can think of.
mjcarroll gravatar image mjcarroll  ( 2011-08-23 14:47:54 -0500 )edit
I updated the original post, and I have changed to orbit views,but the result is the same.
sam gravatar image sam  ( 2011-08-23 16:16:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-08-22 16:49:55 -0500

Seen: 737 times

Last updated: Sep 13 '11