Ask Your Question
0

Compiling Rosrecord fails, Boost path problem.

asked 2011-08-16 18:05:39 -0500

eca gravatar image

updated 2011-08-16 19:33:27 -0500

I followed these instructions by davids. Essentially symlinking and exporting new path to get around python3 troubles, and then rosinstall ...desktop(tried using gcc45 also). I have boost 1.47 in /usr/lib. The problem is filesystem-mt not being in 1.47, Rosrecord fails with:

mkdir -p bin
cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=`rospack find rosbuild`/rostoolchain.cmake  ..
[rosbuild] Building package rosrecord
[rosbuild] Including /home/eca/ros/ros_comm/clients/roslisp/cmake/roslisp.cmake
[rosbuild] Including /home/eca/ros/ros_comm/clients/rospy/cmake/rospy.cmake
[rosbuild] Including /home/eca/ros/ros_comm/clients/cpp/roscpp/cmake/roscpp.cmake
CMake Error at /home/eca/ros/ros/core/rosbuild/public.cmake:888 (message):
  [rosboost-cfg --libs iostreams,system,filesystem-mt] failed with error:
  Traceback (most recent call last):

    File "/home/eca/ros/ros/bin/rosboost-cfg", line 35, in <module>
      rosboost_cfg.main()
    File "/home/eca/ros/ros/tools/rosboost_cfg/src/rosboost_cfg/rosboost_cfg.py", line 347, in main
      output = libs(ver, options.libs.split(','))
    File "/home/eca/ros/ros/tools/rosboost_cfg/src/rosboost_cfg/rosboost_cfg.py", line 283, in libs
      print >> s, find_lib(ver, lib, True),
    File "/home/eca/ros/ros/tools/rosboost_cfg/src/rosboost_cfg/rosboost_cfg.py", line 246, in find_lib
      raise BoostError('Could not locate library [%s] in lib directory [%s]'%(name, dir))

  rosboost_cfg.rosboost_cfg.BoostError: 'Could not locate library
  [filesystem-mt] in lib directory [/usr/lib]'

Call Stack (most recent call first):
  CMakeLists.txt:15 (rosbuild_link_boost)


-- Configuring incomplete, errors occurred!
make: *** [all] Error 1
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-08-16 19:34:55 -0500

eca gravatar image

Symlinking libboost_filesystem.so.1.47.0 to libboost_filesystem-mt.so worked.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-08-16 18:05:39 -0500

Seen: 368 times

Last updated: Aug 16 '11