Ask Your Question
0

Installing WebUI with proper Environmental Variables

asked 2011-07-24 07:46:09 -0500

David Lu gravatar image

I'm trying to install the web interface on my laptop. I've gotten things to work after a little tweaking (which I updated on the wiki), so that I get through the whole installation process.

However, when I open a browser, I get this error message.

MOD_PYTHON ERROR

ProcessId: 6630 Interpreter: '127.0.0.1'

ServerName: '127.0.0.1' DocumentRoot: '/var/www'

URI: '/webui/' Location: '/webui/' Directory: None Filename: '/var/www/webui' PathInfo: '/'

Phase: 'PythonHandler' Handler: 'startmod'

Traceback (most recent call last):

File "/usr/lib/python2.6/dist-packages/mod_python/importer.py", line 1537, in HandlerDispatch default=default_handler, arg=req, silent=hlist.silent)

File "/usr/lib/python2.6/dist-packages/mod_python/importer.py", line 1229, in _process_target result = _execute_target(config, req, object, arg)

File "/usr/lib/python2.6/dist-packages/mod_python/importer.py", line 1128, in _execute_target result = object(arg)

File "/opt/ros/diamondback/stacks/web_interface/webui/src/webui/startmod.py", line 18, in handler ros_root = os.environ['ROS_ROOT']

File "/usr/lib/python2.6/UserDict.py", line 22, in __getitem__ raise KeyError(key)

KeyError: 'ROS_ROOT'

Clearly, ROS_ROOT is not being set properly. Any ideas where to set this variable so that the Webui picks up on it? Currently, I believe it is being set through setup.bash.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2011-07-24 10:39:41 -0500

Peter Heim gravatar image

Hi David I got it to work i had to stop apache from starting at boot after i launched webui from webui directory i could log on using localhost:9090 the web directory in in /tmp

peter

edit flag offensive delete link more

Comments

Stopping apache and then relaunching the webui fixed the problem.
David Lu gravatar imageDavid Lu ( 2011-07-24 12:33:24 -0500 )edit
0

answered 2013-08-12 21:30:34 -0500

da-na gravatar image

Hi there!

I'm experiencing the same problem, but stopping apache with command

apachectl -k stop

and relaunching webui with command

roslaunch webui webui.launch

does not work in my case - the page http://localhost/webui/webui/ is not available.

I tried http://localhost:9090/ but then I have to login and write a password (and I haven't set any).

edit flag offensive delete link more
0

answered 2011-09-13 10:15:16 -0500

mkopack gravatar image

Did you remember to set it in the ROS_ROOT file as per the directions?

You have to create a number of files in /etc/ros/env:

ROBOT ROBOT_NAME ROS_ROOT ROS_MASTER_URI ROS_PACKAGE_PATH

From what I can tell, you just have to create each file with that name (you'll need to sudo vi <filename> to create them) and just put a single line containing the value of that variable as the first line... So for my ROS_ROOT, I put: /opt/ros/electric/ros

Hope this helps!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-07-24 07:46:09 -0500

Seen: 428 times

Last updated: Aug 12 '13