Ask Your Question
1

ros-hydro-desktop-full installs gazebo-current instead of gazebo

asked 2013-11-16 09:17:54 -0600

Angus gravatar image

updated 2013-11-16 09:19:13 -0600

According to the gazebosim wiki, version 1.9.x of gazebo should be installed when ros hydro is installed but for reasons unknown I'm getting gazebo-current (i.e. version 2.x.y) installed. Any idea why?

I'm entering:

sudo apt-get install ros-hydro-desktop-full

and the output is:

The following NEW packages will be installed:
gazebo-current ...

I've also had gazebo-current install earlier but have since removed it.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
4

answered 2013-11-19 12:56:37 -0600

hsu gravatar image

It boils down to the fact that there are two debian repositories (ROS and OSRF) offering different versions of gazebo_ros_pkgs and gazebo / gazebo-current.

ROS Repository:

  • provides gazebo 1.9.x and gazebo_ros_pkgs 2.3.x for hydro as ros-hydro-gazebo-ros-pkgs.

OSRF Repository (this was created for DRCSim and for testing gazebo_ros_pkgs against newer versions of gazebo):

  • provides gazebo 1.9 and gazebo-current 2.1
  • provides gazebo_ros_pkgs 2.4.x for hydro as ros-hydro-gazebo-ros-pkgs that depends on gazebo-current 2.1.

To make sure you do not end up installing the version of ros-hydro-gazebo-ros-pkgs 2.4.x that uses gazebo-current, remove /etc/apt/sources.list.d/gazebo-latest.list or /etc/apt/sources.list.d/osrf*.list or comment out its content:

# deb http://packages.osrfoundation.org/gazebo/ubuntu [quantal/precise/...] main

Then remove gazebo-ros-pkgs and gazebo, update and reinstall:

sudo apt-get remove gazebo-current ros-hydro-gazebo-ros-pkgs
sudo apt-get update
sudo apt-get install ros-hydro-[...]

Note that we are in the process of renaming ros-hydro-gazebo-pkgs 2.4.x in OSRF repo to ros-hydro-gazebo-pkgs-current to avoid confusions.

John

edit flag offensive delete link more
0

answered 2013-11-16 18:30:41 -0600

Angus gravatar image

updated 2013-11-16 18:31:59 -0600

My solution was to first install gazebo (version 1.9.x) via sudo apt-get install gazebo, then do a sudo aptitude install ros-hydro-desktop-full and one of the installation alternatives was to keep the current gazebo simulator version rather than installing gazebo-current. So in that sense, it's solved :-)

Just for curiosity though, I'm still unsure why the package list for apt-get install would be affected by the files on my computer. Shouldn't it be pulling that list from a server? Why would it be different depending on which computer I'm using? If anyone cares to explain or point me to an explanation, I'd be very grateful.

edit flag offensive delete link more

Comments

" one of the installation alternatives was to keep the current gazebo simulator version rather than installing gazebo-current." How did you initialize the installation alternative?

Quadrobo gravatar imageQuadrobo ( 2013-11-19 07:52:21 -0600 )edit

After the "sudo aptitude install ... " command, the terminal came back with a list of changes to packages, including installing some, deleting some and leaving some alone and asked "Accept this solution?". I just entered "no" until it offered to keep the already installed gazebo package while installing the rest of ros.

Angus gravatar imageAngus ( 2013-11-19 12:16:59 -0600 )edit

Install: 1) ros-hydro-gazebo-plugins [2.3.3-0precise ...] 2) ros-hydro-gazebo-ros [2.3.3-0precise...] Keep at their current version: 1) gazebo-current [Not Installed] 2) .... Is this the version that I am suppose to look for?

Quadrobo gravatar imageQuadrobo ( 2013-11-20 04:55:13 -0600 )edit

That looks about right, but I'm not 100% sure. Can you test it out?

Angus gravatar imageAngus ( 2013-11-20 09:20:04 -0600 )edit

I have tried and it works. Many thanks for help.

Quadrobo gravatar imageQuadrobo ( 2013-11-21 03:27:03 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-11-16 09:17:54 -0600

Seen: 1,205 times

Last updated: Nov 19 '13