Ask Your Question
1

error met when rosmake openni_kinect

asked 2011-05-20 03:31:36 -0500

walonchiu gravatar image

Hello, I met a big problem when I want to rosmake the openni_kinect package. The following is the printed-out msg during the rosmake procedure. Could anyone help me out of this problem? Really appreciate!

walon@walon-ROS:~/ros/drivers$ rosmake openni_kinect --rosdep-install [ rosmake ] Packages requested are: ['openni_kinect']
[ rosmake ] Logging to directory/home/walon/.ros/rosmake/rosmake_output-20110520-172547
[ rosmake ] Expanded args ['openni_kinect'] to: ['openni_camera_unstable', 'openni_camera', 'openni_tracker', 'nite', 'openni']
[ rosmake ] Generating Install Script using rosdep then executing. This may take a minute, you will be prompted for permissions. . .
rosdep executing this script: {{{ set -o errexit #Packages sudo apt-get install python-wxgtk2.8 openni-dev python-sip4-dev ps-engine libqhull-dev nite-dev libcppunit-dev libhdf5-serial-dev libgraphicsmagick++1-dev }}} [sudo] password for walon: Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: nite-dev: Depends: openni-dev (= 0.1.0~lucid) but 1.1.0.41-3+lucid1 is to be installed [ rosmake ] rosdep install failed: rosdep script failed with stderr {{{ E: Broken packages

}}}

edit retag flag offensive close merge delete

Comments

Hm, package conflicts. "sudo apt-get update" could help you, but I guess not...
Felix Endres gravatar image Felix Endres  ( 2011-05-22 20:44:31 -0500 )edit
Actually the version of openni-dev now is 1.1.0.41-3+lucid1. But for installing nite-dev, it request for the openni-dev (= 0.1.0~lucid). So I guess I should find out the older version of openni-dev... But I cant find out one.
walonchiu gravatar image walonchiu  ( 2011-05-23 03:49:51 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-05-23 20:01:27 -0500

Here is the state of packages I use (on ubuntu 10.10). Maybe you can force the versions manually (e.g. apt-get install packagename=packageversion)

Package: libcppunit-dev            Version: 1.12.1-1build1
Package: python-sip4-dev           Version: 4.10.5-0ubuntu1
Package: libgraphicsmagick++1-dev  Version: 1.3.12-1
Package: libhdf5-serial-dev        Version: 1.8.4-patch1-2ubuntu1
Package: libqhull-dev              Version: 2009.1-1
Package: python-wxgtk2.8           Version: 2.8.11.0-0ubuntu4
Package: nite-dev                  Version: 0.0.2~maverick
Package: openni-dev                Version: 0.0.2~maverick
Package: ps-engine                 Version: 0.0.2~maverick
Package: python-wxgtk2.8           Version: 2.8.11.0-0ubuntu4.1

The backup solution would be to compile openni_kinect from source yourself. If you want to try that, checkout the mercurial repository somewhere into a directory you add(ed) to the front of your ROS_PACKAGE_PATH:

hg checkout https://kforge.ros.org/openni/openni_ros
rosmake openni_ros

There will be no version conflicts then, but you'd still need to install all requirements.

edit flag offensive delete link more

Comments

Thank you! Felix! It does solve the problem!
walonchiu gravatar image walonchiu  ( 2011-05-23 20:12:38 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-05-20 03:31:36 -0500

Seen: 305 times

Last updated: May 23 '11