Ask Your Question

Uwe's profile - activity

2020-06-02 05:09:08 -0500 received badge  Famous Question (source)
2020-05-27 09:47:22 -0500 commented answer rtabmap_ros, navigation simulation on prerecorded map, pathplanning

Sry, I thougth _database_path should be my Path to the map I created and map.db the name of the map itself. It gave me

2020-05-27 09:44:23 -0500 commented answer rtabmap_ros, navigation simulation on prerecorded map, pathplanning

Sry, I thougth _database_path should be my Path to the map I created and map.db the name of the map itself. It gave me

2020-05-27 06:02:19 -0500 commented answer rtabmap_ros, navigation simulation on prerecorded map, pathplanning

Sry, I thougth _database_path should be my Path to the map I created and map.db the name of the map itself. It gave me

2020-05-27 05:58:43 -0500 commented answer rtabmap_ros, navigation simulation on prerecorded map, pathplanning

Sry, I thougth _database_path should be my Path to the map I created and map.db the name of the map itself. It gave me

2020-05-26 12:05:58 -0500 commented answer rtabmap_ros, navigation simulation on prerecorded map, pathplanning

I reinstalled rtabmap and rtabmap_ros from source. After entering: rosrun rtabmap_ros rtabmap --Mem/IncrementMemory fal

2020-05-23 09:17:29 -0500 received badge  Popular Question (source)
2020-05-23 08:53:06 -0500 edited question rtabmap_ros, navigation simulation on prerecorded map, pathplanning

rtabmap_ros, navigation simulation on prerecorded map, pathplanning Hi, Im fairly new to ros and after a forced break o

2020-05-21 12:48:30 -0500 commented answer rtabmap_ros, navigation simulation on prerecorded map, pathplanning

Thank you for your fast reply! I get following error while trying this: error while loading shared libraries: librtabm

2020-05-18 09:06:42 -0500 asked a question rtabmap_ros, navigation simulation on prerecorded map, pathplanning

rtabmap_ros, navigation simulation on prerecorded map, pathplanning Hi, Im fairly new to ros and after a forced break o

2020-05-12 05:43:24 -0500 received badge  Popular Question (source)
2020-05-02 15:52:41 -0500 asked a question For what do I need data association like SSD, if I already use a deskriptor like BRIEF?

For what do I need data association like SSD, if I already use a deskriptor like BRIEF? Hi, I'm not sure if this will e

2020-04-30 02:04:09 -0500 commented answer Why can't rtabmap_ros access the published zed camera topics?

Thank you, I will try this as soon as I can return to the robot.

2020-04-30 02:04:09 -0500 received badge  Commentator
2020-04-29 10:20:26 -0500 commented answer Why can't rtabmap_ros access the published zed camera topics?

Rviz can catch the topics and i can display the pointcloud with it but rtabmap still dosent recieve any topics. I pretty

2020-03-13 06:03:55 -0500 edited question Why can't rtabmap_ros access the published zed camera topics?

Why can't rtabmap_ros access the published zed camera topics? Hi, I'm new to ROS and currently working on using rtabmap

2020-03-13 06:03:55 -0500 received badge  Editor (source)
2020-03-12 05:28:22 -0500 commented answer rtabmap_ros tutorial zed_stereo_throttle.launch gives unused args error

Thanks that solved the error, though I got some other issues which leaded me to reinstall rtabmap.

2020-03-12 05:27:22 -0500 marked best answer rtabmap_ros tutorial zed_stereo_throttle.launch gives unused args error

At the moment I'm trying to use remote mapping on a robot with a jetson tx2 and a laptop with ubuntu 16.04. Both run with ros kinetic.

Following this tutorial http://wiki.ros.org/rtabmap_ros/Tutor... I build the throttle launch file on the jetson and recieved the following error.

~/catkin_ws$ roslaunch zed_wrapper zed_stereo_throttle.launch 
... logging to /home/nvidia/.ros/log/03f8b8c0-5fa8-11ea-bbd6-b0fc36b76f7b/roslaunch-tegra-ubuntu-5544.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

unused args [resolution, publish_tf, frame_rate] for include of [/home/nvidia/catkin_ws/src/zed-ros-wrapper/zed_wrapper/launch/zed_camera_nodelet.launch]
The traceback for the exception was written to the log file

I'm kinda lost here because looking at the code for the nodelet I can clearly see the args used. Does someone have any idea as of to what I did wrong?

Thank you in advandce and for reading this.

Edit: Thanks to matlabbes awnser I could start the launch file, but get this enourmus error message:

nvidia@tegra-ubuntu:~$ roslaunch zed_wrapper zed_stereo_throttle.launch
... logging to /home/nvidia/.ros/log/a53abca6-638b-11ea-9403-00187daf6704/roslaunch-tegra-ubuntu-4469.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://192.168.0.15:41020/

SUMMARY
========

PARAMETERS
 * /camera/stereo_sync/approx_sync: False
 * /camera/stereo_sync/compressed_rate: 5.0
 * /camera/zed_description: <?xml version="1....
 * /camera/zed_node/auto_exposure: True
 * /camera/zed_node/camera_model: zed
 * /camera/zed_node/confidence: 100
 * /camera/zed_node/depth/confidence_root: confidence
 * /camera/zed_node/depth/depth_stabilization: 1
 * /camera/zed_node/depth/depth_topic_root: depth
 * /camera/zed_node/depth/disparity_topic: disparity/dispari...
 * /camera/zed_node/depth/min_depth: 0.3
 * /camera/zed_node/depth/openni_depth_mode: 0
 * /camera/zed_node/depth/point_cloud_topic_root: point_cloud
 * /camera/zed_node/depth/quality: 1
 * /camera/zed_node/depth/sensing_mode: 0
 * /camera/zed_node/exposure: 100
 * /camera/zed_node/gain: 100
 * /camera/zed_node/general/base_frame: base_link
 * /camera/zed_node/general/camera_flip: False
 * /camera/zed_node/general/camera_frame: zed_camera_center
 * /camera/zed_node/general/frame_rate: 30
 * /camera/zed_node/general/gpu_id: -1
 * /camera/zed_node/general/left_camera_frame: zed_left_camera_f...
 * /camera/zed_node/general/left_camera_optical_frame: zed_left_camera_o...
 * /camera/zed_node/general/resolution: 2
 * /camera/zed_node/general/right_camera_frame: zed_right_camera_...
 * /camera/zed_node/general/right_camera_optical_frame: zed_right_camera_...
 * /camera/zed_node/general/self_calib: True
 * /camera/zed_node/general/serial_number: 0
 * /camera/zed_node/general/svo_compression: 4
 * /camera/zed_node/general/verbose: True
 * /camera/zed_node/general/zed_id: -1
 * /camera/zed_node/mapping/fused_pointcloud_freq: 1.0
 * /camera/zed_node/mapping/mapping_enabled: False
 * /camera/zed_node/mapping/resolution: 1
 * /camera/zed_node/mat_resize_factor: 1.0
 * /camera/zed_node/max_depth: 20.0
 * /camera/zed_node/point_cloud_freq: 10.0
 * /camera/zed_node/stream: 
 * /camera/zed_node/svo_file: 
 * /camera/zed_node/tracking/fixed_cov_value: 1e-6
 * /camera/zed_node/tracking/fixed_covariance: False
 * /camera/zed_node/tracking/fixed_z_value: 1.0
 * /camera/zed_node/tracking/floor_alignment: False
 * /camera/zed_node/tracking/init_odom_with_first_valid_pose: True
 * /camera/zed_node/tracking/initial_base_pose: [0.0, 0.0, 0.0, 0...
 * /camera/zed_node/tracking/map_frame: map
 * /camera/zed_node/tracking/odometry_db: 
 * /camera/zed_node/tracking/odometry_frame: odom
 * /camera/zed_node/tracking/odometry_topic: odom
 * /camera/zed_node/tracking/path_max_count: -1
 * /camera/zed_node/tracking/path_pub_rate: 2.0
 * /camera/zed_node/tracking/pose_topic: pose
 * /camera/zed_node/tracking/publish_map_tf: False
 * /camera/zed_node/tracking/publish_pose_covariance: True
 * /camera ...
(more)
2020-03-12 05:27:22 -0500 received badge  Scholar (source)
2020-03-11 09:13:22 -0500 received badge  Notable Question (source)
2020-03-11 07:40:33 -0500 commented answer Why can't rtabmap_ros access the published zed camera topics?

Now a router is the rosmaster and connects the jetson and the laptop, but the problem persists.

2020-03-11 07:36:16 -0500 edited question rtabmap_ros tutorial zed_stereo_throttle.launch gives unused args error

rtabmap_ros tutorial zed_stereo_throttle.launch gives unused args error At the moment I'm trying to use remote mapping o

2020-03-09 05:04:57 -0500 received badge  Enthusiast
2020-03-07 12:39:30 -0500 commented answer Why can't rtabmap_ros access the published zed camera topics?

Yes, I agree this would be better. At the moment I'm not able to change that circumstance, due to other partys working o

2020-03-07 12:33:40 -0500 asked a question rtabmap_ros tutorial zed_stereo_throttle.launch gives unused args error

rtabmap_ros tutorial zed_stereo_throttle.launch gives unused args error At the moment I'm trying to use remote mapping o

2020-03-07 11:38:06 -0500 commented answer Why can't rtabmap_ros access the published zed camera topics?

The example you sended me ist the zed example which dosen't work for remote mapping, or does it? I wish to start the cam

2020-03-07 11:37:45 -0500 commented answer Why can't rtabmap_ros access the published zed camera topics?

The example you sended me ist the zed example which dosen't work for remote mapping, oor does it? I wish to start the ca

2020-03-05 12:22:30 -0500 commented answer Why can't rtabmap_ros access the published zed camera topics?

I also tried to turn "approx_sync" true, but it didn't change the outcome. It just erased the sentence from the error ou

2020-03-04 11:48:47 -0500 commented answer Why can't rtabmap_ros access the published zed camera topics?

Sry for replying so late. At the moment I'm just trying to run rtabmap on the jetson an drive the robot via remote contr

2020-03-02 16:07:00 -0500 received badge  Popular Question (source)
2020-02-28 04:42:20 -0500 commented answer Why can't rtabmap_ros access the published zed camera topics?

Hey, thank you for your fast reply. I will try this asap. I think I still misunderstand something about the frames. D

2020-02-28 04:39:37 -0500 received badge  Supporter (source)
2020-02-26 10:35:22 -0500 commented question Why can't rtabmap_ros access the published zed camera topics?

I fixed the AF_INET Error by following http://wiki.ros.org/ROS/NetworkSetup

2020-02-26 10:35:22 -0500 asked a question Why can't rtabmap_ros access the published zed camera topics?

Why can't rtabmap_ros access the published zed camera topics? Hi, I'm new to ROS and currently working on using rtabmap