ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question

Ampers4nd's profile - activity

2014-04-28 18:49:06 -0600 received badge  Famous Question (source)
2013-05-31 06:51:21 -0600 received badge  Student (source)
2013-05-31 06:50:03 -0600 received badge  Notable Question (source)
2013-05-29 09:50:00 -0600 received badge  Popular Question (source)
2013-05-26 14:07:52 -0600 commented question Ogre fails to build on Mac OS 10.8.3 during rosdep install

It seems I can add the links here:-) This is a link to the rosdep install output, also posted as a gist: https://gist.github.com/Ampers4nd/5654513

2013-05-26 14:04:52 -0600 commented question Ogre fails to build on Mac OS 10.8.3 during rosdep install

This is the gist for the brew ticket, which contains the verbose output of the brew install command: https://gist.github.com/Ampers4nd/5651663

2013-05-26 14:03:42 -0600 asked a question Ogre fails to build on Mac OS 10.8.3 during rosdep install

I am trying to install ROS using the homebrew based directions found on the main site (I can't publish links).

I am doing the (recommended) Desktop install, and I am running to problems at the resolving dependencies step. Specifically, the 'brew install ogre' is failing. I filed a ticket with Homebrew, but it seems that they don't support the ogre brew formula.

I want to post the output of the rosdep command as well as a link to the gist that I created for a brew ticket, but I am completely hamstrung by my the wiki's refusal to post links. So I'll just post the tail of the output and hope that I can somehow pass the relevant information as a response to someone's comments. I appreciate your help, and please let me know what else you'd like to see. Thanks!

rosdep install --from-paths src --ignore-src --rosdistro groovy -y

i've removed a bunch of stuff b/c the wiki thinks I'm posting links...

==> cmake -DCMAKE_OSX_ARCHITECTURES='x86_64' -DOGRE_BUILD_PLUGIN_CG=OFF -DCMAKE_INSTALL_PREFIX=/usr/local/Cellar/ogre/1.7.4 -DCMAKE_B ==> make install ld: symbol(s) not found for architecture x86_64 clang: error: linker command failed with exit code 1 (use -v to see invocation) make[2]: * [lib/libOgreMain.1.7.4.dylib] Error 1 make[1]: [OgreMain/CMakeFiles/OgreMain.dir/all] Error 2 make: ** [all] Error 2

READ THIS: /brew troubleshooting link/

ERROR: the following rosdeps failed to install homebrew: command [brew install ogre] failed