Ask Your Question

cga's profile - activity

2013-06-17 22:50:03 -0500 received badge  Famous Question (source)
2013-04-25 00:42:29 -0500 received badge  Famous Question (source)
2013-04-12 09:05:23 -0500 received badge  Student (source)
2013-04-12 09:05:18 -0500 received badge  Notable Question (source)
2013-04-05 11:35:19 -0500 received badge  Popular Question (source)
2013-04-02 14:29:17 -0500 asked a question Multiple remote users of ROS master: nickname lookup failure

I am setting up a ROS master that I want students to be able to access, without giving them administrator privileges on that machine. For this example a student laptop has the name vaio4 and has gotten an IP address through the campus wireless network DHCP. The students are able to remotely say

rostopic list

but when they try

rosnode ping gazebo

the master machine prints out an error message about not being able to reach machine vaio4. If I put vaio4 with its current IP address in the /etc/hosts file on the ROS master, everything works. It does not seem that saying

ROS_IP=xxx
or
ROS_HOSTNAME=xxx

on the ROS Master machine makes sense since it is talking to many laptops simultaneously, so which IP address should it use? The laptop knows who it is and can reach the master. It seems that the master should always use numeric IP addresses and not attempt to use machine names or nicknames.

Thanks, Chris

2013-01-19 01:27:02 -0500 received badge  Notable Question (source)
2013-01-18 13:37:05 -0500 received badge  Popular Question (source)
2013-01-18 01:03:47 -0500 asked a question roscore has errors

On Unbuntu 12.04, ROS fuerte, in an installation of drcsim-1.3.1 (gazebo), roscore has the following errors (can't have links in post so I Xed those out):

... logging to /home/cga/.ros/log/a6b2c846-60c6-11e2-9f20-0014225a80ab/roslaunch-cga2-2011.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.



started roslaunch server htXtp:/X/cga2:57907/ ros_comm version 1.8.10

SUMMARY


PARAMETERS * /rosdistro * /rosversion


NODES


auto-starting new master Exception AttributeError: AttributeError("'DummyThread' object has no attribute 'Thread_block'",) in <module 'threading'="" from="" '="" usr="" lib="" python2.7="" threading.pyc'=""> ignored process[master]: started with pid [2027] ROSMASTER_URI=htXtp:/X/cga2:11311/


setting /runid to a6b2c846-60c6-11e2-9f20-0014225a80ab Exception AttributeError: AttributeError("'DummyThread' object has no attribute 'Thread_block'",) in <module 'threading'="" from="" '="" usr="" lib="" python2.7="" threading.pyc'=""> ignored process[rosout-1]: started with pid [2040] started core service [/rosout]

This seems to be causing ROS errors later on. My environment variables are:

ROS_ROOT=/opt/ros/fuerte/share/ros
ROSLISP_PACKAGE_DIRECTORY=/opt/ros/fuerte/share/common-lisp/ros
ROS_PACKAGE_PATH=/home/cga/drc-cmub/ros:/usr/share/drcsim-1.3/ros:/usr/share/drcsim-1.3/models/irobot_hand:/usr/share/drcsim-1.3/models/golf_cart:/usr/share/drcsim-1.3/models/drc_terrain:/usr/share/drcsim-1.3/models/sandia_hand_left:/usr/share/drcsim-1.3/models/multisense_sl:/usr/share/drcsim-1.3/models/sandia_hand:/usr/share/drcsim-1.3/models/sandia_hand_right:/usr/share/drcsim-1.3/models/fire_hose:/usr/share/drcsim-1.3/models/standpipe:/usr/share/drcsim-1.3/models/atlas:/usr/share/drcsim-1.3/models/powerplant:/usr/share/drcsim-1.3/models/atlas_sandia_hand:/usr/share/drcsim-1.3/models/atlas_irobot_hand:/opt/ros/fuerte/share:/opt/ros/fuerte/stacks
ROS_MASTER_URI=htXtp:/X/localhost:11311
ROS_WORKSPACE=/home/cga/drc-cmub/ros
ROS_DISTRO=fuerte
ROS_ETC_DIR=/opt/ros/fuerte/etc/ros