Ask Your Question

Dakow's profile - activity

2019-06-12 10:30:30 -0500 received badge  Famous Question (source)
2019-03-21 11:03:45 -0500 received badge  Famous Question (source)
2019-03-21 11:02:54 -0500 received badge  Notable Question (source)
2019-02-16 03:34:09 -0500 received badge  Enthusiast
2019-02-13 10:29:33 -0500 received badge  Popular Question (source)
2019-02-13 01:55:37 -0500 edited question DWA local planner parameters are never used

DWA local planner parameters are never used Hi, When trying to configure DWA local planner parameters, i've found that

2019-02-13 01:54:26 -0500 edited question DWA local planner parameters are never used

DWA local planner parameters are never used Hi, When trying to parameter DWA local planner, i've found that parameters

2019-02-13 01:53:21 -0500 edited question DWA local planner parameters are never used

DWA local planner parametes are never used Hi, When trying to parameter DWA local planner, i've found that parameters s

2019-02-13 01:53:21 -0500 received badge  Editor (source)
2019-02-13 01:53:09 -0500 asked a question DWA local planner parameters are never used

DWA local planner parametes are never used Hi, When trying to parameter DWA local planner, i've found that parameters s

2019-01-29 10:31:43 -0500 received badge  Notable Question (source)
2019-01-25 03:58:48 -0500 received badge  Student (source)
2019-01-23 04:46:55 -0500 received badge  Popular Question (source)
2019-01-23 02:44:30 -0500 edited question DWB local planner footprint configuration

DWB local planner configuration Hi everyone, I have some issues while trying to use DWB local planner. I'm using it wit

2019-01-23 02:44:00 -0500 commented answer DWB local planner footprint configuration

I had it there: /move_base/global_costmap/footprint /move_base/local_costmap/footprint So I added it too in: /move_b

2019-01-23 02:40:58 -0500 marked best answer DWB local planner footprint configuration

Hi everyone,

I have some issues while trying to use DWB local planner. I'm using it with move_base using this answer.

But when I start the navigation, I get these errors:

[ WARN] [1464825005.450915057]: Critic "ObstacleFootprint" failed to prepare
[ERROR] [1464825005.457386149]: computeVelocityCommands exception: No valid trajectories out of 63! 
[ERROR] [1464825005.550973984]: Footprint spec is empty, maybe missing call to setFootprint?

I've tried to add in my "base_local_planner_params.yaml" file the "ObstacleFootprint" parameter :

  critics:
     ObstacleFootprint: [[-0.3, 0.45], [0.97, 0.45], [0.97, -0.45], [-0.3,-0.45]]

But now, my robot goes around in circles with no errors instead of moving towards the destination...

Thanks for your help!

2019-01-23 02:40:58 -0500 received badge  Scholar (source)
2019-01-22 11:13:41 -0500 asked a question DWB local planner footprint configuration

DWB local planner configuration Hi everyone, I have some issues while trying to use DWB local planner. I'm using it wit

2019-01-22 11:00:28 -0500 received badge  Supporter (source)