ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question

stefano's profile - activity

2018-08-07 09:10:54 -0600 received badge  Taxonomist
2017-11-06 18:52:58 -0600 marked best answer moveit demo.launch, rviz initializing forever

Hi everyone, here is my problem:

I setup my model using the setup assistant of moveit. Everything seems to work. I export the package, save it under src/ in the catkin_ws/. Then I run "roslaunch my_package demo.launch" .

Here the process starts until the terminal says in green " You can start planning now! " The RViz initializing picture is freezed forever.

However, I get in the terminal "[INFO] [1498661559]: MoveGroup context initialization complete".

What do you think about that? is my PC not strong enough or do I have another problem? Thank you in advance, Stefano

Details:

-I can run RViz stand-alone, no problem.

-I am using a 4 years old laptop, intel i3 quadcore 2.53GHz, geforce 610M.

-I am using Ubuntu 16.04 LTS installed by a friend's usb flashkey

-can I run gazebo if the grafics drivers are not installed?

Complete terminal:

    zampieri@zampieri-Hack:~/catkin_ws$ roslaunch moveit_config_complete_arm_3 demo.launch 
... logging to /home/zampieri/.ros/log/8bbb4536-5bd0-11e7-b431-7ce9d3541a7d/roslaunch-zampieri-Hack-26924.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://zampieri-Hack:45617/

SUMMARY
========

PARAMETERS
 * /joint_state_publisher/use_gui: False
 * /move_group/allow_trajectory_execution: True
 * /move_group/arm/longest_valid_segment_fraction: 0.005
 * /move_group/arm/planner_configs: ['SBLkConfigDefau...
 * /move_group/arm/projection_evaluator: joints(joint_1,jo...
 * /move_group/controller_list: [{'joints': ['joi...
 * /move_group/jiggle_fraction: 0.05
 * /move_group/max_range: 5.0
 * /move_group/max_safe_path_cost: 1
 * /move_group/moveit_controller_manager: moveit_fake_contr...
 * /move_group/moveit_manage_controllers: True
 * /move_group/octomap_resolution: 0.025
 * /move_group/planner_configs/BFMTkConfigDefault/balanced: 0
 * /move_group/planner_configs/BFMTkConfigDefault/cache_cc: 1
 * /move_group/planner_configs/BFMTkConfigDefault/extended_fmt: 1
 * /move_group/planner_configs/BFMTkConfigDefault/heuristics: 1
 * /move_group/planner_configs/BFMTkConfigDefault/nearest_k: 1
 * /move_group/planner_configs/BFMTkConfigDefault/num_samples: 1000
 * /move_group/planner_configs/BFMTkConfigDefault/optimality: 1
 * /move_group/planner_configs/BFMTkConfigDefault/radius_multiplier: 1.0
 * /move_group/planner_configs/BFMTkConfigDefault/type: geometric::BFMT
 * /move_group/planner_configs/BKPIECEkConfigDefault/border_fraction: 0.9
 * /move_group/planner_configs/BKPIECEkConfigDefault/failed_expansion_score_factor: 0.5
 * /move_group/planner_configs/BKPIECEkConfigDefault/min_valid_path_fraction: 0.5
 * /move_group/planner_configs/BKPIECEkConfigDefault/range: 0.0
 * /move_group/planner_configs/BKPIECEkConfigDefault/type: geometric::BKPIECE
 * /move_group/planner_configs/BiESTkConfigDefault/range: 0.0
 * /move_group/planner_configs/BiESTkConfigDefault/type: geometric::BiEST
 * /move_group/planner_configs/BiTRRTkConfigDefault/cost_threshold: 1e300
 * /move_group/planner_configs/BiTRRTkConfigDefault/frountier_node_ratio: 0.1
 * /move_group/planner_configs/BiTRRTkConfigDefault/frountier_threshold: 0.0
 * /move_group/planner_configs/BiTRRTkConfigDefault/init_temperature: 100
 * /move_group/planner_configs/BiTRRTkConfigDefault/range: 0.0
 * /move_group/planner_configs/BiTRRTkConfigDefault/temp_change_factor: 0.1
 * /move_group/planner_configs/BiTRRTkConfigDefault/type: geometric::BiTRRT
 * /move_group/planner_configs/ESTkConfigDefault/goal_bias: 0.05
 * /move_group/planner_configs/ESTkConfigDefault/range: 0.0
 * /move_group/planner_configs/ESTkConfigDefault/type: geometric::EST
 * /move_group/planner_configs/FMTkConfigDefault/cache_cc: 1
 * /move_group/planner_configs/FMTkConfigDefault/extended_fmt: 1
 * /move_group/planner_configs/FMTkConfigDefault/heuristics: 0
 * /move_group/planner_configs/FMTkConfigDefault/nearest_k: 1
 * /move_group/planner_configs/FMTkConfigDefault/num_samples: 1000
 * /move_group/planner_configs/FMTkConfigDefault/radius_multiplier: 1.1
 * /move_group/planner_configs/FMTkConfigDefault/type: geometric::FMT
 * /move_group/planner_configs/KPIECEkConfigDefault/border_fraction: 0.9
 * /move_group/planner_configs/KPIECEkConfigDefault/failed_expansion_score_factor: 0.5
 * /move_group/planner_configs/KPIECEkConfigDefault/goal_bias: 0.05
 * /move_group/planner_configs/KPIECEkConfigDefault/min_valid_path_fraction: 0.5
 * /move_group/planner_configs/KPIECEkConfigDefault/range: 0.0
 * /move_group/planner_configs/KPIECEkConfigDefault/type: geometric::KPIECE
 * /move_group/planner_configs/LBKPIECEkConfigDefault/border_fraction: 0.9
 * /move_group/planner_configs/LBKPIECEkConfigDefault/min_valid_path_fraction: 0.5
 * /move_group/planner_configs/LBKPIECEkConfigDefault/range: 0.0
 * /move_group/planner_configs/LBKPIECEkConfigDefault/type: geometric::LBKPIECE
 * /move_group/planner_configs/LBTRRTkConfigDefault/epsilon: 0.4
 * /move_group/planner_configs/LBTRRTkConfigDefault/goal_bias: 0.05
 * /move_group/planner_configs/LBTRRTkConfigDefault/range: 0.0 ...
(more)
2017-10-09 05:24:40 -0600 received badge  Famous Question (source)
2017-06-29 16:38:51 -0600 commented question moveit demo.launch, rviz initializing forever

Guys the problem was the nvidia optimus as gvdhoorn said. I switched the driver from "nvidia binary driver" to "Nouveau

2017-06-29 03:30:56 -0600 commented question moveit demo.launch, rviz initializing forever

Yeah I have nvidia optimus tech. I'll try to disable the Intel video card (I have no Idea how to do such things ^^). May

2017-06-29 03:19:42 -0600 commented question moveit demo.launch, rviz initializing forever

in move_group.launch debug is false the output is the same adding debug:=false at the end of the command I commented t

2017-06-29 02:58:58 -0600 commented question moveit demo.launch, rviz initializing forever

I updated the question with the demo.launch. It seems ok " debug="false". Now when I roslaunch the demo.launch I have

2017-06-29 02:52:26 -0600 commented question moveit demo.launch, rviz initializing forever

I updated the question with the demo.launch. It seems ok " debug="false".

2017-06-29 02:51:12 -0600 edited question moveit demo.launch, rviz initializing forever

moveit demo.launch, rviz initializing forever Hi everyone, here is my problem: I setup my model using the setup assista

2017-06-28 18:13:52 -0600 commented question moveit demo.launch, rviz initializing forever

nope, I did not enable anything. how to disable it? I now tried with a corse mesh but the result is the same.

2017-06-28 18:11:55 -0600 received badge  Notable Question (source)
2017-06-28 13:36:27 -0600 commented question moveit demo.launch, rviz initializing forever

I am going to try anyway with a corse meshing. I keep you updated.

2017-06-28 13:35:47 -0600 commented question moveit demo.launch, rviz initializing forever

in the options within the SlidWorks plug-in I could choose corse meshes or fine meshes. I choose fine... How ever I don

2017-06-28 13:34:18 -0600 commented question moveit demo.launch, rviz initializing forever

in the options within the SlidWorks plug-in I could choose corse meshes or fine meshes. I choose fine... How ever I don

2017-06-28 13:30:53 -0600 edited question moveit demo.launch, rviz initializing forever

moveit demo.launch, rviz initializing forever Hi everyone, here is my problem: I setup my model using the setup assista

2017-06-28 13:29:57 -0600 edited question moveit demo.launch, rviz initializing forever

moveit demo.launch, rviz initializing forever Hi everyone, here is my problem: I setup my model using the setup assista

2017-06-28 13:29:57 -0600 received badge  Editor (source)
2017-06-28 12:25:45 -0600 commented question moveit demo.launch, rviz initializing forever

I corrected the errors in the warnings. I have no more warnings. Still no response from RViz. I hope i don't have to rei

2017-06-28 12:23:37 -0600 received badge  Popular Question (source)
2017-06-28 12:14:20 -0600 commented question moveit demo.launch, rviz initializing forever

@gvdhoorn: Thanks for guiding my question. I updated it. @Felix : Yeah, I dont get "loading robot model mybot". I made

2017-06-28 12:09:14 -0600 commented question moveit demo.launch, rviz initializing forever

Thanks for guiding my question. I updated the question.

2017-06-28 12:08:19 -0600 edited question moveit demo.launch, rviz initializing forever

moveit demo.launch, rviz initializing forever Hi everyone, here is my problem: I setup my model using the setup assista

2017-06-28 10:25:58 -0600 asked a question moveit demo.launch, rviz initializing forever

moveit demo.launch, rviz initializing forever Hi everyone, here is my problem: I setup my model using the setup assista