ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

hunh's profile - activity

2014-11-19 02:58:45 -0500 received badge  Good Question (source)
2012-11-15 22:23:16 -0500 received badge  Nice Question (source)
2012-10-14 23:43:41 -0500 received badge  Student (source)
2012-09-21 08:41:49 -0500 received badge  Famous Question (source)
2012-09-04 06:06:00 -0500 received badge  Notable Question (source)
2012-08-21 07:15:58 -0500 received badge  Popular Question (source)
2012-08-17 04:29:53 -0500 asked a question OpenNI skeleton tracking still requires psi pose for calibration. How to enable the auto calibration

We are encountering a problem using the latest OpenNI and NITE (OpenNI v1.5.4.0, NITE v1.5.2.21) for skeleton tracking on Ubuntu 11.10.

The skeleton tracker always needs the psi-pose(surrendering) for calibration on Ubuntu 11.10, which was not expected as the new OpenNI should support fast calibration without psi-pose. To compare on other Ubuntu release, we compiled and installed the same source on the Ubuntu 12.04, and it works perfect without doing any surrender pose. Both Ubuntu system are newly installed and no other packages has been installed yet. The libraries of the skeleton trackers are supposed to be exactly the same. So we are wondering why 11.10 still use the old fashioned way for skeleton tracking (user have to surrender to initialize the tracker) and how can we enable the skeleton tracking without doing the psi pose.

In summary, the problem can be reproduced by the following:

  • install Ubuntu 11.10 x64 Compile and intall the latest unstable Openni (v1.5.4.0)
  • install NITE(v1.5.2.21)
  • In the folder of newly compiled samples, run Sample-OpenNIUserTracker
  • Do exactly the same thing on Ubuntu 12.04 x32 or x64

RESULT: 11.10 requires psi-pose for calibration, but 12.04 NOT.

We have to use Ubuntu 11.10 since we need to use ROS electric for our project. Any help is appreciated. Thank you.