Ask Your Question

lealem's profile - activity

2019-10-01 21:03:51 -0600 received badge  Famous Question (source)
2019-10-01 21:03:51 -0600 received badge  Notable Question (source)
2019-05-31 14:50:44 -0600 received badge  Popular Question (source)
2019-05-30 02:00:59 -0600 commented question Why no frame lever-arm (translation) parameters are used when transforming acceleration measurements in imu_transformer?

I see. Thanks for the insight.

2019-05-29 17:03:35 -0600 commented question Why no frame lever-arm (translation) parameters are used when transforming acceleration measurements in imu_transformer?

Well, that's what the imu_transformer claims to do. It transforms sensor_msgs/Imu from one frame to another. It actuall

2019-05-29 17:00:42 -0600 commented answer Why no frame lever-arm (translation) parameters are used when transforming acceleration measurements in imu_transformer?

Thanks, but the implementation is here. And I don't see the acceleration being treated any different than other vectors.

2019-05-29 16:52:18 -0600 commented question Why no frame lever-arm (translation) parameters are used when transforming acceleration measurements in imu_transformer?

Well, that's what the imu_transformer claims to do. It transforms sensor_msgs/Imu from one frame to another. It actuall

2019-05-29 16:24:20 -0600 commented question Why no frame lever-arm (translation) parameters are used when transforming acceleration measurements in imu_transformer?

Well, that's what the imu_transformer claims to do. It transforms sensor_msgs/Imu from one frame to another. It actuall

2019-05-29 07:58:08 -0600 edited question Why no frame lever-arm (translation) parameters are used when transforming acceleration measurements in imu_transformer?

Frame lever-arm parameters when transforming acceleration easurements I see that the ROS imu_transformer node does not c

2019-05-29 07:57:01 -0600 asked a question Why no frame lever-arm (translation) parameters are used when transforming acceleration measurements in imu_transformer?

Frame lever-arm parameters when transforming acceleration easurements I see that the ROS imu_transformer node does not c

2019-05-20 02:18:48 -0600 marked best answer rtabmap_ros won't subscribe to 3D point cloud from velodyne.

Hi

I am using rtabmap_ros version 0.13.1 with the ZED stereo camera and the VLP16 laser scanner. Even though I enabled the "subscribe to scan cloud" option and used the correct cloud topic name "velodyne_points" rtabmap seems to ignore the subscription.

My objective is simply to use the pose graph and loop closure optimization from rtabmap to display point clouds from VLP16. Can rtabmap store the 3d laser scan at the graph nodes and display them later?

I am using the sample launch file stereo_mapping.launch

https://www.dropbox.com/s/y9ocshgq8ye...

RTABMAP start log

https://www.dropbox.com/s/wdwivai4snq...

ros graph

https://www.dropbox.com/s/zr0wa3n0gtz...

Thank you in advance!

Lealem

2018-06-22 06:24:38 -0600 received badge  Taxonomist
2018-01-22 08:24:10 -0600 received badge  Famous Question (source)
2017-11-01 01:09:32 -0600 received badge  Notable Question (source)
2017-10-29 13:12:57 -0600 received badge  Famous Question (source)
2017-10-16 17:36:10 -0600 marked best answer RTABMAP non-overlapping 3D cloud

Hi, I am using rtabmap using stereo on a robot. Everything seems to work fine, except that the MapCloud does not contain registered clouds. The individual 3D maps (from different graph nodes) "supposedly" are not registered to each other. For example there are multiple (3 or 4) replica of the same scene which are not registered. Here are some details.

Please help, thanks!

2017-09-08 14:12:56 -0600 received badge  Popular Question (source)
2017-09-08 13:11:51 -0600 commented answer rtabmap_ros won't subscribe to 3D point cloud from velodyne.

Works perfect! Thanks for the help!

2017-09-08 10:51:50 -0600 commented question rtabmap_ros won't subscribe to 3D point cloud from velodyne.

Also checked on rostopic info, it shows there is no subscription to the topic /velodyne_points. I also attached the com

2017-09-08 10:45:13 -0600 edited question rtabmap_ros won't subscribe to 3D point cloud from velodyne.

rtabmap_ros won't subscribe to 3D point cloud from velodyne. Hi I am using rtabmap_ros version 0.13.1 with the ZED ster

2017-09-07 03:37:09 -0600 edited question rtabmap_ros won't subscribe to 3D point cloud from velodyne.

rtabmap_ros won't subscribe to 3D point cloud from velodyne. Hi I am using rtabmap_ros version 0.13.1 with the ZED ster

2017-09-07 03:31:21 -0600 asked a question rtabmap_ros won't subscribe to 3D point cloud from velodyne.

rtabmap_ros won't subscribe to 3D point cloud from velodyne. Hi, I am using rtabmap_ros version 0.13.1 with the ZED ste

2017-08-16 12:00:50 -0600 commented answer RTABMAP non-overlapping 3D cloud

Hi Mathieu, Thank you for the insight. Changed my stereo setup to the "ZED" and works like a charm! Best, Lealem

2017-08-04 10:43:09 -0600 received badge  Notable Question (source)
2017-08-04 09:14:01 -0600 commented question RTABMAP non-overlapping 3D cloud

here is a link to the launch file i used and the rtabmap database database https://www.dropbox.com/sh/vtp0xao60fbfg33/AA

2017-08-04 09:13:45 -0600 commented question RTABMAP non-overlapping 3D cloud

here is a link to the launch file i used and the rtabmap database d_bae https://www.dropbox.com/sh/vtp0xao60fbfg33/AADkB

2017-08-04 09:10:13 -0600 received badge  Organizer (source)
2017-08-04 09:09:15 -0600 edited question RTABMAP non-overlapping 3D cloud

RTABMAP non-overlapping 3D cloud Hi, I am using rtabmap using stereo on a robot. Everything seems to work fine, except

2017-08-04 09:08:20 -0600 edited question RTABMAP non-overlapping 3D cloud

RTABMAP non-overlapping 3D cloud Hi, I am using rtabmap using stereo on a robot. Everything seems to work fine, except

2017-08-03 13:06:33 -0600 commented question RTABMAP non-overlapping 3D cloud

here is a link to the launch file i used and the rtabmap database https://www.dropbox.com/sh/vtp0xao60fbfg33/AADkBI-FDUY

2017-08-03 11:07:36 -0600 received badge  Popular Question (source)
2017-08-03 09:49:57 -0600 commented question RTABMAP non-overlapping 3D cloud

I would say the problem is with the cloud data (mapping result), everything else seems to work perfect! And I am launchi

2017-08-03 09:47:49 -0600 commented question RTABMAP non-overlapping 3D cloud

I would say the problem is with the cloud data (mapping result), everything else seems to work perfect! And I am launchi

2017-08-03 09:44:18 -0600 received badge  Editor (source)
2017-08-03 09:44:18 -0600 edited question RTABMAP non-overlapping 3D cloud

RTABMAP non-overlapping 3D cloud Hi, I am using rtabmap using stereo on a robot. Everything seems to work fine, except

2017-08-03 09:35:45 -0600 edited question RTABMAP non-overlapping 3D cloud

RTABMAP non-overlapping 3D cloud Hi, I am using rtabmap using stereo on a robot. Everything seems to work fine, except

2017-08-03 09:31:33 -0600 received badge  Enthusiast
2017-08-02 12:11:21 -0600 answered a question RTABMAP non-overlapping 3D cloud

sorry! couldn't upload the pics

2017-08-02 12:11:21 -0600 asked a question RTABMAP non-overlapping 3D cloud

RTABMAP non-overlapping 3D cloud Hi, I am using rtabmap using stereo on a robot. Everything seems to work fine, except

2016-10-18 11:22:43 -0600 received badge  Supporter (source)