Ask Your Question

GlenH's profile - activity

2018-09-24 12:11:21 -0500 received badge  Notable Question (source)
2018-09-24 12:11:19 -0500 received badge  Famous Question (source)
2018-09-24 12:11:19 -0500 received badge  Notable Question (source)
2018-09-24 12:11:19 -0500 received badge  Popular Question (source)
2018-03-07 07:51:30 -0500 received badge  Famous Question (source)
2017-03-10 02:39:16 -0500 received badge  Notable Question (source)
2017-02-14 13:52:30 -0500 received badge  Taxonomist
2017-02-10 02:11:50 -0500 received badge  Famous Question (source)
2017-02-10 02:11:50 -0500 received badge  Notable Question (source)
2017-01-19 03:41:05 -0500 received badge  Popular Question (source)
2016-12-12 07:14:12 -0500 received badge  Popular Question (source)
2016-11-10 06:08:09 -0500 received badge  Popular Question (source)
2016-11-10 06:08:06 -0500 received badge  Enthusiast
2016-11-09 13:04:20 -0500 commented answer How to modify the initial orientation (and position) of a robot model

I thought that technique was for fixed robots? Mine is mobile.

2016-11-08 16:06:08 -0500 asked a question How to modify the initial orientation (and position) of a robot model

I have a urdf model of a robot that I inherited. I've built a ROS package around it. When I load it into Gazebo, it ends up being below the floor place, so it "hangs" underneath the floor due to the collision detection on the feet not allowing them to fall through the floor. The rest of the robot is invisible under the floor unless I make everything transparent.

I've tried changing the origin of the parent node of the URDF model, and I've also tried passing (x, y, z, r, p, y) parameters in the args list in the launch file. Neither one seems to change the behavior in any way.

How do you specify an initial orientation and position for a model?

2016-11-08 09:58:33 -0500 received badge  Teacher (source)
2016-11-08 09:58:33 -0500 received badge  Self-Learner (source)
2016-11-08 09:58:24 -0500 received badge  Student (source)
2016-11-07 15:53:08 -0500 answered a question "can't locate node [spawner] in package [controller_manager]"

OK, so if anyone who is flailing trying to understand ROS in the future stumbles across this, here's the answer:

ROS installs a script called "setup.bash" in /opt/ros/kinetic that you have to source before anything will run. If you also install some third-party code that you have to build from source (as opposed to installing from packages), that code resides in a directory somewhere on your system called "catkin_ws" or similar. There will be a couple of directories inside of this called "devel" and maybe "install". Inside those directories there are also "setup.bash" files that tell the system about the new stuff you've built. You can source them using an "--extend" flag in order to add the extra search paths to your ROS system.

Here's the key, though: you have to source all of the setup scripts in all of the terminals, even ones that you aren't using to call your new code.

That was my problem: I was sourcing /opt/ros/kinetic/setup.bash in all of my terminals, but only sourcing devel/setup.bash in the terminal I was using to call the code that lived in my catkin workspace.

2016-11-07 14:51:50 -0500 asked a question "can't locate node [spawner] in package [controller_manager]"

Trying to run the rrbot gazebo demo found at http://arnaudbertrand.io/blog/2015/06... . When I run:

> roslaunch -v rrbot_control rrbot_control.launch

I get:

ERROR: cannot launch node of type [controller_manager/spawner]: can't locate node [spawner] in package [controller_manager]

The problem seems to be that rosrun is trying to find the controller_manager spawner node in /opt/ros/kinetic/share/controller_manager, but in fact it seems to be installed at /opt/ros/kinetic/lib/controller_manager.

This is my first week using ROS, so I'm at something of a loss how to fix this. Is spawner simply installed in the srong location? Should I copy the files over to /share?

2016-10-31 12:08:28 -0500 asked a question rrbot demo won't run on macOS Sierra; "libtf2_ros.dylib image not found"

Running a brand new ROS build (jade) on macOS Sierra 10.12.1. Trying to get the rrbot demo to run. I get:

$ roslaunch rrbot_gazebo rrbot_world.launch
(some stuff)
File "/opt/ros/jade/lib/gazebo_ros/spawn_model", line 32, in <module>
import tf.transformations as tft
File "/opt/ros/jade/lib/python2.7/site-packages/tf/__init__.py", line 28, in <module>
from _tf import *
ImportError: dlopen(/opt/ros/jade/lib/python2.7/site-packages/tf/_tf.so, 2): Library not loaded: libtf2_ros.dylib
  Referenced from: /opt/ros/jade/lib/python2.7/site-packages/tf/_tf.so
  Reason: image not found

libtf2_ros.dylib is sitting right where it's supposed to be, in /opt/ros/jade/lib.

There's a fix where you add a line exporting DYLD_LIBRARY_PATH to the start of rosrun which is purported to fix this problem, but it doesn't work for me.

2016-09-22 09:59:25 -0500 asked a question Cannot build cv_bridge for ROS Jade on OSX Yosemite

I'm getting the following error:

[ 0%] Built target std_msgs_generate_messages_lisp
[ 0%] Built target std_msgs_generate_messages_py
[ 0%] Built target std_msgs_generate_messages_cpp
[ 0%] Built target std_msgs_generate_messages_eus
[ 0%] Built target geometry_msgs_generate_messages_py
[ 0%] Built target geometry_msgs_generate_messages_lisp
[ 0%] Built target sensor_msgs_generate_messages_cpp
[ 0%] Built target sensor_msgs_generate_messages_lisp
[ 0%] Built target sensor_msgs_generate_messages_py
[ 0%] Built target sensor_msgs_generate_messages_eus
[ 0%] Built target geometry_msgs_generate_messages_eus
[ 0%] Built target geometry_msgs_generate_messages_cpp
[ 50%] Built target cv_bridge
[ 66%] Linking CXX shared library /Users/glenhenshaw/Code/ros_catkin_ws/devel_isolated/cv_bridge/lib/python3.5/site-packages/cv_bridge/boost/cv_bridge_boost.so
Undefined symbols for architecture x86_64:
"boost::python::detail::init_module(PyModuleDef&, void ()())", referenced from:
_PyInit_cv_bridge_boost in module.cpp.o
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[2]:
[/Users/glenhenshaw/Code/ros_catkin_ws/devel_isolated/cv_bridge/lib/python3.5/site-packages/cv_bridge/boost/cv_bridge_boost.so] Error 1
make[1]:
[src/CMakeFiles/cv_bridge_boost.dir/all] Error 2
make: *
* [all] Error 2

I've installed the patch listed on the "Installation Instructions for Jade in OSX" page, but it doesn't change the behavior.