Ask Your Question

Humoros's profile - activity

2018-09-30 09:46:40 -0600 received badge  Famous Question (source)
2017-12-26 12:13:27 -0600 received badge  Famous Question (source)
2017-12-26 12:13:27 -0600 received badge  Notable Question (source)
2017-12-26 12:13:27 -0600 received badge  Popular Question (source)
2016-10-17 14:47:55 -0600 received badge  Notable Question (source)
2016-08-18 12:17:06 -0600 commented question Skip urdfdom error during OSX installation

roscoreworked from the start and I did source it, but rosversion ros just didn't work...Your way works, thanks for the tip!

2016-08-17 12:37:21 -0600 commented question Skip urdfdom error during OSX installation

It seems like it worked! It said that everything was installed successfully after I used the curl thing from github. But how do I know if it installed properly? I tried rosversion ros but it couldn't locate it... Sorry if I'm supposed to make another topic for this; I will if I can't solve it soon.

2016-08-17 11:44:28 -0600 commented question Skip urdfdom error during OSX installation

Hmm, I did try to use that at first but I switched to the wiki because of some error I've now forgotten. I GUESS I could retry from scratch but I honestly don't know what I'm doing and what problems this will cause, since I don't know if I must/how to/if I want to clean up. So...I'll try it I guess?

2016-08-17 11:06:46 -0600 received badge  Popular Question (source)
2016-08-17 10:37:18 -0600 asked a question Skip urdfdom error during OSX installation

Hi, I'm using Mac OSX Yosemite, still trying to install ROS Indigo, and I've decided to move on from my last error (for the reason I gave here. So now my error is that, during the $ ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release step, I get the error(s?)

 CMake Error at CMakeLists.txt:5 (find_package):
  By not providing "Findurdfdom_headers.cmake" in CMAKE_MODULE_PATH this
  project has asked CMake to find a package configuration file provided by
  "urdfdom_headers", but CMake did not find one.

  Could not find a package configuration file provided by "urdfdom_headers"
  with any of the following names:

    urdfdom_headersConfig.cmake
    urdfdom_headers-config.cmake

  Add the installation prefix of "urdfdom_headers" to CMAKE_PREFIX_PATH or
  set "urdfdom_headers_DIR" to a directory containing one of the above files.
  If "urdfdom_headers" provides a separate development package or SDK, be
  sure it has been installed.


-- Configuring incomplete, errors occurred!
See also "/Users/School/ros_catkin_ws/build_isolated/urdf_parser_plugin/CMakeFiles/CMakeOutput.log".
<== Failed to process package 'urdf_parser_plugin': 
  Command '['/Users/School/ros_catkin_ws/install_isolated/env.sh', 'cmake', '/Users/School/ros_catkin_ws/src/robot_model/urdf_parser_plugin', '-DCATKIN_DEVEL_PREFIX=/Users/School/ros_catkin_ws/devel_isolated/urdf_parser_plugin', '-DCMAKE_INSTALL_PREFIX=/Users/School/ros_catkin_ws/install_isolated', '-DCMAKE_BUILD_TYPE=Release', '-G', 'Unix Makefiles']' returned non-zero exit status 1

Reproduce this error by running:
==> cd /Users/School/ros_catkin_ws/build_isolated/urdf_parser_plugin && /Users/School/ros_catkin_ws/install_isolated/env.sh cmake /Users/School/ros_catkin_ws/src/robot_model/urdf_parser_plugin -DCATKIN_DEVEL_PREFIX=/Users/School/ros_catkin_ws/devel_isolated/urdf_parser_plugin -DCMAKE_INSTALL_PREFIX=/Users/School/ros_catkin_ws/install_isolated -DCMAKE_BUILD_TYPE=Release -G 'Unix Makefiles'

which I assume has to do with my ignoring my last issue. So, is there a way to make everything that has to do with urdfdom be ignored during this [and future] steps? Thanks.

2016-08-16 14:10:44 -0600 commented question Mac OSX Installation SHA256 mismatch for urdfdom

http://answers.ros.org/question/19465... says that I can go on even with the error so I guess I'll do that. Thanks for your help though!

2016-08-12 14:42:46 -0600 commented question Mac OSX Installation SHA256 mismatch for urdfdom

brew update output was:

Updated Homebrew from 58ffe34 to b3ea5c2.
Updated 2 taps (caskroom/cask, homebrew/core).
==> Updated Formulae
luajit                     sqlite                     sqlite-analyzer

and brew reinstall console_bridge output was the same error as before

2016-08-12 14:07:18 -0600 commented question Mac OSX Installation SHA256 mismatch for urdfdom

output is:

caskroom/cask
homebrew/core
homebrew/nginx
homebrew/python
homebrew/science
homebrew/versions
osrf/simulation
ros/deps
2016-08-12 13:06:29 -0600 asked a question Mac OSX Installation SHA256 mismatch for urdfdom

Hi again, I'm still trying to install ROS Indigo on Mac OSX Yosemite, and I'm getting the following error on the step rosdep install --from-paths src --ignore-src --rosdistro indigo -y:

==> Installing urdfdom from ros/deps
==> Installing dependencies for ros/deps/urdfdom: ros/deps/console_bridge
==> Installing ros/deps/urdfdom dependency: ros/deps/console_bridge
==> Downloading https://github.com/ros/console_bridge/archive/0.2.5.tar.gz
==> Downloading from https://codeload.github.com/ros/console_bridge/tar.gz/0.2.5
######################################################################## 100.0%
Error: SHA256 mismatch
Expected: 6e4f3e8a56903f157829d8928b9ed8c8c9e1cc16f281a90ecd2abfdc904a3b92
Actual: a8843e1d8447c099ef271a942af1c57294c4c51f43bbde2c6d03f7b805989fa7
Archive: /Users/School/Library/Caches/Homebrew/console_bridge-0.2.5.tar.gz
To retry an incomplete download, remove the file above.

I've tried to do brew install urdfdom alone too, but that gives the same error. I've been removing the file they specify whenever I retry too, of course. I also tried brew update && brew upgrade brew-cask && brew cleanup && brew cask cleanup but that gives me Already up-to-date. Error: caskroom/cask/brew-cask not installed and when I do try to install brew-cask, it says that there's no available Cask for caskroom/cask/brew-cask.

Does anyone have a solution? Thanks.

2016-08-12 12:46:55 -0600 received badge  Famous Question (source)
2016-08-12 04:03:18 -0600 received badge  Scholar (source)
2016-08-11 16:30:19 -0600 received badge  Supporter (source)
2016-08-11 16:30:12 -0600 commented answer rosdep update ssl cert error

Wow, thanks so much!! Although I had to use someone's workaround because brew install curl-ca-bundle didn't work directly (davestacey's answer here: https://github.com/devopsgroup-io/vag... ), your thinking was spot-on and it works now! I'm so happy!

2016-08-11 15:49:52 -0600 received badge  Notable Question (source)
2016-08-11 14:40:00 -0600 received badge  Popular Question (source)
2016-08-11 10:08:03 -0600 asked a question Rosdep update ssl error on OSX

Hi, I'm trying to install ROS Indigo for OSX (Yosemite) using the instructions on the official site, and when I get to the step where you update the ros dependencies (rosdep update), this is what it shows:

reading in sources list data from /etc/ros/rosdep/sources.list.d
ERROR: unable to process source [https://raw.githubusercontent.com/mikepurvis/ros-install-osx/master/rosdeps.yaml]:
    <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)> (https://raw.githubusercontent.com/mikepurvis/ros-install-osx/master/rosdeps.yaml)
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/osx-homebrew.yaml]:
    <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/osx-homebrew.yaml)
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/base.yaml]:
    <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/base.yaml)
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/python.yaml]:
    <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/python.yaml)
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/ruby.yaml]:
    <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/ruby.yaml)
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/releases/fuerte.yaml]:
    Failed to download target platform data for gbpdistro:
    <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)>
Query rosdistro index https://raw.githubusercontent.com/ros/rosdistro/master/index.yaml
ERROR: error loading sources list:
    <urlopen error <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)> (https://raw.githubusercontent.com/ros/rosdistro/master/index.yaml)>

I really don't get this, because my browsers are all fine with and trust github. As they should be.

I know there's already someone who asked about this error (here: http://answers.ros.org/question/47177... ) , but the only closure they got was to ask around where they are, so it doesn't really help me, sorry. Important notes: I'm usually in the US but for this month I'm in Germany and I'm borrowing someone's wifi. Before you ask, I've tried using other wifi, like the one from the German university I'm at, public wifi, and I've of course tried going through my US university's vpn. I've tried adding github to my proxy-bypassing list, I've tried deleting the ssl certificate from github so it could re-download, and I've tried to follow answers from similar questions online, but they all didn't seem completely applicable to me or too hard to follow.

Can someone please help? And keep in mind that I'm not very experienced with unix commands and such, so go easy on me? ^_^;

2016-08-11 10:08:02 -0600 asked a question rosdep update ssl cert error

Hi, I'm trying to install ROS Indigo for OSX (Yosemite) using the instructions on the official site, and when I get to the step where you update the ros dependencies (rosdep update), this is what it shows:

reading in sources list data from /etc/ros/rosdep/sources.list.d
ERROR: unable to process source [https://raw.githubusercontent.com/mikepurvis/ros-install-osx/master/rosdeps.yaml]:
    <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)> (https://raw.githubusercontent.com/mikepurvis/ros-install-osx/master/rosdeps.yaml)
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/osx-homebrew.yaml]:
    <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/osx-homebrew.yaml)
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/base.yaml]:
    <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/base.yaml)
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/python.yaml]:
    <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/python.yaml)
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/ruby.yaml]:
    <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/ruby.yaml)
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/releases/fuerte.yaml]:
    Failed to download target platform data for gbpdistro:
    <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)>
Query rosdistro index https://raw.githubusercontent.com/ros/rosdistro/master/index.yaml
ERROR: error loading sources list:
    <urlopen error <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590)> (https://raw.githubusercontent.com/ros/rosdistro/master/index.yaml)>

I really don't get this, because my browsers are all fine with and trust github. As they should.

I know there's already someone who asked about this error (here: http://answers.ros.org/question/47177... ) , but the only closure they got was to ask around where they are, so it doesn't really help me, sorry. Important notes: I'm usually in the US but for this month I'm in Germany and I'm borrowing someone's wifi. Before you ask, I've tried using other wifi, like the one from the German university I'm at, public wifi, and I've of course tried going through my US university's vpn. I've tried adding github to my proxy-bypassing list, I've tried deleting the ssl certificate from github so it could re-download, and I've tried to follow answers from similar questions online, but they all didn't seem completely applicable to me or too hard to follow. Can someone please help? And keep in mind that I'm not very experienced with unix commands and such, so go easy on me? ^_^;