Ask Your Question

Dor's profile - activity

2016-04-10 10:18:04 -0500 received badge  Famous Question (source)
2016-02-02 04:12:29 -0500 received badge  Notable Question (source)
2016-01-27 05:09:59 -0500 received badge  Enthusiast
2016-01-27 05:09:59 -0500 received badge  Enthusiast
2016-01-26 09:59:32 -0500 received badge  Popular Question (source)
2016-01-26 05:55:50 -0500 answered a question robot rotation in place speed lower then minimum

i was able to find in the base_local_planner package in the trajectory planner cpp file a minimum value that was set too low 0.4 and i changed it to 0.6 and than things worked out :)

2016-01-24 08:35:51 -0500 asked a question robot rotation in place speed lower then minimum

hello everyone i am having a difficulty with my robot. it navigates to a goal pretty well. the thing is when it needs to rotate at the end to the orientation of the goal it doesnt seem to move. when i look at the cmd_vel the robot receives a value of 0.457.. but the minimum value required for my robot to rotate is 0.55 this is also the value set in the base_local_planner_params so i dont get how can a value lower than the minimum is sent to the robot

please help me figure this one out

here is my base_local_planner_params file:

controller_frequency: 7.0
recovery_behavior_enabled: false
clearing_rotation_allowed: false

TrajectoryPlannerROS:
   max_vel_x: 0.4
   min_vel_x: 0.25
   max_rotational_vel: 0.79
   min_in_place_vel_theta: 0.55
   escape_vel: -0.3
   acc_lim_x: 0.05
   acc_lim_y: 0.5
   acc_lim_th: 0.07
   #min_rot_vel: 0.6
   #min_trans_vel: 0.6
   #max_trans_vel: 3.0
   #min_rotational_vel: 0.70

   holonomic_robot: false
   yaw_goal_tolerance: 0.5 # about 6 degrees
   xy_goal_tolerance: 0.8  # 5 cm
   latch_xy_goal_tolerance: true
   pdist_scale: 0.8
   gdist_scale: 0.4
   meter_scoring: true

   heading_lookahead: 0.325
   heading_scoring: false
   heading_scoring_timestep: 0.8
   occdist_scale: 0.1
   oscillation_reset_dist: 0.05
   publish_cost_grid_pc: false
   prune_plan: true

   sim_time: 2.0 
   # The amount of time to forward-simulate trajectories in seconds
   sim_granularity: 0.025 
   # The step size, in meters, to take between points on a given trajectory
   angular_sim_granularity: 0.025 
   # The step size, in radians, to take between angular samples on a given trajectory.
   vx_samples: 12  
   # The number of samples to use when exploring the x velocity space
   vtheta_samples: 20 
   # The number of samples to use when exploring the theta velocity space

   dwa: false
   simple_attractor: false
2016-01-24 08:15:23 -0500 received badge  Famous Question (source)
2015-12-10 04:03:51 -0500 received badge  Scholar (source)
2015-12-07 08:00:37 -0500 received badge  Teacher (source)
2015-12-07 08:00:37 -0500 received badge  Self-Learner (source)
2015-12-07 07:50:11 -0500 received badge  Notable Question (source)
2015-12-07 07:03:33 -0500 answered a question ros_arduino_bridge cant get my robot to move

thank you very much for your reply! :) i was able to fix this issue by changing the "gear reduction" in my configuration file, by putting "#" before it.

about the encoder, i will soon recieve my encoder that i ordered online. it is 20 ticks per one revoulution, so thats why i wrote this value. and it is mounted straight on the wheel

thanks again! :)

2015-12-07 00:19:30 -0500 received badge  Popular Question (source)
2015-12-06 07:00:37 -0500 asked a question ros_arduino_bridge cant get my robot to move

hello everyone, basically i want to send twist command to my robot and get it moving but nothing happans when i send the twist commands...

i have successfully uploaded the ros_arduino_bridge sketch in to my robot, i can get it moving by sending "m 20 20" (through serial monitor) and get encoder data "0 0" (although i still don't have encoders plugged in) .

in my config file .yaml i have changed to the following settings:

# For a direct USB cable connection, the port name is typically
# /dev/ttyACM# where is # is a number such as 0, 1, 2, etc
# For a wireless connection like XBee, the port is typically
# /dev/ttyUSB# where # is a number such as 0, 1, 2, etc.

port: /dev/ttyACM4
baud: 57600
timeout: 0.1

rate: 50
sensorstate_rate: 10

use_base_controller: True
base_controller_rate: 10

# For a robot that uses base_footprint, change base_frame to base_footprint
base_frame: base_link

# === Robot drivetrain parameters
wheel_diameter: 0.146
wheel_track: 0.2969
encoder_resolution: 20 # from Pololu for 131:1 motors
gear_reduction: 1.0
motors_reversed: True

# === PID parameters
#Kp: 10
#Kd: 12
#Ki: 0
#Ko: 50
#accel_limit: 1.0

# === Sensor definitions.  Examples only - edit for your robot.
#     Sensor type can be one of the follow (case sensitive!):
#     * Ping
#     * GP2D12
#     * Analog
#     * Digital
#     * PololuMotorCurrent
#     * PhidgetsVoltage
#     * PhidgetsCurrent (20 Amp, DC)



sensors: {
  #motor_current_left:   {pin: 0, type: PololuMotorCurrent, rate: 5},
  #motor_current_right:  {pin: 1, type: PololuMotorCurrent, rate: 5},
  #ir_front_center:      {pin: 2, type: GP2D12, rate: 10},
  #sonar_front_center:   {pin: 5, type: Ping, rate: 10},
  arduino_led:          {pin: 13, type: Digital, rate: 5, direction: output}
}

i am successfully launching the ros communication with the arduino, even pin 13 with the LED is flashing

robot@robot-os:~/catkin_ws$ roslaunch ros_arduino_python arduino.launch
... logging to /home/robot/.ros/log/26e050c2-9bfe-11e5-b637-40f02f469e9c/roslaunch-robot-os-15096.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://robot-os:58763/

SUMMARY
========

PARAMETERS
 * /arduino/base_controller_rate: 10
 * /arduino/base_frame: base_link
 * /arduino/baud: 57600
 * /arduino/encoder_resolution: 20
 * /arduino/gear_reduction: 1.0
 * /arduino/motors_reversed: True
 * /arduino/port: /dev/ttyACM4
 * /arduino/rate: 50
 * /arduino/sensors/arduino_led/direction: output
 * /arduino/sensors/arduino_led/pin: 13
 * /arduino/sensors/arduino_led/rate: 5
 * /arduino/sensors/arduino_led/type: Digital
 * /arduino/sensorstate_rate: 10
 * /arduino/timeout: 0.1
 * /arduino/use_base_controller: True
 * /arduino/wheel_diameter: 0.146
 * /arduino/wheel_track: 0.2969
 * /rosdistro: jade
 * /rosversion: 1.11.16

NODES
  /
    arduino (ros_arduino_python/arduino_node.py)

ROS_MASTER_URI=http://localhost:11311

core service [/rosout] found
process[arduino-1]: started with pid [15114]
[DEBUG] [WallTime: 1449403808.755147] init_node, name[/arduino], pid[15114]
[DEBUG] [WallTime: 1449403808.755488] binding to 0.0.0.0 0
[DEBUG] [WallTime: 1449403808.755694] bound to 0.0.0.0 58098
[DEBUG] [WallTime: 1449403808.759198] ... service URL is rosrpc://robot-os:58098
[DEBUG] [WallTime: 1449403808.759411] [/arduino/get_loggers]: new Service instance
[DEBUG] [WallTime: 1449403808.761027] ... service URL is rosrpc://robot-os:58098
[DEBUG] [WallTime: 1449403808.761239] [/arduino/set_logger_level]: new Service instance
/home/robot/catkin_ws/src/ros_arduino_bridge/ros_arduino_python/nodes/arduino_node.py:62: SyntaxWarning: The publisher should be created with an explicit keyword argument 'queue_size'. Please see http://wiki ...
(more)