ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Andrew Hart's profile - activity

2019-03-26 11:00:52 -0500 received badge  Famous Question (source)
2016-04-14 15:00:20 -0500 received badge  Notable Question (source)
2015-09-17 05:12:39 -0500 received badge  Popular Question (source)
2015-09-17 01:58:34 -0500 received badge  Supporter (source)
2015-09-16 11:21:24 -0500 asked a question nodelet malloc corruption only on nfsroot with home on a disk

We have an unusual setup where ubuntu 14.04 is installed as an nfsroot and we use freenect and ros indigo.

It all works fine until the home folder is on a different mount to nfsroot, then it fails with:

3 0x00007f288bc3cf36 in malloc_printerr (ptr=0x92b620, str=0x7f288bd39c9a "malloc(): memory corruption", action=<optimised out>) at malloc.c:4996
4  _int_malloc (av=0x7f288bf7a760 <main_arena>, bytes=136) at malloc.c:3447
5  0x00007f288bc3e7b0 in __GI___libc_malloc (bytes=136) at malloc.c:2891
6  0x00007f288c1f5dad in operator new(unsigned long) () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
7  0x00007f2856297864 in boost::unordered::detail::table<boost::unordered::detail::map<std::allocator<std::pair<std::string const, unsigned int> >, std::string, unsigned int, boost::hash<std::string>, std::equal_to<std::string> > >::create_buckets(unsigned long) () from /opt/ros/indigo/lib/libtf2.so
8  0x00007f2856297df6 in boost::unordered::detail::table_impl<boost::unordered::detail::map<std::allocator<std::pair<std::string const, unsigned int> >, std::string, unsigned int, boost::hash<std::string>, std::equal_to<std::string> > >::operator[](std::string const&) () from /opt/ros/indigo/lib/libtf2.so

After much playing with settings and installing and uninstalling I found that:

roslaunch freenect_launch freenect.launch depth_registered_processing:=false

could stop the problem and that I didn't actually need a kinect at all to see the bug. It is somewhere in setup...

I have been trying to understand this problem for several days now and I need advice on how to proceed and fix the problem. Can anyone help?