Ask Your Question

darkom's profile - activity

2016-11-30 00:47:33 -0600 commented answer rostopic list return topics, but not able to echo topic

At first, I would suggest checking your network infrastructure - if you have any firewall blocking some ports. At the university where I'm working there was this issue, that just some ports are open. Best is to have your local router and be able to control it. Also, check your environment variables.

2016-05-03 07:55:06 -0600 received badge  Taxonomist
2016-01-25 08:28:16 -0600 received badge  Famous Question (source)
2015-11-19 07:10:48 -0600 received badge  Famous Question (source)
2015-11-19 07:10:48 -0600 received badge  Notable Question (source)
2015-10-06 23:51:32 -0600 received badge  Notable Question (source)
2015-09-09 02:13:07 -0600 received badge  Enthusiast
2015-09-04 02:09:33 -0600 received badge  Popular Question (source)
2015-09-02 06:07:46 -0600 commented question ROS indigo + Arduino Due

I did test with Arduino Mega and it is working fine. So it might be a problem with ARM processor at Due.

2015-09-02 04:12:55 -0600 asked a question ROS indigo + Arduino Due

Hello,

My system consist of: ROS indigo and Arduino Due. I'm trying to run example with Servo control. I succeed with compiling and uploading code to Arduino, but I have a problem with sending angle to Servo motor.

When I'm starting rosserial_python node, I'm getting following error:

$ rosrun rosserial_python serial_node.py /dev/ttyACM3 _baud:=57600
[INFO] [WallTime: 1441184614.282515] ROS Serial Python Node
[INFO] [WallTime: 1441184614.289633] Connecting to /dev/ttyACM3 at 57600 baud
[ERROR] [WallTime: 1441184631.394833] Unable to sync with device; possible link problem or link software version mismatch such as hydro rosserial_python with groovy Arduino

Hardware link is done correctly, tty port and baud rate is set correctly as well. Any hints very welcome :)

2015-08-27 02:21:33 -0600 received badge  Supporter (source)
2015-08-27 02:21:20 -0600 commented answer rostopic list return topics, but not able to echo topic

Thank you so much. Now it is working just great.

2015-08-27 02:20:51 -0600 received badge  Scholar (source)
2015-08-26 15:25:28 -0600 received badge  Popular Question (source)
2015-08-26 10:12:17 -0600 asked a question rostopic list return topics, but not able to echo topic

Hello,

My configuration looks like:

Beaglebone black with GPS + laptop. Both running Ubuntu 14.04 and ROS indigo.

I would like to run roscore at laptop and node gpsd_client at beaglebone. I set following variables: At laptop (ip 192.168.7.1):

export ROS_IP=192.168.7.1
export ROS_HOSTNAME=192.168.7.1
export ROS_MASTER_URI=http://192.168.7.1:11311

At beaglebone (ip 192.168.7.2):

export ROS_IP=192.168.7.2
export ROS_HOSTNAME=192.168.7.1
export ROS_MASTER_URI=http://192.168.7.1:11311

I'm able to ping each other. I'm able to do rostopic list from both. But I'm not able to do rostopic echo fix.

roswtf give following error msg:

Loaded plugin tf.tfwtf
No package or stack in context
================================================================================
Static checks summary:

No errors or warnings
================================================================================
Beginning tests of your ROS graph. These may take awhile...
analyzing graph...
... done analyzing graph
running graph rules...
ERROR: connection refused to [http://192.168.7.1:41219/]
... done running graph rules

Online checks summary:

Found 3 error(s).

ERROR Could not contact the following nodes:
 * /gpsd_client

ERROR The following nodes should be connected but aren't:
 * /gpsd_client->/rosout (/rosout)

ERROR Errors connecting to the following services:
 * service [/gpsd_client/get_loggers] appears to be malfunctioning: Unable to communicate with service [/gpsd_client/get_loggers], address [rosrpc://192.168.7.1:58483]
 * service [/gpsd_client/set_logger_level] appears to be malfunctioning: Unable to communicate with service [/gpsd_client/set_logger_level], address [rosrpc://192.168.7.1:58483]

I see error

ERROR The following nodes should be connected but aren't:
 * /gpsd_client->/rosout (/rosout)

but unfortunately I don't now how should I fix it.

I tried another configuration, when roscore was running at beaglebone with gpsd_client, and do echo from laptop - this is working without any problem. Just problem apear when I run roscore at one machine and node in another.

I hope that my problem is trivial to fix and I'm just missing some setting.