Ask Your Question

seanreynoldscs's profile - activity

2013-01-19 23:34:54 -0600 received badge  Taxonomist
2012-08-23 14:37:42 -0600 received badge  Famous Question (source)
2012-08-23 14:37:42 -0600 received badge  Popular Question (source)
2012-08-23 14:37:42 -0600 received badge  Notable Question (source)
2012-08-19 07:15:52 -0600 received badge  Famous Question (source)
2012-08-19 07:15:52 -0600 received badge  Notable Question (source)
2012-08-08 22:15:34 -0600 received badge  Necromancer (source)
2012-06-21 01:52:20 -0600 received badge  Popular Question (source)
2012-05-31 18:17:10 -0600 answered a question Openni_Launch on Lion with Xtion

In the Virtual Box Settings for my Ubuntu VM I can configure the USB and I see:

Name: PrimeSense Device [0001]

Vender ID: 1D27

Product ID:0600

Revision: 0001

Manufacturer:PrimeSense

Product:PrimeSense Device

Serial No.:

Port:

Remote: NO

Does anyone know if these should be changed for OpenNI_Launch to see the hardware? Also... since everything is a file in Linux, can I just copy the file that my DualBoot gets and tweak it for the VM?

2012-05-28 19:29:39 -0600 commented answer Openni_Launch on Lion with Xtion

Is it: "rosdep install openni_launch" ?

2012-05-28 19:20:36 -0600 commented answer Openni_Launch on Lion with Xtion

I really really like the Xtion, It's flawless! The best thing about it is that it doesnt require external power; much better for robotics. The worst thing about it is that there are other projects which are Kinect Specific.

How can I attempt to install Openni_Launch into ros on OSX? Sorry I'm new.

2012-05-28 19:15:25 -0600 commented answer Openni_Launch on Lion with Xtion

Linux/Ros on Macbook air works flawlessly. I recommend the tutorial here: https://help.ubuntu.com/community/MacBookAir4-2

Please dont give up on OSX! We just need to get OpenNI_Launch working on the Macbook!

What success have you had getting OpenNI to port?

2012-05-28 19:04:04 -0600 commented answer Openni_Launch on Lion with Xtion

So, the red light I was referring to was the faint glow of the emitter. When I check RosTopic with the command you mention, it says: WARNING: topic [/camera/rgb/points] does not appear to be published yet

2012-05-26 04:38:33 -0600 received badge  Student (source)
2012-05-24 04:09:31 -0600 commented answer Openni_Launch on Lion with Xtion

Also worth noting: When I call rosrun rviz rviz, from the vm running in lion, I can see the camera turn on. You can see the little red emitter come on. So, it's definitely doing something. It seems like the openni_camera node just isnt able to tap into the Virtualized hardware data.

2012-05-23 07:32:38 -0600 commented answer Openni_Launch on Lion with Xtion

I forgot to mention that a rostopic for the camera yields no output.

2012-05-23 07:29:04 -0600 answered a question Openni_Launch on Lion with Xtion

In an effort to be Thorough I've tried everything a couple of times. I'm able to see perfect output from the project

RGBD_preRelease_0021_osx

which ran in tech news a few weeks back. This is an OPENNI Project. While recognizing that it's precompiled and prepackaged, It at least lets me know that it's possible to get OpenNI on the MAC Lion.

That being said: I've not had time to get OpenNI installed directly from OpenNI. When I installed RGBD I wrongly assumed it was the same as Installing OpenNI... I'll work on that next.

That said: Unless I know the process Kevin Walchko is undertaking for the Kinect, I'm not sure if I will be able to port any work I do for OpenNI for the Xtron to ROS. Can I get more information about how to get OPENNI_Launch Ros packages running? Id like ROS to get to the point where it is LOOKING for openni to be there...

In reference to your Direction with the VirtualBox solution, I've confirmed that it doesnt work. I've switched Billboard to Points, and every other option in the drop down list. I get nothing. More to the point I've gotten this to work in Ubuntu running on Metal, and not in the VM. I recognize this might be something others have tried, and given up on. But I wouldnt mind trying more things to get it to work, if anyone has any suggestions.

Below is the output of my roslaunch openni_launch openni.launch output. It's worth noting that I connected the camera after running openni, THIS TIME... but not every time. I've tried connecting first as well.

ros@ros-VirtualBox:~$ roslaunch openni_launch openni.launch ... logging to /home/ros/.ros/log/7c0eff3a-a4f9-11e1-b83d-080027a47124/roslaunch-ros-VirtualBox-1902.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://ros-VirtualBox:35053/

SUMMARY

PARAMETERS * /camera/depth/rectify_depth/interpolation * /camera/depth_registered/rectify_depth/interpolation * /camera/disparity_depth/max_range * /camera/disparity_depth/min_range * /camera/disparity_depth_registered/max_range * /camera/disparity_depth_registered/min_range * /camera/driver/depth_camera_info_url * /camera/driver/depth_frame_id * /camera/driver/depth_registration * /camera/driver/device_id * /camera/driver/rgb_camera_info_url * /camera/driver/rgb_frame_id * /rosdistro * /rosversion

NODES /camera/depth/ metric (nodelet/nodelet) metric_rect (nodelet/nodelet) points (nodelet/nodelet) rectify_depth (nodelet/nodelet) /camera/rgb/ debayer (nodelet/nodelet) rectify_color (nodelet/nodelet) rectify_mono (nodelet/nodelet) / camera_base_link (tf/static_transform_publisher) camera_base_link1 (tf/static_transform_publisher) camera_base_link2 (tf/static_transform_publisher) camera_base_link3 (tf/static_transform_publisher) camera_nodelet_manager (nodelet/nodelet) /camera/ disparity_depth (nodelet/nodelet) disparity_depth_registered (nodelet/nodelet) driver (nodelet/nodelet) points_xyzrgb_depth_rgb (nodelet/nodelet) register_depth_rgb (nodelet/nodelet) /camera/ir/ rectify_ir (nodelet/nodelet) /camera/depth_registered/ metric (nodelet/nodelet) metric_rect (nodelet/nodelet) rectify_depth (nodelet/nodelet)

ROS_MASTER_URI=http://localhost:11311

core service [/rosout] found Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading'="" from="" '="" usr="" lib="" python2.7="" threading.pyc'=""> ignored process[camera_nodelet_manager-1]: started with pid [1922] Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading'="" from="" '="" usr="" lib="" python2.7="" threading.pyc'=""> ignored process[camera ...

(more)
2012-05-22 05:09:39 -0600 asked a question Openni_Launch on Lion with Xtion

I'm just returning to ROS after some time. How do you get openni_launch installed in OSX?

I've been able to consistently get ROS Fuerte installed on Lion. using:

http://ros.org/wiki/fuerte/Installation/OSX/Homebrew/Source

I've been able to get VirtualBox with Ubuntu and Fuerte up and running on Lion out of the box.

I've been able to dual boot and get Fuerte and the Xtion with everything working in Ubuntu on the Macbook Air.

But what I want is to get At Least OpenNI_Launch and Openni_camera etc up and running on Lion. I can run roscore, and everything is fine. But Openni_Launch is not present in OSX and obviously apt-get is not either.

How do I install Openni_Launch in an OSX environment? I found:

https://github.com/walchko/kinect

But it seems to be tailored specifically for the kinect even going as far as swapping out usb drivers...

When I get VirtualBox running on Lion with Ubuntu 64x, everything works except that the camera does not display data either in Rviz or RosTopic.

running:

roslaunch openni_launch openni.launch

does FIND the camera in the virtualbox vm of Ubuntu, and everything acts like it's about to work, but there is just no picture and on rostopic the camera node is just not displaying data?

If I could get the camera to work in my VM OR if I could get Openni_Launch to work on Lion this would be sufficient for me.

I just want to utilize to objectiveC and the App store for ROS, so I need to be able to get this running on OSX.

Any Suggestions? Thoughts??

2012-05-11 01:50:08 -0600 received badge  Teacher (source)
2012-05-11 01:50:08 -0600 received badge  Self-Learner (source)
2012-05-10 21:10:28 -0600 answered a question Ros Fuerte on Lion OSX: make -j8

http://ros.org/wiki/fuerte/Installation/OSX/Homebrew/Source

Use this install guide for lion for fuerte on osx.

2012-05-10 18:36:12 -0600 received badge  Editor (source)
2012-05-10 17:24:49 -0600 asked a question Ros Fuerte on Lion OSX: make -j8

I had to install a couple extra things to get here such as: brew install Qt I went and installed wxPython on my own. I chose: wxPython2.9-osx-cocoa-py2.7 Maybe that is my issue, but I tried: wxPython2.8-osx-unicode-py2.7 as well to no avail.

I always get to 100% then it just bombs out like below. Any ideas?

[ 98%] Building CXX object ros_comm/tools/rosbag/CMakeFiles/rosbag.dir/src/message_instance.cpp.o
[ 98%] Built target turtlesim_node
[ 98%] Building CXX object ros_comm/tools/rosbag/CMakeFiles/rosbag.dir/src/player.cpp.o
[ 98%] Building CXX object ros_comm/tools/rosbag/CMakeFiles/rosbag.dir/src/query.cpp.o
[ 98%] Building CXX object ros_comm/tools/rosbag/CMakeFiles/rosbag.dir/src/recorder.cpp.o
[ 98%] Building CXX object ros_comm/tools/rosbag/CMakeFiles/rosbag.dir/src/stream.cpp.o
[ 98%] Building CXX object ros_comm/tools/rosbag/CMakeFiles/rosbag.dir/src/time_translator.cpp.o
[ 98%] Building CXX object ros_comm/tools/rosbag/CMakeFiles/rosbag.dir/src/uncompressed_stream.cpp.o
[100%] Building CXX object ros_comm/tools/rosbag/CMakeFiles/rosbag.dir/src/view.cpp.o
Linking CXX shared library ../../lib/librxtools.dylib
ld: warning: ignoring file /System/Library/Frameworks//QuickTime.framework/QuickTime,

file was built for unsupported file format which is not the architecture being linked (x86_64) Undefined symbols for architecture x86_64: "wxNavigationEnabled<wxnonownedwindow>::SetFocus()", referenced from: vtable for rxtools::GenTopicDisplayDialog in topic_display_generated.cpp.o vtable for rxtools::TopicDisplayDialog in topic_display_dialog.cpp.o vtable for rxtools::RosoutSetupDialogBase in rosout_generated.cpp.o vtable for rxtools::TextboxDialog in rosout_generated.cpp.o vtable for rxtools::RosoutFrame in rosout_generated.cpp.o vtable for rxtools::LoggerLevelFrame in rosout_generated.cpp.o vtable for wxMDIParentFrameBase in rosout_generated.cpp.o ... "wxNavigationEnabled<wxnonownedwindow>::AcceptsFocus() const", referenced from: vtable for rxtools::GenTopicDisplayDialog in topic_display_generated.cpp.o vtable for rxtools::TopicDisplayDialog in topic_display_dialog.cpp.o vtable for rxtools::RosoutSetupDialogBase in rosout_generated.cpp.o vtable for rxtools::TextboxDialog in rosout_generated.cpp.o vtable for rxtools::RosoutFrame in rosout_generated.cpp.o vtable for rxtools::LoggerLevelFrame in rosout_generated.cpp.o vtable for wxMDIParentFrameBase in rosout_generated.cpp.o ... "wxNavigationEnabled<wxnonownedwindow>::AcceptsFocusRecursively() const", referenced from: vtable for rxtools::GenTopicDisplayDialog in topic_display_generated.cpp.o vtable for rxtools::TopicDisplayDialog in topic_display_dialog.cpp.o vtable for rxtools::RosoutSetupDialogBase in rosout_generated.cpp.o vtable for rxtools::TextboxDialog in rosout_generated.cpp.o vtable for rxtools::RosoutFrame in rosout_generated.cpp.o vtable for rxtools::LoggerLevelFrame in rosout_generated.cpp.o vtable for wxMDIParentFrameBase in rosout_generated.cpp.o ... "wxNavigationEnabled<wxnonownedwindow>::AcceptsFocusFromKeyboard() const", referenced from: vtable for rxtools::GenTopicDisplayDialog in topic_display_generated.cpp.o vtable for rxtools::TopicDisplayDialog in topic_display_dialog.cpp.o vtable for rxtools::RosoutSetupDialogBase in rosout_generated.cpp.o vtable for rxtools::TextboxDialog in rosout_generated.cpp.o vtable for rxtools::RosoutFrame in rosout_generated.cpp.o vtable for rxtools::LoggerLevelFrame in rosout_generated.cpp.o vtable for wxMDIParentFrameBase in rosout_generated.cpp.o ... "wxNavigationEnabled<wxnonownedwindow>::AddChild(wxWindowBase)", referenced from: vtable for rxtools::GenTopicDisplayDialog in topic_display_generated.cpp.o vtable for rxtools::TopicDisplayDialog in topic_display_dialog.cpp.o vtable for rxtools::RosoutSetupDialogBase in rosout_generated.cpp.o vtable for rxtools::TextboxDialog in rosout_generated.cpp.o vtable for rxtools::RosoutFrame in rosout_generated.cpp ...

(more)
2012-05-03 08:19:25 -0600 answered a question ROS installation on Mac with Homebrew--bootstrapping issues?

Run Brew doctor This told me that my xcode command tools were not installed and my path was not correct.

2012-04-30 16:01:21 -0600 answered a question problem with ros fuerte install on opensuse 11.2

If anyone else is trying this on OSX Lion please try

pip install EmPy nose
brew install swig
2012-04-30 15:56:24 -0600 answered a question problem with ros fuerte install on opensuse 11.2

pip install EmPy nose brew install swig