Ask Your Question

Roy89's profile - activity

2013-12-05 06:10:14 -0600 received badge  Nice Answer (source)
2013-11-18 21:10:15 -0600 received badge  Student (source)
2013-11-05 02:59:26 -0600 received badge  Self-Learner (source)
2013-08-15 08:30:18 -0600 received badge  Taxonomist
2013-07-18 04:14:01 -0600 received badge  Famous Question (source)
2013-07-10 02:25:13 -0600 received badge  Famous Question (source)
2013-03-02 04:49:39 -0600 received badge  Nice Answer (source)
2012-11-01 11:32:15 -0600 received badge  Notable Question (source)
2012-10-26 08:45:31 -0600 received badge  Famous Question (source)
2012-10-26 08:45:31 -0600 received badge  Popular Question (source)
2012-10-26 08:45:31 -0600 received badge  Notable Question (source)
2012-10-14 07:08:32 -0600 answered a question unable to get collvoid plugin planner for navigation stack to move the robot?

It's not supported for fuerte yet.

2012-10-08 16:48:19 -0600 received badge  Famous Question (source)
2012-10-07 17:23:56 -0600 received badge  Popular Question (source)
2012-09-21 04:47:09 -0600 received badge  Editor (source)
2012-09-21 04:42:43 -0600 asked a question unable to get collvoid plugin planner for navigation stack to move the robot?

Hello, I have been trying to get the multi robot collision avoidance package working with the navigation stack. I set up the launch files similar to the examples provided in the package and can display the costmaps, global and local plans made by the collvoid planner. When I send move_base a goal using rviz or a simple package I get a warning

[ WARN] [1348232889.899224274]: MSG to TF: Quaternion Not Properly Normalized.

I have checked the goals sent to it and they are normalized. The collvoid package doesn't correctly move the robot to the goal even though it's planned a global and local path to it. The robot just rotates from side to side and moves forward very slowly. When I use a different planner like navfn then I don't get this warning and the robot moves correctly along paths. Has anyone got this package working well with fuerte and the navigation stack?

image description

The blue line is the global plan and the purple line is the local plan. The goal was selected from publishing a selected goal from rviz on the move_base_simple/goal which already normalizes the quaternion for you.

<launch>
  <node pkg="move_base" type="move_base" respawn="false" name="move_base" output="screen">
    <param name="oscillation_timeout" value="30.0" />
    <param name="oscillation_distance" value="0.5" />
    <param name="base_global_planner" value="collvoid_simple_global_planner/CollvoidSimpleGlobalPlanner" />  
    <param name="base_local_planner" value="collvoid_local_planner/CollvoidLocalPlanner" />
    <rosparam file="$(find wambot5_2dnav)/CollvoidLocalPlanner_params.yaml" command="load" />
  </node>
</launch>

CollvoidLocalPlanner_params.yaml


controller_frequency: 10

CollvoidLocalPlanner:
  max_neighbors: 10
  neighbor_dist: 1.0
  time_horizon: 5.0
  time_horizon_obst: 5.0
  threshold_last_seen: 1.0

  scale_radius_factor: 2.0

  yaw_goal_tolerance: 3.0
  xy_goal_tolerance: 0.3
  latch_xy_goal_tolerance: false
  global_frame: /map
  wheel_base: 0.35
  time_to_holo: 0.4
  min_error_holo: 0.05
  max_error_holo: 0.10
  holo_robot: false
  delete_observations: false

  max_vel_x: 0.8
  max_vel_th: 0.1
  min_vel_x: 0.01
  min_vel_th: 0.1
  min_vel_theta_inplace: 0.05
  min_vel_y: 0.01
  max_vel_y: 0.1
  max_vel_with_obstacles: 0.2
  acc_lim_x: 1.0
  acc_lim_y: 0.0
  acc_lim_th: 0.5
  footprint_radius: 0.3
  inscribed_radius: 0.2

TrajectoryPlannerROS:
  max_vel_x: 0.50
  min_vel_x: 0.05
  max_rotational_vel: 1.0
  min_in_place_rotational_vel: 0.01
  acc_lim_th: 0.75
  acc_lim_x: 0.50
  acc_lim_y: 0.50
  holonomic_robot: false
  yaw_goal_tolerance: 3.0
  xy_goal_tolerance: 0.3
  goal_distance_bias: 0.8
  path_distance_bias: 1.0
  sim_time: 0.5
  heading_lookahead: 0.325
  oscillation_reset_dist: 0.05
  vx_samples: 6
  vtheta_samples: 20
  dwa: true

local_costmap:
  global_frame: odom
  robot_base_frame: base_link
  update_frequency: 3.0
  publish_frequency: 2.0
  static_map: false
  rolling_window: true
  width: 6.0
  height: 6.0
  resolution: 0.05

  #For this example we'll configure the costmap in voxel-grid mode
  map_type: voxel

  #Voxel grid specific parameters
  origin_z: 0.0
  z_resolution: 0.2
  z_voxels: 10
  unknown_threshold: 9
  mark_threshold: 0

  #Set the tolerance we're willing to have for tf transforms
  transform_tolerance: 0.8

  #Obstacle marking parameters
  obstacle_range: 2.5
  max_obstacle_height: 2.0
  raytrace_range: 3.0

  robot_radius: 0.35
  footprint: [[-0.279, -0.225], [-0.279, 0.225], [0.279, 0.225], [0.279, -0.225]]
  inflation_radius: 0.40
  footprint_padding: 0.01

  #Cost function parameters
  cost_scaling_factor: 10.0

  #The cost at which a cell is considered an obstacle when a ...
(more)
2012-09-10 06:32:45 -0600 commented answer Navigation costmap parameter unknown_cost_value

I used gmapping and the navigation stack with navfn planner. There's is an allow_unknown parameter in navfn that should allow plans to traverse unknown space. I can't seem to get the planner to do so though :(

2012-08-27 01:12:38 -0600 received badge  Teacher (source)
2012-08-22 10:42:19 -0600 received badge  Notable Question (source)
2012-08-16 22:41:31 -0600 received badge  Popular Question (source)
2012-08-16 22:41:31 -0600 received badge  Famous Question (source)
2012-08-16 22:41:31 -0600 received badge  Notable Question (source)
2012-08-16 22:41:04 -0600 received badge  Popular Question (source)
2012-08-16 22:39:23 -0600 received badge  Popular Question (source)
2012-08-16 22:39:23 -0600 received badge  Notable Question (source)
2012-08-01 23:21:08 -0600 commented answer hectorslam + navigation stack : obstacle inflation problem

You can change the desired rate to a lower value so you don't get a warning anymore in the yaml files for the costmap settings. What do you mean the costmaps are wrong completely wrong or just lying in unknown_space?

2012-08-01 22:54:00 -0600 answered a question exploration stack issues

I have been playing around with this problem for a while and I think I managed to get a solution. You need to delete all observation sources for just the explore cost map. Make a new local_costmap_params.yaml file with no observation sources and include this with just the explore cost map.

I created the new files costmap_explore_params.yaml and explore_costmap.yaml which are different to the settings used for the navigation costmaps.

explore_costmap_params.yaml

map_type: voxel origin_z: 0.0 z_resolution: 0.2 z_voxels: 10 unknown_threshold: 9 mark_threshold: 0 transform_tolerance: 0.3 obstacle_range: 2.5 max_obstacle_height: 2.0 raytrace_range: 3.0 footprint: [[-0.325, -0.325], [-0.325, 0.325], [0.325, 0.325], [0.46, 0.0], [0.325, -0.325]] footprint_padding: 0.01 inflation_radius: 0.55 cost_scaling_factor: 10.0 lethal_cost_threshold: 100

In the explore_costmap.yaml file you need to set static_map to true (so it will subscribe to the map topic created by gmapping), track_unknown_space to true and set unknown_cost_value as 255. explore_costmap.yaml

explore_costmap: publish_voxel_map: true global_frame: /map robot_base_frame: base_link update_frequency: 0.5 publish_frequency: 1.0 raytrace_range: 10.0 obstacle_range: 5.0 static_map: true rolling_window: false width: 100.0 height: 100.0 resolution: 0.1 origin_x: 0.0 origin_y: 0.0 track_unknown_space: true unknown_cost_value: 255 transform_tolerance: 0.5

With these settings explore will only create a costmap from the map created with gmapping. Since now the map used for navigation and the cost map in explore used for setting goals are the same the navigation stack has much more success at reaching the goals set for it.

2012-08-01 22:11:33 -0600 answered a question Navigation costmap parameter unknown_cost_value

I think I solved the problem by setting the unknown_cost_value to 255. The cost maps have a range of 0 to 255 so a value of -1 in the occupancy grid is set as 255 in the cost map. It seems to be setting the new cost maps unknown space the same as the occupancy grid from gmappings map which is what I wanted. Thanks me :)

2012-08-01 03:52:30 -0600 asked a question Navigation costmap parameter unknown_cost_value

Hello Does anyone know why the costmap_2d parameter "unknown_cost_value" cannot be set to 0 or lower. My understanding is that a costmap with static_map set to true will take in an occupancy_grid from the map topic. It then uses this unknown_cost_value to set all the corresponding cells with this value as unknown space in the newly created costmap. Since occupancy grids from the map topic have values at -1 for unknown space 0 for free space and 100 for occupied space it seems I can't set the unknown space for the cost map to be the same as the unknown_space in the map. It works fine if I set the unknown_cost_value larger then 0 to 100 for example but this then sets the unknown space in the cost map to be equal to the occupied space in the map.

2012-07-31 20:31:52 -0600 answered a question hectorslam + navigation stack : obstacle inflation problem

The navigation stack creates a set of costmaps directly from the lasers scan data and not the map created with hector or gmapping. The laserscan data may indicate a wall and this is loaded into the costmap to create the inflated obstacles. If the map from hector has not been updated yet then the inflated obstacle costmap may lie partly in unknown space. This creates problems when using hector or gmapping with the navigation and exploration packages due to the differences between the costmaps and the map. I'm not sure if anyone has figured out a way to solve this yet. The navigation tutorial uses a fully made map provided by the map server so there is less discrepancies between the costmaps and the map.

2012-07-03 05:49:58 -0600 asked a question occupancy_grid_utils missing libraries

Hi I am using ros fuerte and tried to instal the occupancy_grid_utils packaged. I used git clone https://kforge.ros.org/gridutils/git but when I tried to make it using rosmake it complained about a missing header file LocalizedCloud.h how can I fix this or is this package no longer maintained? thanks,

[rosmake-0] Starting >>> git [ make ]                                           
[ rosmake ] Last 40 linest: 2.0 sec ]                [ 1 Active 41/62 Complete ]
{-------------------------------------------------------------------------------
  [  0%] Built target rospack_genmsg_libexe
  make[3]: Entering directory `/home/calum0/ros_workspace/git/build'
  Scanning dependencies of target rosbuild_premsgsrvgen
  make[3]: Leaving directory `/home/calum0/ros_workspace/git/build'
  [  0%] Built target rosbuild_premsgsrvgen
  make[3]: Entering directory `/home/calum0/ros_workspace/git/build'
  Scanning dependencies of target ROSBUILD_genmsg_lisp
  make[3]: Leaving directory `/home/calum0/ros_workspace/git/build'
  [ 15%] Built target ROSBUILD_genmsg_lisp
  make[3]: Entering directory `/home/calum0/ros_workspace/git/build'
  Scanning dependencies of target ROSBUILD_genmsg_cpp
  make[3]: Leaving directory `/home/calum0/ros_workspace/git/build'
  [ 31%] Built target ROSBUILD_genmsg_cpp
  make[3]: Entering directory `/home/calum0/ros_workspace/git/build'
  Scanning dependencies of target ROSBUILD_genmsg_py
  make[3]: Leaving directory `/home/calum0/ros_workspace/git/build'
  [ 52%] Built target ROSBUILD_genmsg_py
  make[3]: Entering directory `/home/calum0/ros_workspace/git/build'
  Scanning dependencies of target rospack_genmsg
  make[3]: Leaving directory `/home/calum0/ros_workspace/git/build'
  [ 52%] Built target rospack_genmsg
  make[3]: Entering directory `/home/calum0/ros_workspace/git/build'
  Scanning dependencies of target rosbuild_precompile
  make[3]: Leaving directory `/home/calum0/ros_workspace/git/build'
  [ 52%] Built target rosbuild_precompile
  make[3]: Entering directory `/home/calum0/ros_workspace/git/build'
  Scanning dependencies of target grid_utils
  make[3]: Leaving directory `/home/calum0/ros_workspace/git/build'
  make[3]: Entering directory `/home/calum0/ros_workspace/git/build'
  [ 57%] Building CXX object CMakeFiles/grid_utils.dir/src/ray_tracer.o
  In file included from /home/calum0/ros_workspace/git/src/ray_tracer.cpp:1:0:
  /home/calum0/ros_workspace/git/include/occupancy_grid_utils/ray_tracer.h:5:49: fatal error: occupancy_grid_utils/LocalizedCloud.h: No such file or directory
  compilation terminated.
  make[3]: *** [CMakeFiles/grid_utils.dir/src/ray_tracer.o] Error 1
  make[3]: Leaving directory `/home/calum0/ros_workspace/git/build'
  make[2]: *** [CMakeFiles/grid_utils.dir/all] Error 2
  make[2]: Leaving directory `/home/calum0/ros_workspace/git/build'
  make[1]: *** [all] Error 2
  make[1]: Leaving directory `/home/calum0/ros_workspace/git/build'
-------------------------------------------------------------------------------}
[ rosmake ] Output from build of package git written to:
[ rosmake ]    /home/calum0/.ros/rosmake/rosmake_output-20120605-022130/git/build_output.log
[rosmake-0] Finished <<< git [FAIL] [ 2.09 seconds ]                            
[ rosmake ] Halting due to failure in package git. 
[ rosmake ] Waiting for other threads to complete.
[ rosmake ] Results:                                                            
[ rosmake ] Built 42 packages with 1 failures.                                  
[ rosmake ] Summary output to directory                                         
[ rosmake ] /home/calum0/.ros/rosmake/rosmake_output-20120605-022130            
calum0@ubuntu:~/ros_workspace/git$
2012-05-06 23:07:16 -0600 answered a question unable to change logging level in rxloggerlevel

I think it may have been something to do with the old version of ros electric messing with my environment variables as I deleted both electric and fuerte and reinstalled fuerte and things seem to be working now.

2012-05-06 20:19:20 -0600 asked a question unable to change logging level in rxloggerlevel

Hi I recently installed fuerte and have been having problems with stopping all the DEBUG logging message from slowing packages such as stage to a crawl. I have tried changing the logging level using rxloggerlevel in rxconsole but this package freezes because it too prints out DEBUG messages. I also tried using the set_logger_level service call for both stage and rxconsole but the it comes back with

calum0@ubuntu:/opt/ros/fuerte/share/rosconsole/cmake$ rosservice call /stageros/set_logger_level stage WARN ERROR: Unable to communicate with service [/stageros/set_logger_level], address [rosrpc://ubuntu:48262]

I tried to follow the direction at http://www.ros.org/wiki/rosconsole to make my own configuration file and set the logging levels that way but this hasn't worked. I set the ROSCONSOLE_CONFIG_FILE environment path variable to a config.pc file containing

log4j.logger.ros.stage=WARN

This might not have worked due to a strange message I'm receiving every time I run roscore.

log4cxx: Could not read configuration file [/opt/ros/fuerte/config/rosconsole.config].

Any help is greatly appreciated.

2012-05-03 23:19:27 -0600 received badge  Supporter (source)
2012-05-03 23:17:46 -0600 received badge  Scholar (source)
2012-04-11 00:11:48 -0600 asked a question failed to install pkg-config

Hi i'm new to ros and have been trying to install the player ros package from http://www.ros.org/wiki/player . When I run rosmake player it complains that pkg-config isn't installed. I then tried to run rosdep install player but it fails to install pkg-config.

calum0@ubuntu:~/ros_workspace/player$ rosdep install player
Failed to find rosdep pkg-config for package player on OS:ubuntu version:oneiric
rosdep install ERROR:
failed to install pkg-config
calum0@ubuntu:~/ros_workspace/player$ rosmake player
[ rosmake ] Packages requested are: ['player']                                  
[ rosmake ] Logging to directory/home/calum0/.ros/rosmake/rosmake_output-20120411-180619
[ rosmake ] Expanded args ['player'] to:
['player']                             
[ rosmake ] Checking rosdeps compliance for packages player.  This may take a few seconds.
Failed to find rosdep pkg-config for package player on OS:ubuntu version:oneiric
WARNING: Rosdeps [u'pkg-config'] could not be resolved
Failed to find rosdep pkg-config for package player on OS:ubuntu version:oneiric
[ rosmake ] rosdep check failed to find system dependencies: pkg-config         
[rosmake-0] Starting >>> player [ make ]                                        
[ rosmake ] All 9 lines
{-------------------------------------------------------------------------------
  make wipe
  make[1]: Entering directory `/home/calum0/ros_workspace/player'
  rm -rf build/player-svn/build
  rm -rf player installed wiped
  rm -rf build
  make[1]: Leaving directory `/home/calum0/ros_workspace/player'
  touch wiped
  touch: cannot touch `wiped': Permission denied
-------------------------------------------------------------------------------}
[ rosmake ] Output from build of package player written to:
[ rosmake ]    /home/calum0/.ros/rosmake/rosmake_output-20120411-180619/player/build_output.log
[rosmake-0] Finished <<< player [FAIL] [ 0.01 seconds ]                         
[ rosmake ] Halting due to failure in package player. 
[ rosmake ] Waiting for other threads to complete.
[ rosmake ] Results:                                                            
[ rosmake ] Built 1 packages with 1 failures.                                   
[ rosmake ] Summary output to directory                                         
[ rosmake ] /home/calum0/.ros/rosmake/rosmake_output-20120411-180619            
[ rosmake ] WARNING: Rosdep did not detect the following system dependencies as installed: pkg-config Consider using --rosdep-install option or `rosdep install player`
calum0@ubuntu:~/ros_workspace/player$ 

calum0@ubuntu:~/ros_workspace/player$ rosdep install player
Failed to find rosdep pkg-config for package player on OS:ubuntu version:oneiric
rosdep install ERROR:
failed to install pkg-config
calum0@ubuntu:~/ros_workspace/player$