Ask Your Question

clauniel's profile - activity

2019-04-25 05:43:10 -0600 received badge  Nice Question (source)
2018-05-15 19:34:05 -0600 received badge  Taxonomist
2017-01-16 04:40:52 -0600 received badge  Popular Question (source)
2015-07-16 17:56:30 -0600 received badge  Famous Question (source)
2015-03-26 11:15:19 -0600 received badge  Notable Question (source)
2015-03-26 11:15:19 -0600 received badge  Popular Question (source)
2015-02-21 00:45:31 -0600 received badge  Famous Question (source)
2015-01-13 00:21:56 -0600 received badge  Notable Question (source)
2015-01-09 08:29:12 -0600 received badge  Popular Question (source)
2015-01-09 05:53:07 -0600 asked a question Installing the image_view package

I cannot compile the image_view package because it requires opencv 2.4.9 while I have 2.4.10. However, I was able to compile and install the vision-opencv package so I don't see why having opencv 2.4.10 should be an issue.

Where can I configure the image_view source to build using opencv 2.4.10 instead of 2.4.9?

2015-01-09 04:19:03 -0600 received badge  Student (source)
2015-01-09 04:16:10 -0600 answered a question rosrun python executable

The issue was in the package scripts. They used "#!/usr/bin/env python" which defaults to python3 on Archlinux. I changed it to "#!/usr/bin/python2".

2015-01-09 04:13:59 -0600 commented answer rosrun python executable

Afaik, PYTHONPATH points to libraries, not the executable. Changing it did not make a difference, however you led me on the right track. Thanks!

2015-01-09 03:26:21 -0600 asked a question rosrun python executable

How do you set which python executable rosrun uses? I am on Arch linux and I assume rosrun defaults to python 3 while trying to interpret python 2.7 source, which of course fails.

EDIT: The issue was in the package scripts. They used "#!/usr/bin/env python" which defaults to python3 on Archlinux. I changed it to "#!/usr/bin/python2".

2015-01-06 05:07:26 -0600 asked a question How to update library dependencies

Hi,

I am trying to install ros-indigo-depth-image-proc from the Arch user repository. The current version is 1.12.12-1 and it requires opencv 2.4.9, but I have opencv 2.4.10 which causes the build to fail.

When I search the repository for dependencies, opencv 2.4.9 does not show up anywhere, only after the build files have been generated. How are these files generated and what process determines what version of opencv it depends on? And how do I change it to use 2.4.10 instead of 2.4.9?

2014-10-12 23:19:51 -0600 marked best answer Catkin insists on using em.py 3.4 and nosetests 3.4, when configured to use python 2.7

When I call catkin_make like this

catkin_make -DPYTHON_EXECUTABLE=/usr/bin/python2 -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so

I see this in the output

-- Using PYTHON_EXECUTABLE: /usr/bin/python2
-- Using Python nosetests: /usr/bin/nosetests-3.4
-- Using empy: /usr/lib/python3.4/site-packages/em.py

Naturally my build process fails because the python 2 executable cannot interpret these versions. How do I force catkin to use the python 2.7 versions?

2014-10-12 23:19:36 -0600 received badge  Famous Question (source)
2014-10-06 14:05:52 -0600 received badge  Notable Question (source)
2014-10-06 13:38:22 -0600 received badge  Scholar (source)
2014-10-06 13:38:13 -0600 commented answer Catkin insists on using em.py 3.4 and nosetests 3.4, when configured to use python 2.7

This is an option, but it also means you cannot use the 3.4 version for anything else anymore, right?

2014-10-06 13:36:26 -0600 received badge  Supporter (source)
2014-09-27 15:02:59 -0600 received badge  Popular Question (source)