Ask Your Question

mrsoft99's profile - activity

2017-07-16 12:24:16 -0600 answered a question Real turtlebot

I'm in the Boston area, and I have a Turtlebot2 with kobuki base and Asus 1025c laptop (teeny laptop). Email me and you

2016-11-25 16:19:10 -0600 received badge  Enlightened (source)
2016-11-25 16:19:10 -0600 received badge  Good Answer (source)
2015-06-25 05:28:31 -0600 marked best answer Help with gmapping results using (slower) rplidar on turtlebot2

I mounted my new Robopeak rplidar on the center of the turtlebot's top plate, and modified the various launch/urdf to use this scanner for gmapping. However I have not modified any of the gmapping parameters, I'm using the same files as the turtlebot gmapping tutorials.

I can teleop around and get a map, but the walls are rather thick and fuzzy. I suspect this is a result of the rplidar publishing at only 5 hz, not 50 hz as the original kinect. Or possibly because the rplidar is 360 degrees and kinect was only 57 degrees?

Does anyone know why my map doesn't show a sharp defined wall? Is the slower publishing rate responsible? What params for gmapping should I modify to optimize for the slower rate?

I tried to add a small jpg of the map image, but not enough points.

This is on Hydro/Ubuntu 12.04, using a turtlebot2 (kobuki).

thanks buddy

2015-06-25 05:27:32 -0600 marked best answer Changing RPLIDAR laser scanner motor from being always on?

(This is on Ubuntu 12.04 and Hydro, Turtlebot2 with kobuki.)

I just got a Robopeak RPLIDAR, and I'm working on mounting it to my turtlebot2. (I wanted a wider angle than the kinect could give me.) As soon as the RPLIDAR is plugged into the USB slot, the motor starts spinning (This is without even having the driver loaded). The motor is enabled by the RS232 DTR signal. When the RPLIDAR ros node starts, it also sets the DTR signal to start the motor spinning.

I often have my turtlebot on for hours (days!) at a time, even if I'm not using it. I don't like the idea of the motor spinning for hours (days!). I'm thinking of modifying the RPLIDAR ros node to implement a way to stop/start the motor. What do people think of these ideas?

1) Add a service to the rplidar node, with 3 messages: motor_on, motor_off, get_motor_status. The motor could be controlled from command line, or programatically.

2) Add a dynamic parameter to the rplidar node: motor_enable. Could still use command line or program to change.

3) Use a special case of the rplidar publishing rate. If set to 0 Hz, this would turn the motor off; if non-zero, motor would turn on.

(And I know the motor should be given time to warm up.)

thanks for your comments, buddy

2015-06-25 05:27:32 -0600 received badge  Scholar (source)
2015-03-04 22:18:05 -0600 received badge  Nice Question (source)
2014-12-19 03:58:00 -0600 received badge  Taxonomist
2014-12-18 21:31:40 -0600 received badge  Nice Answer (source)
2014-12-16 12:07:50 -0600 received badge  Teacher (source)
2014-12-16 05:42:05 -0600 answered a question rplidar driver installation problem on Ubuntu

My understanding of the best way to handle this, is to add your userid to the 'dialout' group. The dialout group allows access to the serial ports.

You can do this with the following command. ${USER} will be interpreted as your current user name, but you could manually type in the username instead.

sudo gpasswd --add ${USER} dialout

You will have to logout and then log back in before the group change is recognized.

(I'm using rplidar with ubuntu 12.04 and ros hydro.)

2014-11-06 09:30:22 -0600 answered a question ROS + Intel Galileo + RPlidar not working, but gives OK health status

I had a similar, but not exactly the same, issue running rplidar on a raspberry pi B+, using ros hydro I built from source.

My problem was resolved by using a powered USB hub for the rplidar. So try disconnecting the rplidar from the usb on the galileo, connect a powered usb hub to galileo, and the rplidar to the powered usb hub.

My issue also was led was on and system indicated good health, but no data. Although in my case, the motor was spinning!.

For me, perhaps either the power supply I was using for the B+ pi board wasn't big enough, or the B+ board itself has an issue with current needs of the rplidar, perhaps regarding starting the motor.

2014-10-31 10:01:56 -0600 received badge  Famous Question (source)
2014-10-18 08:16:40 -0600 received badge  Famous Question (source)
2014-10-17 09:40:53 -0600 received badge  Notable Question (source)
2014-10-03 04:41:32 -0600 received badge  Student (source)
2014-10-03 04:41:15 -0600 received badge  Notable Question (source)
2014-09-25 12:48:19 -0600 received badge  Popular Question (source)
2014-09-25 12:47:13 -0600 received badge  Popular Question (source)
2014-08-31 08:57:02 -0600 received badge  Enthusiast