Ask Your Question

Ahyan's profile - activity

2018-03-20 07:20:34 -0500 marked best answer turtlebot obstacle avoidance using point cloud data

I want to understand and write a C++ program in gazebo/ros to make turtlebot avoids obstacles while moving forward using pointcloud data. How to get started with this? I have already created a node to subscribe point cloud data and visualize this in rviz.

Thanks a lot

2017-07-30 21:40:45 -0500 received badge  Notable Question (source)
2017-07-30 21:40:45 -0500 received badge  Famous Question (source)
2017-07-09 05:49:04 -0500 received badge  Famous Question (source)
2017-02-07 15:12:45 -0500 received badge  Famous Question (source)
2017-01-21 10:30:48 -0500 received badge  Famous Question (source)
2017-01-21 10:30:48 -0500 received badge  Notable Question (source)
2016-05-20 03:40:57 -0500 received badge  Famous Question (source)
2016-05-08 15:35:51 -0500 marked best answer problems in following ros tutorial (make a map and navigate it)

I am trying to follow ros tutorial (make a map and navigate it). However each time I tried to use gazebo and RViz, it crushes. Please guide me how to solve the problem? Is the problem related to graphics card? My machine is using nvidia driver (NVIDIA Corporation G92 [GeForce 9800 GT] (rev a2) (prog-if 00 [VGA controller])

Thank you

2016-05-08 15:35:25 -0500 received badge  Famous Question (source)
2016-05-08 15:27:47 -0500 received badge  Popular Question (source)
2016-05-08 15:27:47 -0500 received badge  Notable Question (source)
2016-04-15 02:59:25 -0500 commented question Sending command to move kuka lbr IIWA

rostopic info /iiwa/command/cartPosition shows Unknown topic /iiwa/state/cartPosition. Actually there are only /iiwa/command and /iiwa/state topics if I use rostopic list. However rostopic echo /iiwa/state/cartPosition works. Although rostopic info /iiwa/state/cartPosition also shows same errors.

2016-04-15 01:25:35 -0500 received badge  Popular Question (source)
2016-04-14 22:26:17 -0500 commented question Sending command to move kuka lbr IIWA

I tried but didn't see any message template.

2016-04-14 04:31:09 -0500 commented question Sending command to move kuka lbr IIWA

Is this is in correct syntax? Thank you

2016-04-14 04:29:23 -0500 commented question Sending command to move kuka lbr IIWA

I used as follow: rostopic pub -1 /iiwa/command/cartPosition iiwa/IIWAMsg -- '[600.5455465250951, 1.8979595305782153, 538.6429244423919]' ERROR: Not enough arguments: * Given: [[600.5455465250951, 1.8979595305782153, 538.6429244423919]] * Expected: ['isJointControl', 'cartPosition', 'cartForces',..

2016-04-09 08:14:55 -0500 commented question Sending command to move kuka lbr IIWA

For example I tried with: rostopic echo /iiwa/command/jointAngles 0,0,0,0,0,0,0.2. It shows rostopic: error: you may only specify one input topic

2016-04-09 06:42:12 -0500 asked a question Sending command to move kuka lbr IIWA

I am trying to use the following ros communication interface to control kuka LBR IIWA. https://bitbucket.org/khansari/iiwa I tried to directly send commands to move robot accordingly using respective ros topic /iiwa/command. However it does not work. Can anybody please tell me the correct way.

Thank you

2016-03-28 01:00:19 -0500 received badge  Notable Question (source)
2016-03-26 05:59:04 -0500 received badge  Popular Question (source)
2016-03-26 01:26:17 -0500 commented question Error with IIWA: Robot is not connected...

Modified IP addresses: cabinet:160.69.69.69 (IP),255.255.255.0(netmask),I kept gateway blank. ubuntu:160.69.69.100 (IP),255.255.255.0(netmask),160.69.69.100(gateway) export ROS_MASTER_URI=http://160.69.69.100:11311 export ROS_IP=160.69.69.100 config.txt: master_ip=160.69.69.100 Still same problem.

2016-03-26 01:17:14 -0500 received badge  Associate Editor (source)
2016-03-25 05:30:20 -0500 asked a question Error with IIWA: Robot is not connected...

I am working with Kuka LBR IIWA and trying to use the package ( https://github.com/SalvoVirga/iiwa_stack ). I finished cabinet setup ( https://github.com/SalvoVirga/iiwa_st... ). Now IP addresses are:

cabinet: 192.168.168.2 (IP), 255.255.255.0 (netmask), 192.168.168.0 (gateway)

ubuntu machine: 192.168.168.1 (IP), 255.255.255.0 (netmask), 192.168.168.0 (gateway)

export ROS_MASTER_URI=http://192.168.168.1:11311 export ROS_IP=192.168.168.1

config.txt: master_ip=192.168.168.1

Then I started the ROSSmartServo application from the SmartPad and executed roscore. I can hear the robot being unlocked. However, when I try roslaunch iiwa_tool_examples iiwa_tool_command_moveit.launch, still It shows "Robot is not connected.... No LBR IIWA is connected. waiting for the robot to connect before reading"

Similar post in ( https://github.com/SalvoVirga/iiwa_st... )

Anybody please give any suggestion to fix it? Thank you

2016-03-25 05:23:48 -0500 received badge  Popular Question (source)
2016-03-25 05:23:48 -0500 received badge  Popular Question (source)
2016-03-24 01:38:17 -0500 asked a question Methods of sunrise cabinet access and login information

I am working with Kuka LBR IIWA. Currently I am having difficulty in accessing kuka sunrise cabinet controller. Can anybody tell me how to access sunrise cabinet? Also how to obtain login information (ID/PW)? I didn't get any support from Kuka support service regarding login information.

Thank you

2016-03-21 09:03:21 -0500 commented question Error with LBR IIWA: robot is not connected

ok. thank you

2016-03-19 02:42:36 -0500 asked a question Error with LBR IIWA: robot is not connected

I have recently started to work with Kuka LBR IIWA. My aim is to work with ros and make the robot simulate in gazebo. I am trying to setup ros packages ( https://github.com/SalvoVirga/iiwa_stack ) to work with Kuka LBR IIWA. I am using ubuntu 14.04 LTS and ros Indigo. I found the robot connected with an wireless setting. Therefore, I didn't change the configuration. I uploaded the sunrise project to controller with no error or red sign in IDE. I followed roscore side. Next I ping with cabinet address and got reply. I started the application on cabinet that starts the robot and emits sound of the robot unlocked. However when I run the roscore on terminal, it shows

                  "Couldn't find an AF_INET address for [[fe80]. "

For running the lunch file using

roslaunch iiwa_tool_examples iiwa_tool_read.launch

I found the error

[ERROR] [1458371985.836149274]: Robot is not connected.....  


afroza@afroza-XPS-8700:~/ros_ws$ roslaunch iiwa_tool_examples iiwa_tool_read.launch
... logging to /home/afroza/.ros/log/8b1ff4da-eda1-11e5-8d62-989096a52895/roslaunch-afroza-XPS-8700-6122.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.
started roslaunch server http://afroza-XPS-8700:41750/
SUMMARY
========
PARAMETERS
 * /iiwa/ReadRobotState/joint_position_topic: /iiwa/state/Joint...
 * /iiwa/ReadRobotState/ros_rate: 1000
 * /iiwa/publishJointStates: True
 * /iiwa/robot_description: <?xml version="1....
 * /iiwa/robot_description_kinematics/manipulator/kinematics_solver: kdl_kinematics_pl...
 * /iiwa/robot_description_kinematics/manipulator/kinematics_solver_attempts: 3
 * /iiwa/robot_description_kinematics/manipulator/kinematics_solver_search_resolution: 0.005
 * /iiwa/robot_description_kinematics/manipulator/kinematics_solver_timeout: 0.005
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_1/has_acceleration_limits: False
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_1/has_velocity_limits: True
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_1/max_acceleration: 0
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_1/max_velocity: 10
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_2/has_acceleration_limits: False
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_2/has_velocity_limits: True
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_2/max_acceleration: 0
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_2/max_velocity: 10
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_3/has_acceleration_limits: False
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_3/has_velocity_limits: True
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_3/max_acceleration: 0
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_3/max_velocity: 10
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_4/has_acceleration_limits: False
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_4/has_velocity_limits: True
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_4/max_acceleration: 0
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_4/max_velocity: 10
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_5/has_acceleration_limits: False
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_5/has_velocity_limits: True
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_5/max_acceleration: 0
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_5/max_velocity: 10
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_6/has_acceleration_limits: False
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_6/has_velocity_limits: True
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_6/max_acceleration: 0
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_6/max_velocity: 10
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_7/has_acceleration_limits: False
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_7/has_velocity_limits: True
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_7/max_acceleration: 0
 * /iiwa/robot_description_planning/joint_limits/iiwa_joint_7/max_velocity: 10
 * /iiwa/robot_description_semantic: <?xml version="1....
 * /iiwa/toolName: tool
 * /rosdistro: indigo
 * /rosversion: 1.11.16
NODES
  /iiwa/
    ReadRobotState (iiwa_tool_examples/read_robot_state)
    robot_state_publisher (robot_state_publisher/robot_state_publisher)
    rviz_afroza_XPS_8700_6122_4091623036572324931 (rviz/rviz)
ROS_MASTER_URI=http://172.31.1.2:11311
core service [/rosout] found
process[iiwa/robot_state_publisher-1]: started with pid [6143]
process[iiwa/ReadRobotState-2]: started with pid [6144]
process[iiwa/rviz_afroza_XPS_8700_6122_4091623036572324931-3]: started with pid [6145]
[ERROR] [1458371905.833199520]: Robot is not connected...
[ INFO] [1458371905.886202985]: rviz version 1.11.10
[ INFO] [1458371905.886257469]: compiled against OGRE version 1.8.1 (Byatis)
[ INFO] [1458371906.552963147]: Stereo is NOT SUPPORTED
[ INFO] [1458371906.553024826 ...
(more)
2016-03-17 04:25:32 -0500 commented answer Integrating Kuka LBR IIWA with ROS/Gazebo

I also want to simulate in Gazebo. However, it is stated that Gazebo is currently supported for only LWR IIWA R820. I am using LBR iiwa 7 R800. I would like to know whether anyone simulated this already extending the package? Also can I control my robot (R800 model) using MoveIt? Is it supported?

2016-03-17 04:16:28 -0500 commented answer Integrating Kuka LBR IIWA with ROS/Gazebo

I upgraded my machine to ubuntu 14.04 and ROS indigo. Now it is ok. Thank you

2016-03-17 04:15:00 -0500 received badge  Popular Question (source)
2016-03-11 23:01:09 -0500 commented answer Integrating Kuka LBR IIWA with ROS/Gazebo

Thank you for your response. I followed no.(3) option. However still I am getting different errors. I am considering to follow the option 1). Do you also suggest me to update current ROS hydro distribution to Indigo? Thank you

2016-03-10 22:41:23 -0500 edited question Integrating Kuka LBR IIWA with ROS/Gazebo

I have recently started to work with Kuka LBR IIWA. My aim is to work with ros and make the robot simulate in gazebo. I am trying to setup ros packages ( https://github.com/SalvoVirga/iiwa_stack ) to work with Kuka LBR IIWA. I am using ubuntu 12.04 LTS and ros hydro. I finished cabinet setup, the project is uploaded to controller with no error or red sign in IDE. However, for roscore side, when I build the workspace, I found the following error:

afroza@afroza-XPS-8700:~/my_ws$ catkin build
-------------------------------------------------------
Profile:                     default
Extending:          [cached] /opt/ros/hydro
Workspace:                   /home/afroza/my_ws
Source Space:       [exists] /home/afroza/my_ws/src
Build Space:        [exists] /home/afroza/my_ws/build
Devel Space:        [exists] /home/afroza/my_ws/devel
Install Space:     [missing] /home/afroza/my_ws/install
DESTDIR:                     None
-------------------------------------------------------
Isolate Develspaces:         False
Install Packages:            False
Isolate Installs:            False
-------------------------------------------------------
Additional CMake Args:       None
Additional Make Args:        None
Additional catkin Make Args: None
Internal Make Job Server:    True
-------------------------------------------------------
Whitelisted Packages:        None
Blacklisted Packages:        None
-------------------------------------------------------
Workspace configuration appears valid.
-------------------------------------------------------
Found '8' packages in 0.0 seconds.
Starting ==> iiwa                                                              
Starting ==> iiwa_control                                                      
Starting ==> iiwa_description                                                  
Starting ==> iiwa_gazebo                                                       
Starting ==> iiwa_msgs                                                         
Finished <== iiwa_gazebo      [ 1.0 seconds ]                                  
Finished <== iiwa             [ 1.3 seconds ]                                  
Finished <== iiwa_description [ 1.2 seconds ]                                  
Finished <== iiwa_control     [ 1.4 seconds ]                                  
Starting ==> iiwa_moveit                                                       
Finished <== iiwa_moveit      [ 0.4 seconds ]                                  
Finished <== iiwa_msgs        [ 4.8 seconds ]                                  
Starting ==> iiwa_ros                                                          

[iiwa_ros] ==> '/home/afroza/my_ws/build/iiwa_ros/build_env.sh /usr/bin/make --jobserver-fds=3,5 -j' in '/home/afroza/my_ws/build/iiwa_ros'
Scanning dependencies of target iiwa_msgs_generate_messages_cpp
[  0%] Built target iiwa_msgs_generate_messages_cpp
Scanning dependencies of target iiwa_ros
[ 50%] Building CXX object CMakeFiles/iiwa_ros.dir/src/iiwaRos.cpp.o
cc1plus: error: unrecognized command line option -std=c++11
make[2]: *** [CMakeFiles/iiwa_ros.dir/src/iiwaRos.cpp.o] Error 1
make[1]: *** [CMakeFiles/iiwa_ros.dir/all] Error 2
make: *** [all] Error 2
[iiwa_ros] <== '/home/afroza/my_ws/build/iiwa_ros/build_env.sh /usr/bin/make --jobserver-fds=3,5 -j' failed with return code '2'

Failed   <== iiwa_ros         [ 2.3 seconds ]                                  
[build] There were '1' errors:                                                 

Failed to build package 'iiwa_ros' because the following command:

# Command to reproduce:
cd /home/afroza/my_ws/build/iiwa_ros && /home/afroza/my_ws/build/iiwa_ros/build_env.sh /usr/bin/make --jobserver-fds=3,5 -j; cd -

# Path to log:
cat /home/afroza/my_ws/build/build_logs/iiwa_ros.log

Exited with return code: 2

[build] Runtime: 7.6 seconds

Please guide me to fix this. Thank you