Ask Your Question

Raghu Parvatha's profile - activity

2015-06-12 09:41:12 -0600 received badge  Famous Question (source)
2015-02-02 23:18:05 -0600 received badge  Popular Question (source)
2015-02-02 23:18:05 -0600 received badge  Popular Question (source)
2015-02-02 23:18:05 -0600 received badge  Notable Question (source)
2015-01-11 11:19:35 -0600 received badge  Famous Question (source)
2015-01-11 11:19:35 -0600 received badge  Notable Question (source)
2014-12-30 22:48:25 -0600 received badge  Notable Question (source)
2014-12-30 22:48:25 -0600 received badge  Popular Question (source)
2014-08-19 00:18:07 -0600 received badge  Student (source)
2014-07-03 16:29:55 -0600 received badge  Famous Question (source)
2014-06-29 19:25:13 -0600 received badge  Famous Question (source)
2014-06-29 09:21:53 -0600 received badge  Notable Question (source)
2014-06-29 09:21:53 -0600 received badge  Popular Question (source)
2014-06-28 22:19:40 -0600 asked a question Model importing in gazebo

I wanted to import a Gazebo model from DARPA models how can I do that without installing the DARPASim.

2014-06-28 18:59:59 -0600 received badge  Editor (source)
2014-06-28 18:21:22 -0600 asked a question Installing hydro-desktop-full: libboost unmet dependencies
The following packages have unmet dependencies:
 ps-engine : Depends: openni-dev (>= 1.5.2.23~precise) but 1.3.2.1-4+precise2 is to be installed.
 libboost1.49-dev : Conflicts: libboost1.46-dev but 1.46.1-7ubuntu3 is installed.
 libboost-graph-parallel-dev : Depends: libboost-graph-parallel1.49-dev which is a virtual package.
 libboost-serialization1.49-dev : Conflicts: libboost-serialization1.46-dev but 1.46.1-7ubuntu3 is installed.
 libboost-mpi-dev : Depends: libboost-mpi1.49-dev which is a virtual package.
 libboost-mpi-python-dev : Depends: libboost-mpi-python1.49-dev which is a virtual package.

I could reduce the errors to above

2014-06-25 22:30:02 -0600 received badge  Popular Question (source)
2014-06-25 20:09:06 -0600 commented answer Turtlebot Error

raghu@Raghu:~$ sudo apt-get install ros-hydro-turtlebot [sudo] password for raghu: Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: ros-hydro-turtlebot : Depends: ros-hydro-turtlebot-bringup but it is not going to be installed E: Unable to correct problems, you have held broken packages. raghu@Raghu:~$ sudo apt-get install ros-hydro-turtlebot-bringup Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some requi

2014-06-25 20:07:53 -0600 commented answer Turtlebot Error

raghu@Raghu:~$ rosdep init ERROR: default sources list file already exists: /etc/ros/rosdep/sources.list.d/20-default.list Please delete if you wish to re-initialize

2014-06-25 19:13:02 -0600 commented answer Turtlebot Error

I am unable to do for sudo apt-get install ros-hydro-desktop-full but can install sudo apt-get install ros-hydro-desktop

2014-06-25 16:15:13 -0600 commented answer Turtlebot Error

When I try installing using sudo apt-get install ros-hydro-turtlebot ros-hydro-turtlebot-apps ros-hydro-turtlebot-viz ros-hydro-turtlebot-simulator ros-hydro-kobuki-ftdi it gives me error message as stated above

2014-06-25 11:41:35 -0600 received badge  Notable Question (source)
2014-06-25 08:36:25 -0600 commented question Turtlebot Error

raghu@Raghu:~$ source /opt/ros/hydro/setup.bash ROS_DISTRO was set to 'groovy' before. Please make sure that the environment does not mix paths from different distributions. How to change it

2014-06-25 08:35:09 -0600 received badge  Enthusiast
2014-06-24 21:25:55 -0600 commented question Turtlebot Error

/opt/ros/groovy/share/kobuki_ftdi

2014-06-24 21:25:15 -0600 received badge  Popular Question (source)
2014-06-24 20:22:48 -0600 asked a question Gazebo Error
raghu@Raghu:~/.gazebo/cfg$ gazebo kinect.world 
Gazebo multi-robot simulator, version 1.9.5
Copyright (C) 2014 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

Gazebo multi-robot simulator, version 1.9.5
Copyright (C) 2014 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

Msg Waiting for master.Warning [parser.cc:340] Converting a deprecated source[/home/raghu/.gazebo/cfg/kinect.world].
Warning [Converter.cc:59]   Version[1.0] to Version[1.4]
  Please use the gzsdf tool to update your SDF files.
    $ gzsdf convert [sdf_file]
Warning [parser.cc:340] Converting a deprecated source[/home/raghu/.gazebo/models/sun/model.sdf].
Warning [Converter.cc:59]   Version[1.2] to Version[1.4]
  Please use the gzsdf tool to update your SDF files.
    $ gzsdf convert [sdf_file]
Msg Waiting for master
Msg Connected to gazebo master @ http://127.0.0.1:11345
Msg Publicized address: 10.0.0.10

When I try to open gazebo I am unable to do so. I am using this tutorial to do Please help I am in dire need.

2014-06-24 10:08:57 -0600 asked a question Turtlebot Error
raghu@Raghu:~$ sudo apt-get install ros-hydro-turtlebot ros-hydro-turtlebot-apps ros-hydro-turtlebot-viz ros-hydro-turtlebot-simulator ros-hydro-kobuki-ftdi
Reading package lists... Done
Building dependency tree       
Reading state information... Done
ros-hydro-kobuki-ftdi is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-hydro-turtlebot : Depends: ros-hydro-turtlebot-bringup but it is not going to be installed
 ros-hydro-turtlebot-apps : Depends: ros-hydro-turtlebot-actions but it is not going to be installed
                            Depends: ros-hydro-turtlebot-calibration but it is not going to be installed
                            Depends: ros-hydro-turtlebot-core-apps but it is not going to be installed
                            Depends: ros-hydro-turtlebot-follower but it is not going to be installed
                            Depends: ros-hydro-turtlebot-navigation but it is not going to be installed
                            Depends: ros-hydro-turtlebot-panorama but it is not going to be installed
                            Depends: ros-hydro-turtlebot-teleop but it is not going to be installed
 ros-hydro-turtlebot-simulator : Depends: ros-hydro-turtlebot-gazebo but it is not going to be installed
 ros-hydro-turtlebot-viz : Depends: ros-hydro-turtlebot-interactive-markers but it is not going to be installed
                           Depends: ros-hydro-turtlebot-rviz-launchers but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

When I try to run the turtlebot package I am facing the above errors and solution is highly appreciated.

2014-06-14 11:29:16 -0600 asked a question Unable to find shader lib. Error in Gazebo

I am facing below error when I try to run gazebo any help regarding this is highly appreciated

  Error [RTShaderSystem.cc:408] Unable to find shader lib. Shader generating will fail.terminate called after throwing an instance of 'Ogre::ItemIdentityException'   what():  OGRE EXCEPTION(5:ItemIdentityException): Cannot locate material called 'Gazebo/shadow_caster' in SceneManager::setShadowTextureCasterMaterial at /build/buildd/ogre-1.7.4/OgreMain/src/OgreSceneManager.cpp (line 5833)
2014-05-27 01:58:50 -0600 received badge  Famous Question (source)
2014-05-02 01:45:07 -0600 received badge  Notable Question (source)
2014-05-01 10:18:09 -0600 received badge  Popular Question (source)
2014-04-29 12:05:46 -0600 received badge  Scholar (source)
2014-04-29 12:04:29 -0600 asked a question Gazebo installation in Ubuntu 14.04 LTS

When I try to install Gazebo on my Ubuntu 14.04 LTS I am facing the below problem

admin@admin:~$ sudo apt-get install ros-indigo-simulator-gazebo
[sudo] password for admin: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package ros-indigo-simulator-gazebo

Is there any problem with the code I am executing? or is it the problem of Ubuntu version?

2014-04-28 18:55:17 -0600 received badge  Famous Question (source)
2014-04-28 18:51:15 -0600 received badge  Notable Question (source)
2014-04-28 18:46:39 -0600 received badge  Popular Question (source)
2014-04-28 06:04:47 -0600 received badge  Supporter (source)
2014-04-28 05:36:45 -0600 commented answer Unable to install ROS in Ubuntu 14.04 LTS

hamid thank you for your reply but as Hansg said even I am unable to install the package I am getting below error message admin@admin:~$ sudo apt-get install ros-indigo-desktop-full Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package ros-indigo-desktop-full

2014-04-28 05:35:54 -0600 commented answer Unable to install ROS in Ubuntu 14.04 LTS

Hansg91 can you please help me in installation process.

2014-04-27 15:51:47 -0600 asked a question Unable to install ROS in Ubuntu 14.04 LTS

I am unable to install ROS on my Ubuntu 14.04 LTS. Below is the error I am facing

> admin@admin:~$ sudo apt-get install ros-hydro-desktop-full
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 ros-hydro-desktop-full : Depends: ros-hydro-desktop but it is not going to be installed
                          Depends: ros-hydro-mobile but it is not going to be installed
                          Depends: ros-hydro-perception but it is not going to be installed
                          Depends: ros-hydro-simulators but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

update:

raghu@raghu:~$ sudo aptitude install ros-hydro-desktop-full
The following NEW packages will be installed:
  cmake{a} cmake-data{a} collada-dom-dev{a} collada-dom2.4-dp-base{ab} collada-dom2.4-dp-dev{a} doxygen{a} fltk1.3-doc{a} fluid{a} 
  fonts-texgyre{a} freeglut3{a} gazebo{ab} gir1.2-gtk-2.0{a} hddtemp{a} icu-devtools{a} liballegro4.4{a} liballegro4.4-plugin-alsa{a} 
  libapr1-dev{a} libaprutil1-dev{a} libasound2-dev{a} libassimp-dev{a} libassimp3{a} libatk1.0-dev{a} libavahi-client-dev{a} 
  libavahi-common-dev{a} libavcodec-dev{a} libavformat-dev{a} libavutil-dev{a} libboost-all-dev{a} libboost-atomic-dev{a} 
  libboost-atomic1.54-dev{a} libboost-atomic1.54.0{a} libboost-chrono-dev{a} libboost-chrono1.54-dev{a} libboost-chrono1.54.0{a} 
  libboost-context-dev{a} libboost-context1.54-dev{a} libboost-context1.54.0{a} libboost-coroutine-dev{a} libboost-coroutine1.54-dev{a} 
  libboost-date-time-dev{a} libboost-date-time1.54-dev{a} libboost-dev{a} libboost-exception-dev{a} libboost-exception1.54-dev{a} 
  libboost-filesystem-dev{a} libboost-filesystem1.54-dev{a} libboost-filesystem1.54.0{a} libboost-graph-dev{a} 
  libboost-graph-parallel-dev{a} libboost-graph-parallel1.54-dev{a} libboost-graph-parallel1.54.0{a} libboost-graph1.54-dev{a} 
  libboost-graph1.54.0{a} libboost-iostreams-dev{a} libboost-iostreams1.54-dev{a} libboost-locale-dev{a} libboost-locale1.54-dev{a} 
  libboost-locale1.54.0{a} libboost-log-dev{a} libboost-log1.54-dev{a} libboost-log1.54.0{a} libboost-math-dev{a} libboost-math1.54-dev{a} 
  libboost-math1.54.0{a} libboost-mpi-dev{a} libboost-mpi-python-dev{a} libboost-mpi-python1.54-dev{a} libboost-mpi-python1.54.0{a} 
  libboost-mpi1.54-dev{a} libboost-mpi1.54.0{a} libboost-program-options-dev{a} libboost-program-options1.54-dev{a} 
  libboost-program-options1.54.0{a} libboost-python-dev{a} libboost-python1.54-dev{a} libboost-python1.54.0{a} libboost-random-dev{a} 
  libboost-random1.54-dev{a} libboost-random1.54.0{a} libboost-regex-dev{a} libboost-regex1.54-dev{a} libboost-regex1.54.0{a} 
  libboost-serialization-dev{a} libboost-serialization1.54-dev{a} libboost-serialization1.54.0{a} libboost-signals-dev{a} 
  libboost-signals1.54-dev{a} libboost-signals1.54.0{a} libboost-system-dev{a} libboost-system1.54-dev{a} libboost-test-dev{a} 
  libboost-test1.54-dev{a} libboost-test1.54.0{a} libboost-thread-dev{a} libboost-thread1.54-dev{a} libboost-thread1.54.0{a} 
  libboost-timer-dev{a} libboost-timer1.54-dev{a} libboost-timer1.54.0{a} libboost-tools-dev{a} libboost-wave-dev{a} 
  libboost-wave1.54-dev{a} libboost-wave1.54.0{a} libboost1.54-dev{a} libboost1.54-tools-dev{a} libbullet-dev{a} libbulletcollision2.81{a} 
  libbulletdynamics2.81{a} libbulletsoftbody2.81{a} libbz2-dev{a} libcaca-dev{a} libcairo-script-interpreter2{a} libcairo2-dev{a} 
  libcegui-mk2-0.7.6{a} libcegui-mk2-dev{a} libcf0{a} libcppunit-1.13-0{a} libcppunit-dev{a} libcr0{a} libcurl4-openssl-dev{a} 
  libdbus-1-dev{a} libdevil-dev{a} libdevil1c2{a} libeigen3-dev{a} libexpat1-dev{a} libflann-dev{a} libflann1.8{a} libfltk-cairo1.3{a} 
  libfltk-forms1.3{a ...
(more)