Ask Your Question

Rizwan's profile - activity

2019-02-24 14:50:45 -0500 received badge  Famous Question (source)
2017-04-20 17:30:37 -0500 marked best answer openni2 launcher issue

when i try to launch "roslaunch openni2_launch openni2_launch" command, this command is for the kinect but the openni1 command doesn't open or connect to the usb interface.But the openni2 can connect to the asus kinect (primesense) it can detect the usb interface without any errors. In the rviz software there is no images and also the camera together with Openni2 launch. Openni2 camera.

how to solve the kinect issue, please help me with the kinect issue please thanks.

2015-11-02 01:17:29 -0500 received badge  Famous Question (source)
2015-11-02 01:17:29 -0500 received badge  Notable Question (source)
2015-07-16 12:01:57 -0500 received badge  Famous Question (source)
2014-10-22 19:16:28 -0500 received badge  Notable Question (source)
2014-10-13 15:54:44 -0500 received badge  Famous Question (source)
2014-10-13 15:54:44 -0500 received badge  Notable Question (source)
2014-08-20 12:57:18 -0500 received badge  Famous Question (source)
2014-07-14 17:39:03 -0500 received badge  Famous Question (source)
2014-07-01 22:48:30 -0500 received badge  Notable Question (source)
2014-05-29 18:28:23 -0500 commented question waiting for the map problem

same problem

2014-05-18 16:48:35 -0500 commented question turtlebot2 navigate using hokuyo laser scanner

the saved map is taking a long time to open till about 2 hrs. the map is not opened in the ros map saver map server command which will open in the rviz displayer. thx.. for the help..

2014-05-18 16:45:19 -0500 received badge  Popular Question (source)
2014-05-13 17:06:39 -0500 asked a question turtlebot2 navigate using hokuyo laser scanner

how to saver the map, i have an error with is tf connection problems. using hydro, ubuntu 12.04 pls help thks.

2014-05-12 05:40:01 -0500 received badge  Famous Question (source)
2014-05-11 15:03:43 -0500 answered a question kinect for windows not detected in the ubuntu 12.04 hydro

#!/bin/sh -e

usage=" Usage: $0 [OPTIONS] Installs PrimeSense Sensor Driver to current machine.

-i,--install Installs PrimeSense Sensor Driver (default mode) -u,--uninstall Uninstalls PrimeSense Sensor Driver. -c,--cross-compile-rootfs <path> Used for cross-compiling. Installs PrimeSense Sensor Driver to <path> instead of '/'. -h,--help Shows this help screen. "

OS_NAME=uname -s

#--avin mod-- case $OS_NAME in Darwin) MODULES="libXnDeviceSensorV2KM.dylib libXnDeviceFile.dylib" ;; *) MODULES="libXnDeviceSensorV2KM.so libXnDeviceFile.so" ;; esac

RULES_FILE="55-primesense-usb.rules" #--avin mod-- MODPROBE_BLACKLIST="blacklist-gspca-kinect.conf"

create file list

SCRIPT_DIR=pwd/dirname $0

LIB_FILES=ls $SCRIPT_DIR/Lib/* BIN_FILES=ls $SCRIPT_DIR/Bin/*

rootfs=

parse command line

while [ "$1" ]; do case $1 in -i|--install) install=yes ;; -u|--uninstall) uninstall=yes ;; -c|--cross-staging-dir) shift rootfs=$1 ;; -h|--help) echo "$usage" exit 0 ;; *) echo "Unrecognized option $1" exit 1 esac shift done

default mode is install

if [ ! "$install" = yes ] && [ ! "$uninstall" = yes ]; then install=yes fi

validity check

if [ "$install" = yes ] && [ "$uninstall" = yes ]; then echo "-i and -u flags cannot be used together!" exit 1 fi

INSTALL_LIB=$rootfs/usr/lib INSTALL_BIN=$rootfs/usr/bin INSTALL_ETC=$rootfs/usr/etc/primesense INSTALL_RULES=$rootfs/etc/udev/rules.d SERVER_LOGS_DIR=$rootfs/var/log/primesense/XnSensorServer #--avin mod-- MODPROBE_CONF_DIR=$rootfs/etc/modprobe.d

make all calls into OpenNI run in this filesystem

export OPEN_NI_INSTALL_PATH=$rootfs

make sure the staging dir OpenNI is the one being run

export LD_LIBRARY_PATH=$INSTALL_LIB

if [ "$install" = yes ]; then printf "Installing PrimeSense Sensor\n" printf "********\n\n"

# create config dir
printf "creating config dir $INSTALL_ETC..."
mkdir -p $INSTALL_ETC
printf "OK\n"

# Copy shared libraries
printf "copying shared libraries..."
cp $LIB_FILES $INSTALL_LIB
printf "OK\n"

# Copy executables
printf "copying executables..."
cp $BIN_FILES $INSTALL_BIN
printf "OK\n"

# register modules
for module in $MODULES; do
    printf "registering module '$module' with OpenNI..."
    $INSTALL_BIN/niReg -r $INSTALL_LIB/$module $INSTALL_ETC
    printf "OK\n"
done

# copy config file
printf "copying server config file..."

#--avin mod-- cp Config/GlobalDefaultsKinect.ini $INSTALL_ETC printf "OK\n"

# make server run as root
printf "setting uid of server..."
chown root $INSTALL_BIN/XnSensorServer
chmod +s $INSTALL_BIN/XnSensorServer
printf "OK\n"

# create server log dir
printf "creating server logs dir..."
mkdir -p $SERVER_LOGS_DIR
# make this dir readable and writable by all (we allow anyone to delete logs)
chmod a+w $SERVER_LOGS_DIR
printf "OK\n"

if [ "`uname -s`" != "Darwin" ]; then
    # install USB rules (so that PrimeSense sensors will be mounted with write permissions)
    printf "installing usb rules..."
    cp Install/$RULES_FILE $INSTALL_RULES
    printf "OK\n"
    #--avin mod--
    printf "installing modprobe blacklist..."
    cp Install/$MODPROBE_BLACKLIST $MODPROBE_CONF_DIR
    printf "OK\n"
fi

printf "\n*** DONE ***\n\n"

elif [ "$uninstall" = yes ]; then

printf "Uninstalling PrimeSense Sensor\n"
printf "******************************\n\n"

# unregister modules
for module in $MODULES; do
    printf "unregistering module '$module' from OpenNI..."
    if $INSTALL_BIN/niReg -u $INSTALL_LIB/$module; then
        printf "OK\n"
    fi
done

# delete shared libraries
printf "removing shared libraries..."
for filename in $LIB_FILES; do
    rm -f $INSTALL_LIB/`basename $filename`
done
printf "OK\n"

# delete executables
printf "removing executables..."
for filename in $BIN_FILES; do
    rm -f $INSTALL_BIN/`basename $filename`
done
printf "OK\n"

# delete config dir
printf "removing config dir..."
rm -rf $INSTALL_ETC ...
(more)
2014-05-09 02:01:06 -0500 received badge  Notable Question (source)
2014-05-08 21:00:33 -0500 commented answer kinect for windows not detected in the ubuntu 12.04 hydro

i followed the steps but the last part at sudo ./install.sh is not working.

2014-05-08 20:58:55 -0500 commented answer kinect for windows not detected in the ubuntu 12.04 hydro

when i key in "$ sudo ./install.sh", this command in the terminal gives me "no such files or directory".

2014-05-08 17:57:13 -0500 commented answer kinect for windows not detected in the ubuntu 12.04 hydro

i tried to run the code but the execution displayed me No such file or directory. Is still not working please help Thanks.

2014-05-08 17:43:42 -0500 received badge  Popular Question (source)
2014-05-07 22:17:47 -0500 commented answer kinect for windows not detected in the ubuntu 12.04 hydro

to get the code is workable but installing the code .sr1@sr1-ThinkPad-T430:~/SensorKinect/Platform/Linux/Redist$ cd Sensor-Bin-Linux-x64-v5.1.2.1/ .bash: cd: Sensor-Bin-Linux-x64-v5.1.2.1/: No such file or directory .sr1@sr1-ThinkPad-T430:~/SensorKinect/Platform/Linux/Redist $ sudo ./install.sh .sudo: ./install.sh: command not found Thanks for the help but is still not able to work.

2014-05-07 18:51:56 -0500 asked a question kinect for windows not detected in the ubuntu 12.04 hydro

hello, this is rizwan here please help my kinect for windows can be detected in the dmesg, but why is not detected in the lsusb, so because of that i cannot launch the rviz and display the kinect and usually it prompt me that device not connected. so please help me to teach me how to install and get the device run please. Thanks.

2014-05-05 18:11:21 -0500 received badge  Popular Question (source)
2014-05-01 17:53:14 -0500 commented answer Xsens error comunicating with Ubuntu 12.04

hi,after Configuration steps 1. Attach IMU via USB 2. sudo chmod 777 /dev/ttyUSB0 3. rosrun xsens_driver mtdevice.py --configure --output-mode=coapvs --output-settings=tqMAG after this step in the terminal, [rospack] Error: stack/package xsens_driver not found i receive this error and i cannot continue Please help ... i m using xsens MTI-G700 on ubuntu 12.04 hydro. Thanks.

2014-04-30 05:56:46 -0500 received badge  Famous Question (source)
2014-04-29 22:12:33 -0500 received badge  Famous Question (source)
2014-04-29 17:48:24 -0500 commented answer hydro xsens driver

i tried to do the step then i don't now how to run i am also using it for the first time and new to ROS application. How do i carry on on the launching of the xsens IMU. Please help me a special thanks to mr adrendo sir. Please help me.

2014-04-29 17:15:05 -0500 commented answer hydro xsens driver

[rospack] Error: stack/package receive_xsens not found

2014-04-28 18:45:49 -0500 received badge  Notable Question (source)
2014-04-28 18:38:16 -0500 received badge  Popular Question (source)
2014-04-28 18:23:21 -0500 commented answer hydro xsens driver

but how to do dialout group, please help if anyone know. Thanks.

2014-04-27 22:54:26 -0500 answered a question hydro xsens driver

But how to install and run the MTi-G700 IMU unit, the driver is not recognized by the usb port and i also using ubuntu 12.04 hydro version. Please help thanks.

2014-04-27 18:55:08 -0500 received badge  Scholar (source)
2014-04-24 22:33:02 -0500 asked a question hydro xsens driver

how to install and run the MTi-G Xsens device is a IMU device. Pls help and reply me thx.

2014-04-23 22:42:28 -0500 commented answer OpenNI launching error process[camera/driver-3]

the packages installed successfully but the kinect driver still not recognize the driver of the usb.

2014-04-23 22:42:28 -0500 received badge  Commentator
2014-04-23 21:24:09 -0500 commented question libfreenect cannot find kinect

is it able to work in Linux envrionment Ubuntu 12.04 Hydro

2014-04-23 21:01:28 -0500 received badge  Editor (source)
2014-04-23 21:00:28 -0500 asked a question kinect driver problems

Hey everyone,

i think i have s similar problem, which could not be solved by killing the xnsensorserver. let me explain: i'm running ros hydro, ubuntu 12.04 and installed openni by "sudo apt-get install ros-hydro-openni-launch". after running "roslaunch openni_launch openni.launch". Openni starts, but in the end it says

" No devices connected.... waiting for devices to be connected "

lsusb lists 3 microsoft devices,- as it should. my kinect led is blinking green. the output of "rostopic list" is

" eddi@Eddi:~$ rostopic list /rosout /rosout_agg "

When i try "killall XnSensorServer" it says "XnSensorServer: Kein Prozess gefunden" (no process found) "XnSensorServer" --> "XnSensorServer: Befehl nicht gefunden" (command not found)

thanks for your help!

2014-04-20 14:23:44 -0500 marked best answer how to connect to wireless connection

i cannot connect to the ubuntu 12.04 wireless connection

2014-04-20 06:57:09 -0500 marked best answer how to ping the IP_OF_WORKSTATION

what is the procedure of how to ping this when i am using the turtle bot system and the OS is the Ubuntu 12.04 version it prompt me for "unknown host IP_OF_WORKSTATION"