Ask Your Question

SimonC's profile - activity

2013-01-23 13:33:46 -0500 received badge  Famous Question (source)
2013-01-23 13:33:46 -0500 received badge  Popular Question (source)
2013-01-23 13:33:46 -0500 received badge  Notable Question (source)
2011-10-11 03:41:27 -0500 received badge  Student (source)
2011-10-11 01:20:04 -0500 commented answer No debugging symbols found in base_local_planner library
Thanks that was it! Not sure why I didn't spot the option...!
2011-10-11 01:18:23 -0500 marked best answer No debugging symbols found in base_local_planner library

The base_local_planner has the build type set to "Release" in the CMakeLists.txt which does not include debug symbols. Change it to RelWithDebug and recompile to get debugging symbols. Usually the release type should be commented out in released code to allow the system builder to change the build type for the whole system. You might want to open a ticket about this for the base_local_planner package.

2011-10-11 01:18:23 -0500 received badge  Scholar (source)
2011-10-11 01:17:51 -0500 received badge  Supporter (source)
2011-10-10 16:01:06 -0500 asked a question No debugging symbols found in base_local_planner library

Hey everyone,

I'm new to ROS. At the moment I'm using Eclipse CDT to debug the move_base node, more specifically the default local planner (base_local_planner/TrajectoryPlannerROS). When I start the move_base node, Eclipse can apparently find the debugging symbols for all the necessary packages (navfn, costmap_2d, etc) except for base_local_planner (libbase_local_planner.so). Indeed when I run the command "file libbase_local_planner.so" inside gdb, it tells me there's no debug symbol for that library.

I've tried to make sure the "-g" option was actually used to link the library, but I admit I got lost in the cmake files.

However I don't remember changing any linking option anywhere... anyone's got a clue to what may cause the problem? (and are the debugging symbols for this library present in your setup?)

Thanks, Simon C