ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

shangl's profile - activity

2021-01-22 17:28:39 -0500 received badge  Famous Question (source)
2016-09-01 12:15:03 -0500 received badge  Notable Question (source)
2016-04-07 08:13:43 -0500 received badge  Popular Question (source)
2016-04-07 07:44:29 -0500 commented question modelling floor with moveit

hi gvdhoorn. thanks for your response thats how we did it in the end. its kind of disappointing that moveit only provides such a "hacky" solution

2016-04-06 08:35:08 -0500 received badge  Student (source)
2016-04-06 08:33:18 -0500 asked a question modelling floor with moveit

hi,

i would like to model an (infinite) flat floor such that moveit can't plan crashes with the floor. is that possible?

cheers simon

2014-09-11 05:33:29 -0500 received badge  Famous Question (source)
2014-02-26 07:55:13 -0500 received badge  Notable Question (source)
2014-02-12 03:43:52 -0500 received badge  Popular Question (source)
2014-02-12 01:35:52 -0500 commented answer debugging with eclipse

do i have to pass some special arguments to it? when i call a binary working perfectly fine with rosrun, it crashes with a segmentation fault

2014-02-11 04:32:59 -0500 asked a question debugging with eclipse

hi, i struggle a lot with using ros with eclipse

first of all, i did all that is standing on the ros with IDE page. i can import the project to eclipse and build it. the indexer is absolutely not working (it recognizes rosnode etc, but i get errors like "namespace std is amgiguous" - i use eclipse kepler). however, for now i just ignored that, because i can still do some autocompletion stuff etc.. building works fine, but when it comes to debug the program, i have no clue what to do. the tutorial says:

"Create a new launch configuration, by clicking on Run --> Run configurations... --> C/C++ Application (double click or click on New). Select the correct binary on the main tab (Search project should work when your binary was already built). Then in the environment tab, add (at least)" --> which binary? i cannot execute the binary directly, right? i have to use rosrun. so what should be in there? i dont see any binaries listed when i click on "search project"

2014-02-11 04:17:24 -0500 answered a question ros debug to runtime

hi, i still dont get it. i uese eclipse, but i cannot configure the "run configuration". the online tutorial says, i should see a list of executables when i click on "search project", but there is nothing. if i type in there rosrun ..., i can execute but not debug it says "Program is not a recognized executable.". however, i can build the whole package without problems, but indexer is not working for me as well. all in all, it is a huge mess