Ask Your Question

Revision history [back]

Kinect vs. PSDK5.0 Registration Speed

I have 2 Kinects and a PSDK 5.0, I'm running Ubuntu 10.10 and the latest debian-based install of Diamondback. Both of the Kinects work fine with openni_camera (of the openni_kinect stack) generating either /camera/depth/points or /camera/rgb/points outputs at high speed. However, with my PSDK, I can only seem to get reliable depth point clouds. Issues are:

  • Only the VGA 30hz mode works for XYZRGB clouds, and at only about 8hz.
  • If I connect to /camera/rgb/image_color while viewing only the XYZ cloud I can get a 30hz update rate on the image and the XYZ cloud, so it doesn't appear to be an issue with USB bandwidth.
  • Turning on registration, even without a subscriber on /camera/rgb/points appears to significantly slow things down.

Any thoughts? This machine is a quad-core i7 with 8GB of RAM, and the registration runs fine on the Kinect devices...

Kinect vs. PSDK5.0 Registration Speed

I have 2 Kinects and a PSDK 5.0, I'm running Ubuntu 10.10 and the latest debian-based install of Diamondback. Both of the Kinects work fine with openni_camera (of the openni_kinect stack) generating either /camera/depth/points or /camera/rgb/points outputs at high speed. However, with my PSDK, I can only seem to get reliable depth point clouds. Issues are:

  • Only the VGA 30hz mode works for XYZRGB clouds, and at only about 8hz.
  • If I connect to /camera/rgb/image_color while viewing only the XYZ cloud I can get a 30hz update rate on the image and the XYZ cloud, so it doesn't appear to be an issue with USB bandwidth.
  • Turning on registration, even without a subscriber on /camera/rgb/points appears to significantly slow things down.

Any thoughts? This machine is a quad-core i7 with 8GB of RAM, and the registration runs fine on the Kinect devices...

Kinect vs. PSDK5.0 Registration Speed

I have 2 Kinects and a PSDK 5.0, I'm running Ubuntu 10.10 and the latest debian-based install of Diamondback. Both of the Kinects work fine with openni_camera (of the openni_kinect stack) generating either /camera/depth/points or /camera/rgb/points outputs at high speed. However, with my PSDK, I can only seem to get reliable depth point clouds. Issues are:

  • Only the VGA 30hz mode works for XYZRGB clouds, and at only about 8hz.
  • If I connect to /camera/rgb/image_color while viewing only the XYZ cloud I can get a 30hz update rate on the image and the XYZ cloud, so it doesn't appear to be an issue with USB bandwidth.
  • Turning on registration, even without a subscriber on /camera/rgb/points appears to significantly slow things down.

Any thoughts? This machine is a quad-core i7 with 8GB of RAM, and the registration runs fine on the Kinect devices...

Kinect vs. PSDK5.0 Registration Speed

I have 2 Kinects and a PSDK 5.0, I'm running Ubuntu 10.10 and the latest debian-based install of Diamondback. Both of the Kinects work fine with openni_camera (of the openni_kinect stack) generating either /camera/depth/points or /camera/rgb/points outputs at high speed. However, with my PSDK, I can only seem to get reliable depth point clouds. Issues are:

  • Only the VGA 30hz mode works for XYZRGB clouds, and at only about 8hz.
  • If I connect to /camera/rgb/image_color while viewing only the XYZ cloud I can get a 30hz update rate on the image and the XYZ cloud, so it doesn't appear to be an issue with USB bandwidth.
  • Turning on registration, even without a subscriber on /camera/rgb/points appears to significantly slow things down.

Any thoughts? This machine is a quad-core i7 with 8GB of RAM, and the registration runs fine on the Kinect devices...

Kinect vs. PSDK5.0 Registration Speed

I have 2 Kinects and a PSDK 5.0, I'm running Ubuntu 10.10 and the latest debian-based install of Diamondback. Both of the Kinects work fine with openni_camera (of the openni_kinect stack) generating either /camera/depth/points or /camera/rgb/points outputs at high speed. However, with my PSDK, I can only seem to get reliable depth point clouds. Issues are:

  • Only the VGA 30hz mode works for XYZRGB clouds, and at only about 8hz.
  • If I connect to /camera/rgb/image_color while viewing only the XYZ cloud I can get a 30hz update rate on the image and the XYZ cloud, so it doesn't appear to be an issue with USB bandwidth.
  • Turning on registration, even without a subscriber on /camera/rgb/points appears to significantly slow things down.

Any thoughts? This machine is a quad-core i7 with 8GB of RAM, and the registration runs fine on the Kinect devices...