Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

gmapping : no transform from /map->odom_combined

I recently try to run SLAM gmapping on PR2. Here's my procedure:

1.roslaunch gmapping slam_gmapping_pr2.launch on PR2. I've set the parameter odom_frame to odom_combined to suit PR2.

2.roslaunch pr2_teleop teleop_joystick.launch on my computer to move the robot around.

3.rosrun rviz rviz on my computer to show the map

However, the gmapping node would not publish the transform from /map->odom_combined. Therefore, if I want to show the Map, I have to manually set the fixed frame to /map, which does not exist. I can show the map and it will expand when I teleop the robot around. Only the transform is missing.

What might the problem be? Thanks for any advise.

gmapping : no transform from /map->odom_combined

I recently try to run SLAM gmapping on PR2. Here's my procedure:

1.roslaunch gmapping slam_gmapping_pr2.launch on PR2. I've set the parameter odom_frame to odom_combined to suit PR2.

2.roslaunch pr2_teleop teleop_joystick.launch on my computer to move the robot around.

3.rosrun rviz rviz on my computer to show the map

However, the gmapping node would not publish the transform from /map->odom_combined. Therefore, if I want to show the Map, I have to manually set the fixed frame to /map, which does not exist. I can show the map and it will expand when I teleop the robot around. Only the transform is missing.

What might the problem be? Thanks for any advise.

gmapping : no transform from /map->odom_combined

I recently try to run SLAM gmapping on PR2. Here's my procedure:

1.roslaunch gmapping slam_gmapping_pr2.launch on PR2. I've set the parameter odom_frame to odom_combined to suit PR2.

2.roslaunch pr2_teleop teleop_joystick.launch on my computer to move the robot around.

3.rosrun rviz rviz on my computer to show the map

However, the gmapping node would not publish the transform from /map->odom_combined. Therefore, if I want to show the Map, I have to manually set the fixed frame to /map, which does not exist. I can show the map and it will expand when I teleop the robot around. Only the transform is missing.

What might the problem be? Thanks for any advise.