Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Installing an older version of a ros package by source

I currently have version 1.8.9 of openni_camera, and I'd like to revert back to an older version of it. The source is found here.

This is actually a commit between versions 1.8.8 and 1.8.9. Does anyone know how I can go about installing this package through source?

I've previously installed openni_camera as a deb package, and have uninstalled it using sudo apt-get --purge remove ros-groovy-openni-camera. What I've tried so far is putting the source folder into my catkin workspace (~/catkin_ws/src), and using catkin_make in ~/catkin_ws, but I'm faced with an error:

$ catkin_make
Base path: /home/andrew/catkin_ws
Source space: /home/andrew/catkin_ws/src
Build space: /home/andrew/catkin_ws/build
Devel space: /home/andrew/catkin_ws/devel
Install space: /home/andrew/catkin_ws/install
####
#### Running command: "cmake /home/andrew/catkin_ws/src -DCATKIN_DEVEL_PREFIX=/home/andrew/catkin_ws/devel -DCMAKE_INSTALL_PREFIX=/home/andrew/catkin_ws/install" in "/home/andrew/catkin_ws/build"
####
-- Using CATKIN_DEVEL_PREFIX: /home/andrew/catkin_ws/devel
-- Using CMAKE_PREFIX_PATH: /home/andrew/catkin_ws/devel;/opt/ros/groovy
-- This workspace overlays: /home/andrew/catkin_ws/devel;/opt/ros/groovy
-- Using Debian Python package layout
-- Using CATKIN_ENABLE_TESTING: ON
-- Call enable_testing()
-- Using CATKIN_TEST_RESULTS_DIR: /home/andrew/catkin_ws/build/test_results
-- Found gtest sources under '/usr/src/gtest': gtests will be built
-- catkin 0.5.71
-- BUILD_SHARED_LIBS is on
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- ~~  traversing 2 packages in topological order:
-- ~~  - openni_camera
-- ~~  - servo
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- +++ processing catkin package: 'openni_camera'
-- ==> add_subdirectory(openni_camera)
-- Boost version: 1.49.0
-- Found the following Boost libraries:
--   system
--   filesystem
--   thread
CMake Error at /opt/ros/groovy/share/dynamic_reconfigure/cmake/extras.cmake:47 (message):
  Could not run dynamic reconfigure file 'cfg/OpenNI.cfg':
  /home/andrew/catkin_ws/build/catkin_generated/env_cached.sh: 10: exec:
  /home/andrew/catkin_ws/src/openni_camera/cfg/OpenNI.cfg: Permission denied
Call Stack (most recent call first):
  openni_camera/CMakeLists.txt:11 (generate_dynamic_reconfigure_options)


-- Configuring incomplete, errors occurred!
Invoking "cmake" failed

I'm running Ubuntu 12.10 on ROS Groovy. Please help!

Installing an older version of a ros package by source

I currently have used to run version 1.8.9 of openni_camera, and I'd like to revert back to an older version of it. The source is found here.

This is actually a commit between versions 1.8.8 and 1.8.9. Does anyone know how I can go about installing this package through source?

I've previously installed openni_camera as a deb package, and have uninstalled it using sudo apt-get --purge remove ros-groovy-openni-camera. What I've tried so far is putting the source folder into my catkin workspace (~/catkin_ws/src), and using catkin_make in ~/catkin_ws, but I'm faced with an error:

$ catkin_make
Base path: /home/andrew/catkin_ws
Source space: /home/andrew/catkin_ws/src
Build space: /home/andrew/catkin_ws/build
Devel space: /home/andrew/catkin_ws/devel
Install space: /home/andrew/catkin_ws/install
####
#### Running command: "cmake /home/andrew/catkin_ws/src -DCATKIN_DEVEL_PREFIX=/home/andrew/catkin_ws/devel -DCMAKE_INSTALL_PREFIX=/home/andrew/catkin_ws/install" in "/home/andrew/catkin_ws/build"
####
-- Using CATKIN_DEVEL_PREFIX: /home/andrew/catkin_ws/devel
-- Using CMAKE_PREFIX_PATH: /home/andrew/catkin_ws/devel;/opt/ros/groovy
-- This workspace overlays: /home/andrew/catkin_ws/devel;/opt/ros/groovy
-- Using Debian Python package layout
-- Using CATKIN_ENABLE_TESTING: ON
-- Call enable_testing()
-- Using CATKIN_TEST_RESULTS_DIR: /home/andrew/catkin_ws/build/test_results
-- Found gtest sources under '/usr/src/gtest': gtests will be built
-- catkin 0.5.71
-- BUILD_SHARED_LIBS is on
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- ~~  traversing 2 packages in topological order:
-- ~~  - openni_camera
-- ~~  - servo
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- +++ processing catkin package: 'openni_camera'
-- ==> add_subdirectory(openni_camera)
-- Boost version: 1.49.0
-- Found the following Boost libraries:
--   system
--   filesystem
--   thread
CMake Error at /opt/ros/groovy/share/dynamic_reconfigure/cmake/extras.cmake:47 (message):
  Could not run dynamic reconfigure file 'cfg/OpenNI.cfg':
  /home/andrew/catkin_ws/build/catkin_generated/env_cached.sh: 10: exec:
  /home/andrew/catkin_ws/src/openni_camera/cfg/OpenNI.cfg: Permission denied
Call Stack (most recent call first):
  openni_camera/CMakeLists.txt:11 (generate_dynamic_reconfigure_options)


-- Configuring incomplete, errors occurred!
Invoking "cmake" failed

I'm running Ubuntu 12.10 on ROS Groovy. Please help!

Installing an older version of a ros package by source

I used to run version 1.8.9 of openni_camera, and I'd like to revert back to an older version of it. The source is found here.

This is actually a commit between versions 1.8.8 and 1.8.9. Does anyone know how I can go about installing this package through source?

I've previously installed openni_camera as a deb package, and have uninstalled it using sudo apt-get --purge remove ros-groovy-openni-camera. What I've tried so far is putting the source folder into my catkin workspace (~/catkin_ws/src), and using catkin_make in ~/catkin_ws, but I'm faced with an error:

$ catkin_make
Base path: /home/andrew/catkin_ws
Source space: /home/andrew/catkin_ws/src
Build space: /home/andrew/catkin_ws/build
Devel space: /home/andrew/catkin_ws/devel
Install space: /home/andrew/catkin_ws/install
####
#### Running command: "cmake /home/andrew/catkin_ws/src -DCATKIN_DEVEL_PREFIX=/home/andrew/catkin_ws/devel -DCMAKE_INSTALL_PREFIX=/home/andrew/catkin_ws/install" in "/home/andrew/catkin_ws/build"
####
-- Using CATKIN_DEVEL_PREFIX: /home/andrew/catkin_ws/devel
-- Using CMAKE_PREFIX_PATH: /home/andrew/catkin_ws/devel;/opt/ros/groovy
-- This workspace overlays: /home/andrew/catkin_ws/devel;/opt/ros/groovy
-- Using Debian Python package layout
-- Using CATKIN_ENABLE_TESTING: ON
-- Call enable_testing()
-- Using CATKIN_TEST_RESULTS_DIR: /home/andrew/catkin_ws/build/test_results
-- Found gtest sources under '/usr/src/gtest': gtests will be built
-- catkin 0.5.71
-- BUILD_SHARED_LIBS is on
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- ~~  traversing 2 packages in topological order:
-- ~~  - openni_camera
-- ~~  - servo
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- +++ processing catkin package: 'openni_camera'
-- ==> add_subdirectory(openni_camera)
-- Boost version: 1.49.0
-- Found the following Boost libraries:
--   system
--   filesystem
--   thread
CMake Error at /opt/ros/groovy/share/dynamic_reconfigure/cmake/extras.cmake:47 (message):
  Could not run dynamic reconfigure file 'cfg/OpenNI.cfg':
  /home/andrew/catkin_ws/build/catkin_generated/env_cached.sh: 10: exec:
  /home/andrew/catkin_ws/src/openni_camera/cfg/OpenNI.cfg: Permission denied
Call Stack (most recent call first):
  openni_camera/CMakeLists.txt:11 (generate_dynamic_reconfigure_options)


-- Configuring incomplete, errors occurred!
Invoking "cmake" failed

I'm running Ubuntu 12.10 on ROS Groovy. Groovy, and using an Asus Xtion Pro Live. Please help!

Installing an older version of a ros package by source

I used to run version 1.8.9 of openni_camera, and I'd like to revert back to an older version of it. The source is found here.

This is actually a commit between versions 1.8.8 and 1.8.9. Does anyone know how I can go about installing this package through source?

I've previously installed openni_camera as a deb package, and have uninstalled it using sudo apt-get --purge remove ros-groovy-openni-camera. What I've tried so far is putting the source folder into my catkin workspace (~/catkin_ws/src), and using catkin_make in ~/catkin_ws, but I'm faced with an error:

$ catkin_make
Base path: /home/andrew/catkin_ws
Source space: /home/andrew/catkin_ws/src
Build space: /home/andrew/catkin_ws/build
Devel space: /home/andrew/catkin_ws/devel
Install space: /home/andrew/catkin_ws/install
####
#### Running command: "cmake /home/andrew/catkin_ws/src -DCATKIN_DEVEL_PREFIX=/home/andrew/catkin_ws/devel -DCMAKE_INSTALL_PREFIX=/home/andrew/catkin_ws/install" in "/home/andrew/catkin_ws/build"
####
-- Using CATKIN_DEVEL_PREFIX: /home/andrew/catkin_ws/devel
-- Using CMAKE_PREFIX_PATH: /home/andrew/catkin_ws/devel;/opt/ros/groovy
-- This workspace overlays: /home/andrew/catkin_ws/devel;/opt/ros/groovy
-- Using Debian Python package layout
-- Using CATKIN_ENABLE_TESTING: ON
-- Call enable_testing()
-- Using CATKIN_TEST_RESULTS_DIR: /home/andrew/catkin_ws/build/test_results
-- Found gtest sources under '/usr/src/gtest': gtests will be built
-- catkin 0.5.71
-- BUILD_SHARED_LIBS is on
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- ~~  traversing 2 packages in topological order:
-- ~~  - openni_camera
-- ~~  - servo
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- +++ processing catkin package: 'openni_camera'
-- ==> add_subdirectory(openni_camera)
-- Boost version: 1.49.0
-- Found the following Boost libraries:
--   system
--   filesystem
--   thread
CMake Error at /opt/ros/groovy/share/dynamic_reconfigure/cmake/extras.cmake:47 (message):
  Could not run dynamic reconfigure file 'cfg/OpenNI.cfg':
  /home/andrew/catkin_ws/build/catkin_generated/env_cached.sh: 10: exec:
  /home/andrew/catkin_ws/src/openni_camera/cfg/OpenNI.cfg: Permission denied
Call Stack (most recent call first):
  openni_camera/CMakeLists.txt:11 (generate_dynamic_reconfigure_options)


-- Configuring incomplete, errors occurred!
Invoking "cmake" failed

I'm running Ubuntu 12.10 on ROS Groovy, and using an Asus Xtion Pro Live. Please help!

Installing an older version of a ros package by source

I used to run version 1.8.9 of openni_camera, and I'd like to revert back to an older version of it. The source is found here.

This is actually a commit between versions 1.8.8 and 1.8.9. Does anyone know how I can go about installing this package through source?

I've previously installed openni_camera as a deb package, and have uninstalled it using sudo apt-get --purge remove ros-groovy-openni-camera. What I've tried so far is putting the source folder into my catkin workspace (~/catkin_ws/src), and using catkin_make in ~/catkin_ws, but I'm faced with an error:

$ catkin_make
Base path: /home/andrew/catkin_ws
Source space: /home/andrew/catkin_ws/src
Build space: /home/andrew/catkin_ws/build
Devel space: /home/andrew/catkin_ws/devel
Install space: /home/andrew/catkin_ws/install
####
#### Running command: "cmake /home/andrew/catkin_ws/src -DCATKIN_DEVEL_PREFIX=/home/andrew/catkin_ws/devel -DCMAKE_INSTALL_PREFIX=/home/andrew/catkin_ws/install" in "/home/andrew/catkin_ws/build"
####
-- Using CATKIN_DEVEL_PREFIX: /home/andrew/catkin_ws/devel
-- Using CMAKE_PREFIX_PATH: /home/andrew/catkin_ws/devel;/opt/ros/groovy
-- This workspace overlays: /home/andrew/catkin_ws/devel;/opt/ros/groovy
-- Using Debian Python package layout
-- Using CATKIN_ENABLE_TESTING: ON
-- Call enable_testing()
-- Using CATKIN_TEST_RESULTS_DIR: /home/andrew/catkin_ws/build/test_results
-- Found gtest sources under '/usr/src/gtest': gtests will be built
-- catkin 0.5.71
-- BUILD_SHARED_LIBS is on
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- ~~  traversing 2 packages in topological order:
-- ~~  - openni_camera
-- ~~  - servo
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- +++ processing catkin package: 'openni_camera'
-- ==> add_subdirectory(openni_camera)
-- Boost version: 1.49.0
-- Found the following Boost libraries:
--   system
--   filesystem
--   thread
CMake Error at /opt/ros/groovy/share/dynamic_reconfigure/cmake/extras.cmake:47 (message):
  Could not run dynamic reconfigure file 'cfg/OpenNI.cfg':
  /home/andrew/catkin_ws/build/catkin_generated/env_cached.sh: 10: exec:
  /home/andrew/catkin_ws/src/openni_camera/cfg/OpenNI.cfg: Permission denied
Call Stack (most recent call first):
  openni_camera/CMakeLists.txt:11 (generate_dynamic_reconfigure_options)


-- Configuring incomplete, errors occurred!
Invoking "cmake" failed

I'm running Ubuntu 12.10 on ROS Groovy, and using an Asus Xtion Pro Live. Please help!

Installing an older version of a ros package by source

I used to run version 1.8.9 of openni_camera, and I'd like to revert back to an older version of it. The source is found here.

This is actually a commit between versions 1.8.8 and 1.8.9. Does anyone know how I can go about installing this package through source?

I've previously installed openni_camera as a deb package, and have uninstalled it using sudo apt-get --purge remove ros-groovy-openni-camera. What I've tried so far is putting the source folder into my catkin workspace (~/catkin_ws/src), and using catkin_make in ~/catkin_ws, but I'm faced with an error:

$ catkin_make
Base path: /home/andrew/catkin_ws
Source space: /home/andrew/catkin_ws/src
Build space: /home/andrew/catkin_ws/build
Devel space: /home/andrew/catkin_ws/devel
Install space: /home/andrew/catkin_ws/install
####
#### Running command: "cmake /home/andrew/catkin_ws/src -DCATKIN_DEVEL_PREFIX=/home/andrew/catkin_ws/devel -DCMAKE_INSTALL_PREFIX=/home/andrew/catkin_ws/install" in "/home/andrew/catkin_ws/build"
####
-- Using CATKIN_DEVEL_PREFIX: /home/andrew/catkin_ws/devel
-- Using CMAKE_PREFIX_PATH: /home/andrew/catkin_ws/devel;/opt/ros/groovy
-- This workspace overlays: /home/andrew/catkin_ws/devel;/opt/ros/groovy
-- Using Debian Python package layout
-- Using CATKIN_ENABLE_TESTING: ON
-- Call enable_testing()
-- Using CATKIN_TEST_RESULTS_DIR: /home/andrew/catkin_ws/build/test_results
-- Found gtest sources under '/usr/src/gtest': gtests will be built
-- catkin 0.5.71
-- BUILD_SHARED_LIBS is on
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- ~~  traversing 2 packages in topological order:
-- ~~  - openni_camera
-- ~~  - servo
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- +++ processing catkin package: 'openni_camera'
-- ==> add_subdirectory(openni_camera)
-- Boost version: 1.49.0
-- Found the following Boost libraries:
--   system
--   filesystem
--   thread
CMake Error at /opt/ros/groovy/share/dynamic_reconfigure/cmake/extras.cmake:47 (message):
  Could not run dynamic reconfigure file 'cfg/OpenNI.cfg':
  /home/andrew/catkin_ws/build/catkin_generated/env_cached.sh: 10: exec:
  /home/andrew/catkin_ws/src/openni_camera/cfg/OpenNI.cfg: Permission denied
Call Stack (most recent call first):
  openni_camera/CMakeLists.txt:11 (generate_dynamic_reconfigure_options)


-- Configuring incomplete, errors occurred!
Invoking "cmake" failed

I'm running Ubuntu 12.10 on ROS Groovy, and using an Asus Xtion Pro Live. Please help!

Installing an older version of a ros package by source

I used to run version 1.8.9 of openni_camera, and I'd like to revert back to an older version of it. The source is found here.

This is actually a commit between versions 1.8.8 and 1.8.9. Does anyone know how I can go about installing this package through source?

I've previously installed openni_camera as a deb package, and have uninstalled it using sudo apt-get --purge remove ros-groovy-openni-camera. What I've tried so far is putting the source folder into my catkin workspace (~/catkin_ws/src), and using catkin_make in ~/catkin_ws, but I'm faced with an error:

$ catkin_make
Base path: /home/andrew/catkin_ws
Source space: /home/andrew/catkin_ws/src
Build space: /home/andrew/catkin_ws/build
Devel space: /home/andrew/catkin_ws/devel
Install space: /home/andrew/catkin_ws/install
####
#### Running command: "cmake /home/andrew/catkin_ws/src -DCATKIN_DEVEL_PREFIX=/home/andrew/catkin_ws/devel -DCMAKE_INSTALL_PREFIX=/home/andrew/catkin_ws/install" in "/home/andrew/catkin_ws/build"
####
-- Using CATKIN_DEVEL_PREFIX: /home/andrew/catkin_ws/devel
-- Using CMAKE_PREFIX_PATH: /home/andrew/catkin_ws/devel;/opt/ros/groovy
-- This workspace overlays: /home/andrew/catkin_ws/devel;/opt/ros/groovy
-- Using Debian Python package layout
-- Using CATKIN_ENABLE_TESTING: ON
-- Call enable_testing()
-- Using CATKIN_TEST_RESULTS_DIR: /home/andrew/catkin_ws/build/test_results
-- Found gtest sources under '/usr/src/gtest': gtests will be built
-- catkin 0.5.71
-- BUILD_SHARED_LIBS is on
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- ~~  traversing 2 packages in topological order:
-- ~~  - openni_camera
-- ~~  - servo
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- +++ processing catkin package: 'openni_camera'
-- ==> add_subdirectory(openni_camera)
-- Boost version: 1.49.0
-- Found the following Boost libraries:
--   system
--   filesystem
--   thread
CMake Error at /opt/ros/groovy/share/dynamic_reconfigure/cmake/extras.cmake:47 (message):
  Could not run dynamic reconfigure file 'cfg/OpenNI.cfg':
  /home/andrew/catkin_ws/build/catkin_generated/env_cached.sh: 10: exec:
  /home/andrew/catkin_ws/src/openni_camera/cfg/OpenNI.cfg: Permission denied
Call Stack (most recent call first):
  openni_camera/CMakeLists.txt:11 (generate_dynamic_reconfigure_options)


-- Configuring incomplete, errors occurred!
Invoking "cmake" failed

I'm running Ubuntu 12.10 on ROS Groovy, and using an Asus Xtion Pro Live. Please help!