Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Error running MIT demos on Fuerte

I followed the demo guide for the MIT Demos (found here - sorry I can't publish links: www dot ros dot org /wiki/mit-ros-pkg/KinectDemos/HandDetection), and I have a few errors.

I know they are created for Cturtle through Electric, but I am trying to get them to run on Ubuntu 12.04 and Fuerte (This is better than Groovy/Hydro because of the rosbuild/catkin discrepancy, correct?).

I am stuck on the section entitled "Execution" in the guide, specifically on "roslaunch hand_interaction hand_detector.launch" which yields the following:

... logging to /home/seil-user/.ros/log/e975edac-042c-11e3-ab2d-90b11c9cc7b4/roslaunch-EAB0201D-A-24982.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.

started roslaunch server (http - can't post links) 128.8.140.96:59947/

SUMMARY

PARAMETERS * /openni_node1/debayering * /openni_node1/depth_frame_id * /openni_node1/depth_mode * /openni_node1/depth_registration * /openni_node1/depth_rgb_rotation * /openni_node1/depth_rgb_translation * /openni_node1/depth_time_offset * /openni_node1/device_id * /openni_node1/image_mode * /openni_node1/image_time_offset * /openni_node1/projector_depth_baseline * /openni_node1/rgb_frame_id * /openni_node1/shift_offset * /openni_node1/use_indices * /rosdistro * /rosversion

NODES / handdetector (hand_interaction/detectskelhands) kinect_base_link (tf/static_transform_publisher) kinect_base_link1 (tf/static_transform_publisher) kinect_base_link2 (tf/static_transform_publisher) kinect_base_link3 (tf/static_transform_publisher) openni_node1 (openni_camera/openni_node) ressetter (dynamic_reconfigure/dynparam) skel_tracker (skeletal_tracker/tracker)

auto-starting new master process[master]: started with pid [24998] ROS_MASTER_URI=(http - can't post links) localhost:11311

setting /run_id to e975edac-042c-11e3-ab2d-90b11c9cc7b4 process[rosout-1]: started with pid [25011] started core service [/rosout] process[openni_node1-2]: started with pid [25023] process[kinect_base_link-3]: started with pid [25024] process[kinect_base_link1-4]: started with pid [25036] process[kinect_base_link2-5]: started with pid [25048] process[kinect_base_link3-6]: started with pid [25060] ERROR: cannot launch node of type [hand_interaction/detectskelhands]: can't locate node [detectskelhands] in package [hand_interaction] process[ressetter-8]: started with pid [25072] ERROR: cannot launch node of type [skeletal_tracker/tracker]: can't locate node [tracker] in package [skeletal_tracker] Waiting for service /openni_camera/set_parameters... The last line repeats indefinitely until I abort.

I've made some progress troubleshooting. These are the past errors:

  • There used to be several XML errors which I believe I corrected line by line in multiple files.
  • Furthermore, this error: "ERROR: cannot launch node of type [openni_camera/openni_node]: can't locate node [openni_node] in package [openni_camera]" used to appear until I installed "ros-fuerte-openni-camera"
  • I also installed things while troubleshooting aside from what was in the guide: openni_kinect and openni_camera
  • I did the following (I can't publish links): "sudo wget -P rospack find openni/lib github dot com/OpenNI/OpenNI/raw/43c256b554dcbe478644be73e29af16b3470f1c1/Data/SamplesConfig.xml --no-check-certificate" after reading answers dot ros dot org/question/9721/skeletal_tracker-crashes/ but it didn't seem to help

I'm new to ROS, and I'm not sure what changed between Electric and Fuerte that would affect these nodes. Any ideas on how to fix these errors? Thanks in advance.

Error running MIT demos on Fuerte

I followed the demo guide for the MIT Demos (found here - sorry I can't publish links: www dot ros dot org /wiki/mit-ros-pkg/KinectDemos/HandDetection), and I have a few errors.

I know they are created for Cturtle through Electric, but I am trying to get them to run on Ubuntu 12.04 and Fuerte (This is better than Groovy/Hydro because of the rosbuild/catkin discrepancy, correct?).

I am stuck on the section entitled "Execution" in the guide, specifically on "roslaunch hand_interaction hand_detector.launch" which yields the following:

... logging to /home/seil-user/.ros/log/e975edac-042c-11e3-ab2d-90b11c9cc7b4/roslaunch-EAB0201D-A-24982.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.

started roslaunch server (http - can't post links) 128.8.140.96:59947/

SUMMARY

PARAMETERS * /openni_node1/debayering * /openni_node1/depth_frame_id * /openni_node1/depth_mode * /openni_node1/depth_registration * /openni_node1/depth_rgb_rotation * /openni_node1/depth_rgb_translation * /openni_node1/depth_time_offset * /openni_node1/device_id * /openni_node1/image_mode * /openni_node1/image_time_offset * /openni_node1/projector_depth_baseline * /openni_node1/rgb_frame_id * /openni_node1/shift_offset * /openni_node1/use_indices * /rosdistro * /rosversion

NODES / handdetector (hand_interaction/detectskelhands) kinect_base_link (tf/static_transform_publisher) kinect_base_link1 (tf/static_transform_publisher) kinect_base_link2 (tf/static_transform_publisher) kinect_base_link3 (tf/static_transform_publisher) openni_node1 (openni_camera/openni_node) ressetter (dynamic_reconfigure/dynparam) skel_tracker (skeletal_tracker/tracker)

auto-starting new master process[master]: started with pid [24998] ROS_MASTER_URI=(http - can't post links) localhost:11311

setting /run_id to e975edac-042c-11e3-ab2d-90b11c9cc7b4 process[rosout-1]: started with pid [25011] started core service [/rosout] process[openni_node1-2]: started with pid [25023] process[kinect_base_link-3]: started with pid [25024] process[kinect_base_link1-4]: started with pid [25036] process[kinect_base_link2-5]: started with pid [25048] process[kinect_base_link3-6]: started with pid [25060] ERROR: cannot launch node of type [hand_interaction/detectskelhands]: can't locate node [detectskelhands] in package [hand_interaction] process[ressetter-8]: started with pid [25072] ERROR: cannot launch node of type [skeletal_tracker/tracker]: can't locate node [tracker] in package [skeletal_tracker] Waiting for service /openni_camera/set_parameters... The last line repeats indefinitely until I abort.

I've made some progress troubleshooting. been troubleshooting for a while. These are the past errors:

  • There used to be several XML errors which I believe I corrected line by line in multiple files.
  • Furthermore, this error: "ERROR: cannot launch node of type [openni_camera/openni_node]: can't locate node [openni_node] in package [openni_camera]" used to appear until I installed "ros-fuerte-openni-camera"
  • I also installed things while troubleshooting aside from what was in the guide: openni_kinect and openni_camera
  • Whiel attempting to solve this problem, I did the following (I can't publish links): "sudo wget -P rospack find openni/lib github dot com/OpenNI/OpenNI/raw/43c256b554dcbe478644be73e29af16b3470f1c1/Data/SamplesConfig.xml --no-check-certificate" after reading answers dot ros dot org/question/9721/skeletal_tracker-crashes/ but it didn't seem to help

I'm new to ROS, and I'm not sure what changed between Electric and Fuerte that would affect these nodes. Any ideas on how to fix these errors? Thanks in advance.

Error running MIT demos on Fuerte

I followed the demo guide for the MIT Demos (found here - sorry I can't publish links: www dot ros dot org /wiki/mit-ros-pkg/KinectDemos/HandDetection), and I have a few errors.

I know they are created for Cturtle through Electric, but I am trying to get them to run on Ubuntu 12.04 and Fuerte (This is better than Groovy/Hydro because of the rosbuild/catkin discrepancy, correct?).

I am stuck on the section entitled "Execution" in the guide, specifically on "roslaunch hand_interaction hand_detector.launch" which yields the following:

... logging to /home/seil-user/.ros/log/e975edac-042c-11e3-ab2d-90b11c9cc7b4/roslaunch-EAB0201D-A-24982.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.

started roslaunch server (http - can't post links) 128.8.140.96:59947/

SUMMARY

PARAMETERS * /openni_node1/debayering * /openni_node1/depth_frame_id * /openni_node1/depth_mode * /openni_node1/depth_registration * /openni_node1/depth_rgb_rotation * /openni_node1/depth_rgb_translation * /openni_node1/depth_time_offset * /openni_node1/device_id * /openni_node1/image_mode * /openni_node1/image_time_offset * /openni_node1/projector_depth_baseline * /openni_node1/rgb_frame_id * /openni_node1/shift_offset * /openni_node1/use_indices * /rosdistro * /rosversion

NODES / handdetector (hand_interaction/detectskelhands) kinect_base_link (tf/static_transform_publisher) kinect_base_link1 (tf/static_transform_publisher) kinect_base_link2 (tf/static_transform_publisher) kinect_base_link3 (tf/static_transform_publisher) openni_node1 (openni_camera/openni_node) ressetter (dynamic_reconfigure/dynparam) skel_tracker (skeletal_tracker/tracker)

auto-starting new master process[master]: started with pid [24998] ROS_MASTER_URI=(http - can't post links) localhost:11311

setting /run_id to e975edac-042c-11e3-ab2d-90b11c9cc7b4 process[rosout-1]: started with pid [25011] started core service [/rosout] process[openni_node1-2]: started with pid [25023] process[kinect_base_link-3]: started with pid [25024] process[kinect_base_link1-4]: started with pid [25036] process[kinect_base_link2-5]: started with pid [25048] process[kinect_base_link3-6]: started with pid [25060] ERROR: cannot launch node of type [hand_interaction/detectskelhands]: can't locate node [detectskelhands] in package [hand_interaction] process[ressetter-8]: started with pid [25072] ERROR: cannot launch node of type [skeletal_tracker/tracker]: can't locate node [tracker] in package [skeletal_tracker] Waiting for service /openni_camera/set_parameters... The last line repeats indefinitely until I abort.

I've been troubleshooting for a while. These are the past errors:

  • There used to be several XML errors which I believe I corrected line by line in multiple files.
  • Furthermore, this error: "ERROR: cannot launch node of type [openni_camera/openni_node]: can't locate node [openni_node] in package [openni_camera]" used to appear until I installed "ros-fuerte-openni-camera"
  • I also installed things while troubleshooting aside from what was in the guide: openni_kinect and openni_camera
  • Whiel While attempting to solve this problem, I did the following (I can't publish links): "sudo wget -P rospack find openni/lib github dot com/OpenNI/OpenNI/raw/43c256b554dcbe478644be73e29af16b3470f1c1/Data/SamplesConfig.xml --no-check-certificate" after reading answers dot ros dot org/question/9721/skeletal_tracker-crashes/ but it didn't seem to help

I'm new to ROS, and I'm not sure what changed between Electric and Fuerte that would affect these nodes. Any ideas on how to fix these errors? Thanks in advance.

Error running MIT demos on Fuerte

I followed the demo guide for the MIT Demos (found here - sorry I can't publish links: www dot ros dot org /wiki/mit-ros-pkg/KinectDemos/HandDetection), and I have a few errors.

I know they are created for Cturtle through Electric, but I am trying to get them to run on Ubuntu 12.04 and Fuerte (This is better than Groovy/Hydro because of the rosbuild/catkin discrepancy, correct?).

I am stuck on the section entitled "Execution" in the guide, specifically on "roslaunch hand_interaction hand_detector.launch" which yields the following: following:

... logging to /home/seil-user/.ros/log/e975edac-042c-11e3-ab2d-90b11c9cc7b4/roslaunch-EAB0201D-A-24982.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.

started roslaunch server (http - can't post links) 128.8.140.96:59947/

SUMMARY

PARAMETERS * /openni_node1/debayering * /openni_node1/depth_frame_id * /openni_node1/depth_mode * /openni_node1/depth_registration * /openni_node1/depth_rgb_rotation * /openni_node1/depth_rgb_translation * /openni_node1/depth_time_offset * /openni_node1/device_id * /openni_node1/image_mode * /openni_node1/image_time_offset * /openni_node1/projector_depth_baseline * /openni_node1/rgb_frame_id * /openni_node1/shift_offset * /openni_node1/use_indices * /rosdistro * /rosversion

NODES / handdetector (hand_interaction/detectskelhands) kinect_base_link (tf/static_transform_publisher) kinect_base_link1 (tf/static_transform_publisher) kinect_base_link2 (tf/static_transform_publisher) kinect_base_link3 (tf/static_transform_publisher) openni_node1 (openni_camera/openni_node) ressetter (dynamic_reconfigure/dynparam) skel_tracker (skeletal_tracker/tracker)

auto-starting new master process[master]: started with pid [24998] ROS_MASTER_URI=(http - can't post links) localhost:11311

setting /run_id to e975edac-042c-11e3-ab2d-90b11c9cc7b4 process[rosout-1]: started with pid [25011] started core service [/rosout] process[openni_node1-2]: started with pid [25023] process[kinect_base_link-3]: started with pid [25024] process[kinect_base_link1-4]: started with pid [25036] process[kinect_base_link2-5]: started with pid [25048] process[kinect_base_link3-6]: started with pid [25060] ERROR: cannot launch node of type [hand_interaction/detectskelhands]: can't locate node [detectskelhands] in package [hand_interaction] process[ressetter-8]: started with pid [25072] ERROR: cannot launch node of type [skeletal_tracker/tracker]: can't locate node [tracker] in package [skeletal_tracker] Waiting for service /openni_camera/set_parameters... The last line repeats indefinitely until I abort.

I've been troubleshooting for a while. These are the past errors:

  • There used to be several XML errors which I believe I corrected line by line in multiple files.
  • Furthermore, this error: "ERROR: cannot launch node of type [openni_camera/openni_node]: can't locate node [openni_node] in package [openni_camera]" used to appear until I installed "ros-fuerte-openni-camera"
  • I also installed things while troubleshooting aside from what was in the guide: openni_kinect and openni_camera
  • While attempting to solve this problem, I did the following (I can't publish links): "sudo wget -P rospack find openni/lib github dot com/OpenNI/OpenNI/raw/43c256b554dcbe478644be73e29af16b3470f1c1/Data/SamplesConfig.xml --no-check-certificate" after reading answers dot ros dot org/question/9721/skeletal_tracker-crashes/ but it didn't seem to help

I'm new to ROS, and I'm not sure what changed between Electric and Fuerte that would affect these nodes. Any ideas on how to fix these errors? Thanks in advance.

Error running MIT demos on Fuerte

I followed the demo guide for the MIT Demos (found here - sorry I can't publish links: www dot ros dot org /wiki/mit-ros-pkg/KinectDemos/HandDetection), and I have a few errors.

I know they are created for Cturtle through Electric, but I am trying to get them to run on Ubuntu 12.04 and Fuerte (This is better than Groovy/Hydro because of the rosbuild/catkin discrepancy, correct?).

I am stuck on the section entitled "Execution" in the guide, specifically on "roslaunch hand_interaction hand_detector.launch" which yields the following:

... logging to /home/seil-user/.ros/log/e975edac-042c-11e3-ab2d-90b11c9cc7b4/roslaunch-EAB0201D-A-24982.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.

started roslaunch server (http - can't post links) 128.8.140.96:59947/

SUMMARY

PARAMETERS * /openni_node1/debayering * /openni_node1/depth_frame_id * /openni_node1/depth_mode * /openni_node1/depth_registration * /openni_node1/depth_rgb_rotation * /openni_node1/depth_rgb_translation * /openni_node1/depth_time_offset * /openni_node1/device_id * /openni_node1/image_mode * /openni_node1/image_time_offset * /openni_node1/projector_depth_baseline * /openni_node1/rgb_frame_id * /openni_node1/shift_offset * /openni_node1/use_indices * /rosdistro * /rosversion

NODES / handdetector (hand_interaction/detectskelhands) kinect_base_link (tf/static_transform_publisher) kinect_base_link1 (tf/static_transform_publisher) kinect_base_link2 (tf/static_transform_publisher) kinect_base_link3 (tf/static_transform_publisher) openni_node1 (openni_camera/openni_node) ressetter (dynamic_reconfigure/dynparam) skel_tracker (skeletal_tracker/tracker)

auto-starting new master process[master]: started with pid [24998] ROS_MASTER_URI=(http - can't post links) localhost:11311

setting /run_id to e975edac-042c-11e3-ab2d-90b11c9cc7b4 process[rosout-1]: started with pid [25011] started core service [/rosout] process[openni_node1-2]: started with pid [25023] process[kinect_base_link-3]: started with pid [25024] process[kinect_base_link1-4]: started with pid [25036] process[kinect_base_link2-5]: started with pid [25048] process[kinect_base_link3-6]: started with pid [25060] ERROR: cannot launch node of type [hand_interaction/detectskelhands]: can't locate node [detectskelhands] in package [hand_interaction] process[ressetter-8]: started with pid [25072] ERROR: cannot launch node of type [skeletal_tracker/tracker]: can't locate node [tracker] in package [skeletal_tracker] Waiting for service /openni_camera/set_parameters... The last line repeats indefinitely until I abort.

I've been troubleshooting for a while. These are the past errors:

  • There used to be several XML errors which I believe I corrected line by line in multiple files.
  • Furthermore, this error: "ERROR: cannot launch node of type [openni_camera/openni_node]: can't locate node [openni_node] in package [openni_camera]" used to appear until I installed "ros-fuerte-openni-camera"
  • I also installed things while troubleshooting aside from what was in the guide: openni_kinect and openni_camera
  • While attempting to solve this problem, I did the following (I can't publish links): "sudo wget -P rospack find openni/lib github dot com/OpenNI/OpenNI/raw/43c256b554dcbe478644be73e29af16b3470f1c1/Data/SamplesConfig.xml --no-check-certificate" after reading answers dot ros dot org/question/9721/skeletal_tracker-crashes/ but it didn't seem to help

I'm new to ROS, and I'm not sure what changed between Electric and Fuerte that would affect these nodes. Any ideas on how to fix these errors? Thanks in advance.

Error running MIT demos on Fuerte

I followed the demo guide for the MIT Demos (found here - sorry I can't publish links: www dot ros dot org /wiki/mit-ros-pkg/KinectDemos/HandDetection), and I have a few errors.

I know they are created for Cturtle through Electric, but I am trying to get them to run on Ubuntu 12.04 and Fuerte (This is better than Groovy/Hydro because of the rosbuild/catkin discrepancy, correct?).

I am stuck on the section entitled "Execution" in the guide, specifically on "roslaunch hand_interaction hand_detector.launch" which yields the following:

... logging to /home/seil-user/.ros/log/e975edac-042c-11e3-ab2d-90b11c9cc7b4/roslaunch-EAB0201D-A-24982.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.

started roslaunch server (http - can't post links) 128.8.140.96:59947/

SUMMARY

PARAMETERS * /openni_node1/debayering * /openni_node1/depth_frame_id * /openni_node1/depth_mode * /openni_node1/depth_registration * /openni_node1/depth_rgb_rotation * /openni_node1/depth_rgb_translation * /openni_node1/depth_time_offset * /openni_node1/device_id * /openni_node1/image_mode * /openni_node1/image_time_offset * /openni_node1/projector_depth_baseline * /openni_node1/rgb_frame_id * /openni_node1/shift_offset * /openni_node1/use_indices * /rosdistro * /rosversion

NODES / handdetector (hand_interaction/detectskelhands) kinect_base_link (tf/static_transform_publisher) kinect_base_link1 (tf/static_transform_publisher) kinect_base_link2 (tf/static_transform_publisher) kinect_base_link3 (tf/static_transform_publisher) openni_node1 (openni_camera/openni_node) ressetter (dynamic_reconfigure/dynparam) skel_tracker (skeletal_tracker/tracker)

auto-starting new master process[master]: started with pid [24998] ROS_MASTER_URI=(http - can't post links) localhost:11311

setting /run_id to e975edac-042c-11e3-ab2d-90b11c9cc7b4 process[rosout-1]: started with pid [25011] started core service [/rosout] process[openni_node1-2]: started with pid [25023] process[kinect_base_link-3]: started with pid [25024] process[kinect_base_link1-4]: started with pid [25036] process[kinect_base_link2-5]: started with pid [25048] process[kinect_base_link3-6]: started with pid [25060] ERROR: cannot launch node of type [hand_interaction/detectskelhands]: can't locate node [detectskelhands] in package [hand_interaction] process[ressetter-8]: started with pid [25072] ERROR: cannot launch node of type [skeletal_tracker/tracker]: can't locate node [tracker] in package [skeletal_tracker] Waiting for service /openni_camera/set_parameters... The last line repeats indefinitely until I abort.

I've been troubleshooting for a while. These are the past errors:

  • There used to be several XML errors which I believe I corrected line by line in multiple files.
  • Furthermore, this error: "ERROR: cannot launch node of type [openni_camera/openni_node]: can't locate node [openni_node] in package [openni_camera]" used to appear until I installed "ros-fuerte-openni-camera"
  • I also installed things while troubleshooting aside from what was in the guide: openni_kinect and openni_camera
  • While attempting to solve this problem, I did the following (I can't publish links): "sudo wget -P rospack find openni/lib github dot com/OpenNI/OpenNI/raw/43c256b554dcbe478644be73e29af16b3470f1c1/Data/SamplesConfig.xml --no-check-certificate" after reading answers dot ros dot org/question/9721/skeletal_tracker-crashes/ but it didn't seem to help

I'm new to ROS, and I'm not sure what changed between Electric and Fuerte that would affect these nodes. Any ideas on how to fix these errors? Thanks in advance.