Ask Your Question

Revision history [back]

husky_navigation gmapping_demo.launch not updating

Hello again,

I am using the husky_navigation gmapping_demo.launch to try mapping my lab. Everything is set up properly (as far as I know anyway) but when I launch the program rviz only shows the first scan. I used rviz to show the laser scan and that is sending data. It seems for some reason that the map won't update after the initial scan. Anyone know the reason for this?

husky_navigation gmapping_demo.launch not updating

Hello again,

I am using the husky_navigation gmapping_demo.launch to try mapping my lab. Everything is set up properly (as far as I know anyway) but when I launch the program rviz only shows the first scan. I used rviz to show the laser scan and that is sending data. It seems for some reason that the map won't update after the initial scan. Anyone know the reason for this?

UPDATE So, I think I have figured out what I did wrong, but I am having trouble fixing it. I used a static transform to connect the odom tf to the base_footprint tf. It appears though that the map will only update when it detects a change between those tfs, but since I used a static transform it will never change and therefore the map will never update. How can I attach the /map->/odom tf tree to the /base_footprint tf tree without using a static transform?

husky_navigation gmapping_demo.launch not updating

Hello again,

I am using the husky_navigation gmapping_demo.launch to try mapping my lab. Everything is set up properly (as far as I know anyway) but when I launch the program rviz only shows the first scan. I used rviz to show the laser scan and that is sending data. It seems for some reason that the map won't update after the initial scan. Anyone know the reason for this?

UPDATE So, I think I have figured out what I did wrong, but I am having trouble fixing it. I used a static transform to connect the odom tf to the base_footprint tf. It appears though that the map will only update when it detects a change between those tfs, but since I used a static transform it will never change and therefore the map will never update. How can I attach the /map->/odom tf tree to the /base_footprint tf tree without using a static transform?

husky_navigation gmapping_demo.launch not updating

Hello again,

I am using the husky_navigation gmapping_demo.launch to try mapping my lab. Everything is set up properly (as far as I know anyway) but when I launch the program rviz only shows the first scan. I used rviz to show the laser scan and that is sending data. It seems for some reason that the map won't update after the initial scan. Anyone know the reason for this?

UPDATE So, I think I have figured out what I did wrong, but I am having trouble fixing it. I used a static transform to connect the odom tf to the base_footprint tf. It appears though that the map will only update when it detects a change between those tfs, but since I used a static transform it will never change and therefore the map will never update. How can I attach the /map->/odom tf tree to the /base_footprint tf tree without using a static transform?

husky_navigation gmapping_demo.launch not updating

Hello again,

I am using the husky_navigation gmapping_demo.launch to try mapping my lab. Everything is set up properly (as far as I know anyway) but when I launch the program rviz only shows the first scan. I used rviz to show the laser scan and that is sending data. It seems for some reason that the map won't update after the initial scan. Anyone know the reason for this?

UPDATE So, I think I have figured out what I did wrong, but I am having trouble fixing it. I used a static transform to connect the odom tf to the base_footprint tf. It appears though that the map will only update when it detects a change between those tfs, but since I used a static transform it will never change and therefore the map will never update. How can I attach the /map->/odom tf tree to the /base_footprint tf tree without using a static transform?