Ask Your Question

Revision history [back]

Timeout Error in Fuerte's openni_tracker running Ubuntu 12.04

Hi all,

I'm trying to execute the openni_tracker node in ROS Fuerte running a Ubuntu 12.04 fresh install. When I launch the node I get the following error (full log at the end of the question):

[ERROR] [1340212031.075733079]: InitFromXml failed: Got a timeout while waiting for a network command to complete!

I have found other posts with a similar problem in Fuerte running (x)Ubuntu 12.04:

http://answers.ros.org/question/35956/openni_tracker-with-kinect-for-windows/ http://answers.ros.org/question/35620/openni_tracker-fails-with-fuerte-and-xubuntu-1204/

The first one points out that it might be a bug in Fuerte when running Ubuntu 12.04. Unfortunately, their questions did not receive any response. Therefore, I want to discard a problem related with my configuration or my installation before thinking that it is a bug in Fuerte. Moreover, if this were the case, It would already have aroused more noise from the community.

I'll appreciate any help that you can provide me, including if you are using this node in Fuerte with Ubuntu 12.04 LTS.

Thanks, Víctor.

LOGS

SYSTEM INFO:

  • Computer: MacBook Pro early 2011
  • Xbox Kinect
  • SO: Ubuntu 12.04 with dual boot (i.e. not running in a virtual machine)
  • ROS Version: ROS Fuerte

ERROR LOG when running the node (note that I set filter for openni to "INFO"):

vgonpa@VGonMac:[/opt/ros/fue.../openni_tracker]$ rosrun openni_tracker openni_tracker 
      446 INFO       New log started on 2012-06-20 17:54:52
      532 INFO       OpenNI version is 1.5.2 (Build 23)-Linux-x86 (May  3 2012 08:41:21)
      564 INFO       --- Filter Info --- Minimum Severity: INFO
    11555 INFO       Creating node 'Script1' of type Script: OpenNI/OpenNI/1.5.2.23...
    12196 INFO       USB is initialized.
    22861 INFO       Creating node 'Device1' of type Device: PrimeSense/SensorV2/5.1.0.41...
  4030211 INFO       Destroying node 'Script1'
  4030303 INFO       Destroying context
[ERROR] [1340211296.727793328]: InitFromXml failed: Got a timeout while waiting for a network command to complete!

lsusb LOG:

vgonpa@VGonMac:[/opt/ros/fue.../openni_tracker]$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0424:2513 Standard Microsystems Corp. 
Bus 001 Device 003: ID 05ac:8509 Apple, Inc. FaceTime HD Camera
Bus 002 Device 002: ID 0424:2513 Standard Microsystems Corp. 
Bus 001 Device 004: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 001 Device 005: ID 05ac:0246 Apple, Inc. Internal Keyboard/Trackpad (ISO)
Bus 002 Device 003: ID 05ac:8242 Apple, Inc. IR Receiver [built-in]
Bus 002 Device 016: ID 0409:005a NEC Corp. HighSpeed Hub
Bus 001 Device 008: ID 05ac:821a Apple, Inc. Bluetooth Host Controller
Bus 002 Device 017: ID 045e:02b0 Microsoft Corp. Xbox NUI Motor
Bus 002 Device 018: ID 045e:02ad Microsoft Corp. Xbox NUI Audio
Bus 002 Device 019: ID 045e:02ae Microsoft Corp. Xbox NUI Camera

LS in the usb/002

vgonpa@VGonMac:[/opt/ros/fue.../openni_tracker]$ ls -lh /dev/bus/usb/002/
total 0
crw-rw-r-- 1 root root  189, 128 jun 20 11:49 001
crw-rw-r-- 1 root root  189, 129 jun 20 11:49 002
crw-rw-r-- 1 root root  189, 130 jun 20 11:49 003
crw-rw-r-- 1 root root  189, 143 jun 20 15:53 016
crw-rw-rw- 1 root video 189, 144 jun 20 15:53 017
crw-rw-rw- 1 root video 189, 145 jun 20 15:53 018
crw-rw-rw- 1 root video 189, 146 jun 20 16:16 019

EXTRA:

The Kinect green led is blinking since I connect it to my computer. Is this normal? or is it a malfunction in the driver or in the kinect?

openni_tracker Timeout Error in Fuerte's openni_tracker running Ubuntu 12.04Fuerte (Ubuntu 12.04 LTS)

Hi all,

I'm trying to execute the openni_tracker node in ROS Fuerte running a Ubuntu 12.04 fresh install. When I launch the node I get the following error (full log at the end of the question):

[ERROR] [1340212031.075733079]: InitFromXml failed: Got a timeout while waiting for a network command to complete!

I have found other posts with a similar problem in Fuerte running (x)Ubuntu 12.04:

http://answers.ros.org/question/35956/openni_tracker-with-kinect-for-windows/ http://answers.ros.org/question/35620/openni_tracker-fails-with-fuerte-and-xubuntu-1204/

The first one points out that it might be a bug in Fuerte when running Ubuntu 12.04. Unfortunately, their questions did not receive any response. Therefore, I want to discard a problem related with my configuration or my installation before thinking that it is a bug in Fuerte. Moreover, if this were the case, It would already have aroused more noise from the community.

I'll appreciate any help that you can provide me, including if you are using this node in Fuerte with Ubuntu 12.04 LTS.

Thanks, Víctor.

LOGS

SYSTEM INFO:

  • Computer: MacBook Pro early 2011
  • Xbox Kinect
  • SO: Ubuntu 12.04 with dual boot (i.e. not running in a virtual machine)
  • ROS Version: ROS Fuerte

ERROR LOG when running the node (note that I set filter for openni to "INFO"):

vgonpa@VGonMac:[/opt/ros/fue.../openni_tracker]$ rosrun openni_tracker openni_tracker 
      446 INFO       New log started on 2012-06-20 17:54:52
      532 INFO       OpenNI version is 1.5.2 (Build 23)-Linux-x86 (May  3 2012 08:41:21)
      564 INFO       --- Filter Info --- Minimum Severity: INFO
    11555 INFO       Creating node 'Script1' of type Script: OpenNI/OpenNI/1.5.2.23...
    12196 INFO       USB is initialized.
    22861 INFO       Creating node 'Device1' of type Device: PrimeSense/SensorV2/5.1.0.41...
  4030211 INFO       Destroying node 'Script1'
  4030303 INFO       Destroying context
[ERROR] [1340211296.727793328]: InitFromXml failed: Got a timeout while waiting for a network command to complete!

lsusb LOG:

vgonpa@VGonMac:[/opt/ros/fue.../openni_tracker]$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0424:2513 Standard Microsystems Corp. 
Bus 001 Device 003: ID 05ac:8509 Apple, Inc. FaceTime HD Camera
Bus 002 Device 002: ID 0424:2513 Standard Microsystems Corp. 
Bus 001 Device 004: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 001 Device 005: ID 05ac:0246 Apple, Inc. Internal Keyboard/Trackpad (ISO)
Bus 002 Device 003: ID 05ac:8242 Apple, Inc. IR Receiver [built-in]
Bus 002 Device 016: ID 0409:005a NEC Corp. HighSpeed Hub
Bus 001 Device 008: ID 05ac:821a Apple, Inc. Bluetooth Host Controller
Bus 002 Device 017: ID 045e:02b0 Microsoft Corp. Xbox NUI Motor
Bus 002 Device 018: ID 045e:02ad Microsoft Corp. Xbox NUI Audio
Bus 002 Device 019: ID 045e:02ae Microsoft Corp. Xbox NUI Camera

LS in the usb/002

vgonpa@VGonMac:[/opt/ros/fue.../openni_tracker]$ ls -lh /dev/bus/usb/002/
total 0
crw-rw-r-- 1 root root  189, 128 jun 20 11:49 001
crw-rw-r-- 1 root root  189, 129 jun 20 11:49 002
crw-rw-r-- 1 root root  189, 130 jun 20 11:49 003
crw-rw-r-- 1 root root  189, 143 jun 20 15:53 016
crw-rw-rw- 1 root video 189, 144 jun 20 15:53 017
crw-rw-rw- 1 root video 189, 145 jun 20 15:53 018
crw-rw-rw- 1 root video 189, 146 jun 20 16:16 019

EXTRA:

The Kinect green led is blinking since I connect it to my computer. Is this normal? or is it a malfunction in the driver or in the kinect?

click to hide/show revision 3
Discarded a possible problem of my Kinect.

openni_tracker Timeout Error in Fuerte (Ubuntu 12.04 LTS)

Hi all,

I'm trying to execute the openni_tracker node in ROS Fuerte running a Ubuntu 12.04 fresh install. When I launch the node I get the following error (full log at the end of the question):

[ERROR] [1340212031.075733079]: InitFromXml failed: Got a timeout while waiting for a network command to complete!

I have found other posts with a similar problem in Fuerte running (x)Ubuntu 12.04:

http://answers.ros.org/question/35956/openni_tracker-with-kinect-for-windows/ http://answers.ros.org/question/35620/openni_tracker-fails-with-fuerte-and-xubuntu-1204/

The first one points out that it might be a bug in Fuerte when running Ubuntu 12.04. Unfortunately, their questions did not receive any response. Therefore, I want to discard a problem related with my configuration or my installation before thinking that it is a bug in Fuerte. Moreover, if this were the case, It would already have aroused more noise from the community.

I'll appreciate any help that you can provide me, including if you are using this node in Fuerte with Ubuntu 12.04 LTS.

Thanks, Víctor.

LOGS

SYSTEM INFO:

  • Computer: MacBook Pro early 2011
  • Xbox Kinect
  • SO: Ubuntu 12.04 with dual boot (i.e. not running in a virtual machine)
  • ROS Version: ROS Fuerte

ERROR LOG when running the node (note that I set filter for openni to "INFO"):

vgonpa@VGonMac:[/opt/ros/fue.../openni_tracker]$ rosrun openni_tracker openni_tracker 
      446 INFO       New log started on 2012-06-20 17:54:52
      532 INFO       OpenNI version is 1.5.2 (Build 23)-Linux-x86 (May  3 2012 08:41:21)
      564 INFO       --- Filter Info --- Minimum Severity: INFO
    11555 INFO       Creating node 'Script1' of type Script: OpenNI/OpenNI/1.5.2.23...
    12196 INFO       USB is initialized.
    22861 INFO       Creating node 'Device1' of type Device: PrimeSense/SensorV2/5.1.0.41...
  4030211 INFO       Destroying node 'Script1'
  4030303 INFO       Destroying context
[ERROR] [1340211296.727793328]: InitFromXml failed: Got a timeout while waiting for a network command to complete!

lsusb LOG:

vgonpa@VGonMac:[/opt/ros/fue.../openni_tracker]$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0424:2513 Standard Microsystems Corp. 
Bus 001 Device 003: ID 05ac:8509 Apple, Inc. FaceTime HD Camera
Bus 002 Device 002: ID 0424:2513 Standard Microsystems Corp. 
Bus 001 Device 004: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 001 Device 005: ID 05ac:0246 Apple, Inc. Internal Keyboard/Trackpad (ISO)
Bus 002 Device 003: ID 05ac:8242 Apple, Inc. IR Receiver [built-in]
Bus 002 Device 016: ID 0409:005a NEC Corp. HighSpeed Hub
Bus 001 Device 008: ID 05ac:821a Apple, Inc. Bluetooth Host Controller
Bus 002 Device 017: ID 045e:02b0 Microsoft Corp. Xbox NUI Motor
Bus 002 Device 018: ID 045e:02ad Microsoft Corp. Xbox NUI Audio
Bus 002 Device 019: ID 045e:02ae Microsoft Corp. Xbox NUI Camera

LS in the usb/002

vgonpa@VGonMac:[/opt/ros/fue.../openni_tracker]$ ls -lh /dev/bus/usb/002/
total 0
crw-rw-r-- 1 root root  189, 128 jun 20 11:49 001
crw-rw-r-- 1 root root  189, 129 jun 20 11:49 002
crw-rw-r-- 1 root root  189, 130 jun 20 11:49 003
crw-rw-r-- 1 root root  189, 143 jun 20 15:53 016
crw-rw-rw- 1 root video 189, 144 jun 20 15:53 017
crw-rw-rw- 1 root video 189, 145 jun 20 15:53 018
crw-rw-rw- 1 root video 189, 146 jun 20 16:16 019

EXTRA:

The Kinect green led is blinking since I connect it to my computer. Is this normal? or is it a malfunction in the driver or in the kinect?

openni_tracker Timeout Error in Fuerte (Ubuntu 12.04 LTS)

Hi all,

I'm trying to execute the openni_tracker node in ROS Fuerte running a Ubuntu 12.04 fresh install. When I launch the node I get the following error (full log at the end of the question):

[ERROR] [1340212031.075733079]: InitFromXml failed: Got a timeout while waiting for a network command to complete!

I have found other posts with a similar problem in Fuerte running (x)Ubuntu 12.04:

http://answers.ros.org/question/35956/openni_tracker-with-kinect-for-windows/ http://answers.ros.org/question/35620/openni_tracker-fails-with-fuerte-and-xubuntu-1204/

The first one points out that it might be a bug in Fuerte when running Ubuntu 12.04. Unfortunately, their questions did not receive any response. Therefore, I want to discard a problem related with my configuration or my installation before thinking that it is a bug in Fuerte. Moreover, if this were the case, It would already have aroused more noise from the community.

I'll appreciate any help that you can provide me, including if you are using this node in Fuerte with Ubuntu 12.04 LTS.

Thanks, Víctor.

LOGS

SYSTEM INFO:

  • Computer: MacBook Pro early 2011
  • Xbox Kinect
  • SO: Ubuntu 12.04 with dual boot (i.e. not running in a virtual machine)
  • ROS Version: ROS Fuerte

ERROR LOG when running the node (note that I set filter for openni to "INFO"):

vgonpa@VGonMac:[/opt/ros/fue.../openni_tracker]$ rosrun openni_tracker openni_tracker 
      446 INFO       New log started on 2012-06-20 17:54:52
      532 INFO       OpenNI version is 1.5.2 (Build 23)-Linux-x86 (May  3 2012 08:41:21)
      564 INFO       --- Filter Info --- Minimum Severity: INFO
    11555 INFO       Creating node 'Script1' of type Script: OpenNI/OpenNI/1.5.2.23...
    12196 INFO       USB is initialized.
    22861 INFO       Creating node 'Device1' of type Device: PrimeSense/SensorV2/5.1.0.41...
  4030211 INFO       Destroying node 'Script1'
  4030303 INFO       Destroying context
[ERROR] [1340211296.727793328]: InitFromXml failed: Got a timeout while waiting for a network command to complete!

lsusb LOG:

vgonpa@VGonMac:[/opt/ros/fue.../openni_tracker]$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0424:2513 Standard Microsystems Corp. 
Bus 001 Device 003: ID 05ac:8509 Apple, Inc. FaceTime HD Camera
Bus 002 Device 002: ID 0424:2513 Standard Microsystems Corp. 
Bus 001 Device 004: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 001 Device 005: ID 05ac:0246 Apple, Inc. Internal Keyboard/Trackpad (ISO)
Bus 002 Device 003: ID 05ac:8242 Apple, Inc. IR Receiver [built-in]
Bus 002 Device 016: ID 0409:005a NEC Corp. HighSpeed Hub
Bus 001 Device 008: ID 05ac:821a Apple, Inc. Bluetooth Host Controller
Bus 002 Device 017: ID 045e:02b0 Microsoft Corp. Xbox NUI Motor
Bus 002 Device 018: ID 045e:02ad Microsoft Corp. Xbox NUI Audio
Bus 002 Device 019: ID 045e:02ae Microsoft Corp. Xbox NUI Camera

LS in the usb/002

vgonpa@VGonMac:[/opt/ros/fue.../openni_tracker]$ ls -lh /dev/bus/usb/002/
total 0
crw-rw-r-- 1 root root  189, 128 jun 20 11:49 001
crw-rw-r-- 1 root root  189, 129 jun 20 11:49 002
crw-rw-r-- 1 root root  189, 130 jun 20 11:49 003
crw-rw-r-- 1 root root  189, 143 jun 20 15:53 016
crw-rw-rw- 1 root video 189, 144 jun 20 15:53 017
crw-rw-rw- 1 root video 189, 145 jun 20 15:53 018
crw-rw-rw- 1 root video 189, 146 jun 20 16:16 019

openni_tracker Timeout Error in Fuerte (Ubuntu 12.04 LTS)

Hi all,

I'm trying to execute the openni_tracker node in ROS Fuerte running a Ubuntu 12.04 fresh install. When I launch the node I get the following error (full log at the end of the question):

[ERROR] [1340212031.075733079]: InitFromXml failed: Got a timeout while waiting for a network command to complete!

I have found other posts with a similar problem in Fuerte running (x)Ubuntu 12.04:

http://answers.ros.org/question/35956/openni_tracker-with-kinect-for-windows/ http://answers.ros.org/question/35620/openni_tracker-fails-with-fuerte-and-xubuntu-1204/

The first one points out that it might be a bug in Fuerte when running Ubuntu 12.04. Unfortunately, their questions did not receive any response. Therefore, I want to discard a problem related with my configuration or my installation before thinking that it is a bug in Fuerte. Moreover, if this were the case, It would already have aroused more noise from the community.

I'll appreciate any help that you can provide me, including if you are using this node in Fuerte with Ubuntu 12.04 LTS.

Thanks, Víctor.

LOGS

SYSTEM INFO:

  • Computer: MacBook Pro early 2011
  • Xbox Kinect
  • SO: Ubuntu 12.04 with dual boot (i.e. not running in a virtual machine)
  • ROS Version: ROS Fuerte

ERROR LOG when running the node (note that I set filter for openni to "INFO"):

vgonpa@VGonMac:[/opt/ros/fue.../openni_tracker]$ rosrun openni_tracker openni_tracker 
      446 INFO       New log started on 2012-06-20 17:54:52
      532 INFO       OpenNI version is 1.5.2 (Build 23)-Linux-x86 (May  3 2012 08:41:21)
      564 INFO       --- Filter Info --- Minimum Severity: INFO
    11555 INFO       Creating node 'Script1' of type Script: OpenNI/OpenNI/1.5.2.23...
    12196 INFO       USB is initialized.
    22861 INFO       Creating node 'Device1' of type Device: PrimeSense/SensorV2/5.1.0.41...
  4030211 INFO       Destroying node 'Script1'
  4030303 INFO       Destroying context
[ERROR] [1340211296.727793328]: InitFromXml failed: Got a timeout while waiting for a network command to complete!

lsusb LOG:

vgonpa@VGonMac:[/opt/ros/fue.../openni_tracker]$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0424:2513 Standard Microsystems Corp. 
Bus 001 Device 003: ID 05ac:8509 Apple, Inc. FaceTime HD Camera
Bus 002 Device 002: ID 0424:2513 Standard Microsystems Corp. 
Bus 001 Device 004: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 001 Device 005: ID 05ac:0246 Apple, Inc. Internal Keyboard/Trackpad (ISO)
Bus 002 Device 003: ID 05ac:8242 Apple, Inc. IR Receiver [built-in]
Bus 002 Device 016: ID 0409:005a NEC Corp. HighSpeed Hub
Bus 001 Device 008: ID 05ac:821a Apple, Inc. Bluetooth Host Controller
Bus 002 Device 017: ID 045e:02b0 Microsoft Corp. Xbox NUI Motor
Bus 002 Device 018: ID 045e:02ad Microsoft Corp. Xbox NUI Audio
Bus 002 Device 019: ID 045e:02ae Microsoft Corp. Xbox NUI Camera

LS in the usb/002

vgonpa@VGonMac:[/opt/ros/fue.../openni_tracker]$ ls -lh /dev/bus/usb/002/
total 0
crw-rw-r-- 1 root root  189, 128 jun 20 11:49 001
crw-rw-r-- 1 root root  189, 129 jun 20 11:49 002
crw-rw-r-- 1 root root  189, 130 jun 20 11:49 003
crw-rw-r-- 1 root root  189, 143 jun 20 15:53 016
crw-rw-rw- 1 root video 189, 144 jun 20 15:53 017
crw-rw-rw- 1 root video 189, 145 jun 20 15:53 018
crw-rw-rw- 1 root video 189, 146 jun 20 16:16 019

openni_tracker Timeout Error in Fuerte (Ubuntu 12.04 LTS)

Hi all,

I'm trying to execute the openni_tracker node in ROS Fuerte running a Ubuntu 12.04 fresh install. When I launch the node I get the following error (full log at the end of the question):

[ERROR] [1340212031.075733079]: InitFromXml failed: Got a timeout while waiting for a network command to complete!

I have found other posts with a similar problem in Fuerte running (x)Ubuntu 12.04:

http://answers.ros.org/question/35956/openni_tracker-with-kinect-for-windows/ http://answers.ros.org/question/35620/openni_tracker-fails-with-fuerte-and-xubuntu-1204/

The first one points out that it might be a bug in Fuerte when running Ubuntu 12.04. Unfortunately, their questions did not receive any response. Therefore, I want to discard a problem related with my configuration or my installation before thinking that it is a bug in Fuerte. Moreover, if this were the case, It would already have aroused more noise from the community.

I'll appreciate any help that you can provide me, including if you are using this node in Fuerte with Ubuntu 12.04 LTS.

Thanks, Víctor.

LOGS

SYSTEM INFO:

  • Computer: MacBook Pro early 2011
  • Xbox Kinect
  • SO: Ubuntu 12.04 with dual boot (i.e. not running in a virtual machine)
  • ROS Version: ROS Fuerte

ERROR LOG when running the node (note that I set filter for openni to "INFO"):

vgonpa@VGonMac:[/opt/ros/fue.../openni_tracker]$ rosrun openni_tracker openni_tracker 
      446 INFO       New log started on 2012-06-20 17:54:52
      532 INFO       OpenNI version is 1.5.2 (Build 23)-Linux-x86 (May  3 2012 08:41:21)
      564 INFO       --- Filter Info --- Minimum Severity: INFO
    11555 INFO       Creating node 'Script1' of type Script: OpenNI/OpenNI/1.5.2.23...
    12196 INFO       USB is initialized.
    22861 INFO       Creating node 'Device1' of type Device: PrimeSense/SensorV2/5.1.0.41...
  4030211 INFO       Destroying node 'Script1'
  4030303 INFO       Destroying context
[ERROR] [1340211296.727793328]: InitFromXml failed: Got a timeout while waiting for a network command to complete!

lsusb LOG:

vgonpa@VGonMac:[/opt/ros/fue.../openni_tracker]$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0424:2513 Standard Microsystems Corp. 
Bus 001 Device 003: ID 05ac:8509 Apple, Inc. FaceTime HD Camera
Bus 002 Device 002: ID 0424:2513 Standard Microsystems Corp. 
Bus 001 Device 004: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 001 Device 005: ID 05ac:0246 Apple, Inc. Internal Keyboard/Trackpad (ISO)
Bus 002 Device 003: ID 05ac:8242 Apple, Inc. IR Receiver [built-in]
Bus 002 Device 016: ID 0409:005a NEC Corp. HighSpeed Hub
Bus 001 Device 008: ID 05ac:821a Apple, Inc. Bluetooth Host Controller
Bus 002 Device 017: ID 045e:02b0 Microsoft Corp. Xbox NUI Motor
Bus 002 Device 018: ID 045e:02ad Microsoft Corp. Xbox NUI Audio
Bus 002 Device 019: ID 045e:02ae Microsoft Corp. Xbox NUI Camera

LS in the usb/002

vgonpa@VGonMac:[/opt/ros/fue.../openni_tracker]$ ls -lh /dev/bus/usb/002/
total 0
crw-rw-r-- 1 root root  189, 128 jun 20 11:49 001
crw-rw-r-- 1 root root  189, 129 jun 20 11:49 002
crw-rw-r-- 1 root root  189, 130 jun 20 11:49 003
crw-rw-r-- 1 root root  189, 143 jun 20 15:53 016
crw-rw-rw- 1 root video 189, 144 jun 20 15:53 017
crw-rw-rw- 1 root video 189, 145 jun 20 15:53 018
crw-rw-rw- 1 root video 189, 146 jun 20 16:16 019

openni_tracker Timeout Error in Fuerte (Ubuntu 12.04 LTS)

Hi all,

I'm trying to execute the openni_tracker node in ROS Fuerte running a Ubuntu 12.04 fresh install. When I launch the node I get the following error (full log at the end of the question):

[ERROR] [1340212031.075733079]: InitFromXml failed: Got a timeout while waiting for a network command to complete!

I have found other posts with a similar problem in Fuerte running (x)Ubuntu 12.04:

http://answers.ros.org/question/35956/openni_tracker-with-kinect-for-windows/ http://answers.ros.org/question/35620/openni_tracker-fails-with-fuerte-and-xubuntu-1204/

The first one points out that it might be a bug in Fuerte when running Ubuntu 12.04. Unfortunately, their questions did not receive any response. Therefore, I want to discard a problem related with my configuration or my installation before thinking that it is a bug in Fuerte. Moreover, if this were the case, It would already have aroused more noise from the community.

I'll appreciate any help that you can provide me, including if you are using this node in Fuerte with Ubuntu 12.04 LTS.

Thanks, Víctor.

LOGS

SYSTEM INFO:

  • Computer: MacBook Pro early 2011
  • Xbox Kinect
  • SO: Ubuntu 12.04 with dual boot (i.e. not running in a virtual machine)
  • ROS Version: ROS Fuerte

ERROR LOG when running the node (note that I set filter for openni to "INFO"):

vgonpa@VGonMac:[/opt/ros/fue.../openni_tracker]$ rosrun openni_tracker openni_tracker 
      446 INFO       New log started on 2012-06-20 17:54:52
      532 INFO       OpenNI version is 1.5.2 (Build 23)-Linux-x86 (May  3 2012 08:41:21)
      564 INFO       --- Filter Info --- Minimum Severity: INFO
    11555 INFO       Creating node 'Script1' of type Script: OpenNI/OpenNI/1.5.2.23...
    12196 INFO       USB is initialized.
    22861 INFO       Creating node 'Device1' of type Device: PrimeSense/SensorV2/5.1.0.41...
  4030211 INFO       Destroying node 'Script1'
  4030303 INFO       Destroying context
[ERROR] [1340211296.727793328]: InitFromXml failed: Got a timeout while waiting for a network command to complete!

lsusb LOG:

vgonpa@VGonMac:[/opt/ros/fue.../openni_tracker]$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0424:2513 Standard Microsystems Corp. 
Bus 001 Device 003: ID 05ac:8509 Apple, Inc. FaceTime HD Camera
Bus 002 Device 002: ID 0424:2513 Standard Microsystems Corp. 
Bus 001 Device 004: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 001 Device 005: ID 05ac:0246 Apple, Inc. Internal Keyboard/Trackpad (ISO)
Bus 002 Device 003: ID 05ac:8242 Apple, Inc. IR Receiver [built-in]
Bus 002 Device 016: ID 0409:005a NEC Corp. HighSpeed Hub
Bus 001 Device 008: ID 05ac:821a Apple, Inc. Bluetooth Host Controller
Bus 002 Device 017: ID 045e:02b0 Microsoft Corp. Xbox NUI Motor
Bus 002 Device 018: ID 045e:02ad Microsoft Corp. Xbox NUI Audio
Bus 002 Device 019: ID 045e:02ae Microsoft Corp. Xbox NUI Camera

LS in the usb/002

vgonpa@VGonMac:[/opt/ros/fue.../openni_tracker]$ ls -lh /dev/bus/usb/002/
total 0
crw-rw-r-- 1 root root  189, 128 jun 20 11:49 001
crw-rw-r-- 1 root root  189, 129 jun 20 11:49 002
crw-rw-r-- 1 root root  189, 130 jun 20 11:49 003
crw-rw-r-- 1 root root  189, 143 jun 20 15:53 016
crw-rw-rw- 1 root video 189, 144 jun 20 15:53 017
crw-rw-rw- 1 root video 189, 145 jun 20 15:53 018
crw-rw-rw- 1 root video 189, 146 jun 20 16:16 019

openni_tracker Timeout Error in Fuerte (Ubuntu 12.04 LTS)

Hi all,

I'm trying to execute the openni_tracker node in ROS Fuerte running a Ubuntu 12.04 fresh install. When I launch the node I get the following error (full log at the end of the question):

[ERROR] [1340212031.075733079]: InitFromXml failed: Got a timeout while waiting for a network command to complete!

I have found other posts with a similar problem in Fuerte running (x)Ubuntu 12.04:

http://answers.ros.org/question/35956/openni_tracker-with-kinect-for-windows/ http://answers.ros.org/question/35620/openni_tracker-fails-with-fuerte-and-xubuntu-1204/

The first one points out that it might be a bug in Fuerte when running Ubuntu 12.04. Unfortunately, their questions did not receive any response. Therefore, I want to discard a problem related with my configuration or my installation before thinking that it is a bug in Fuerte. Moreover, if this were the case, It would already have aroused more noise from the community.

I'll appreciate any help that you can provide me, including if you are using this node in Fuerte with Ubuntu 12.04 LTS.

Thanks, Víctor.

LOGS

SYSTEM INFO:

  • Computer: MacBook Pro early 2011
  • Xbox Kinect
  • SO: Ubuntu 12.04 with dual boot (i.e. not running in a virtual machine)
  • ROS Version: ROS Fuerte

ERROR LOG when running the node (note that I set filter for openni to "INFO"):

vgonpa@VGonMac:[/opt/ros/fue.../openni_tracker]$ rosrun openni_tracker openni_tracker 
      446 INFO       New log started on 2012-06-20 17:54:52
      532 INFO       OpenNI version is 1.5.2 (Build 23)-Linux-x86 (May  3 2012 08:41:21)
      564 INFO       --- Filter Info --- Minimum Severity: INFO
    11555 INFO       Creating node 'Script1' of type Script: OpenNI/OpenNI/1.5.2.23...
    12196 INFO       USB is initialized.
    22861 INFO       Creating node 'Device1' of type Device: PrimeSense/SensorV2/5.1.0.41...
  4030211 INFO       Destroying node 'Script1'
  4030303 INFO       Destroying context
[ERROR] [1340211296.727793328]: InitFromXml failed: Got a timeout while waiting for a network command to complete!

lsusb LOG:

vgonpa@VGonMac:[/opt/ros/fue.../openni_tracker]$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0424:2513 Standard Microsystems Corp. 
Bus 001 Device 003: ID 05ac:8509 Apple, Inc. FaceTime HD Camera
Bus 002 Device 002: ID 0424:2513 Standard Microsystems Corp. 
Bus 001 Device 004: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 001 Device 005: ID 05ac:0246 Apple, Inc. Internal Keyboard/Trackpad (ISO)
Bus 002 Device 003: ID 05ac:8242 Apple, Inc. IR Receiver [built-in]
Bus 002 Device 016: ID 0409:005a NEC Corp. HighSpeed Hub
Bus 001 Device 008: ID 05ac:821a Apple, Inc. Bluetooth Host Controller
Bus 002 Device 017: ID 045e:02b0 Microsoft Corp. Xbox NUI Motor
Bus 002 Device 018: ID 045e:02ad Microsoft Corp. Xbox NUI Audio
Bus 002 Device 019: ID 045e:02ae Microsoft Corp. Xbox NUI Camera

LS in the usb/002

vgonpa@VGonMac:[/opt/ros/fue.../openni_tracker]$ ls -lh /dev/bus/usb/002/
total 0
crw-rw-r-- 1 root root  189, 128 jun 20 11:49 001
crw-rw-r-- 1 root root  189, 129 jun 20 11:49 002
crw-rw-r-- 1 root root  189, 130 jun 20 11:49 003
crw-rw-r-- 1 root root  189, 143 jun 20 15:53 016
crw-rw-rw- 1 root video 189, 144 jun 20 15:53 017
crw-rw-rw- 1 root video 189, 145 jun 20 15:53 018
crw-rw-rw- 1 root video 189, 146 jun 20 16:16 019