Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Ros Foxy Bridge Failing

image description

Ros Foxy Bridge Failing

image description

click to hide/show revision 3
None

Ros Install Ros1-Bridge on Foxy Bridge is Failing

image description

Edit: text version of the error log:

root@7e18fbc1e12c:/# apt install ros-foxy-ros1-bridge
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-foxy-ros1-bridge : Depends: ros-noetic-actionlib-msgs but it is not installable
                        Depends: ros-noetic-catkin but it is not installable
                        Depends: ros-noetic-common-msgs but it is not installable
                        Depends: ros-noetic-gazebo-msgs but it is not installable
                        Depends: ros-noetic-geometry-msgs but it is not installable
                        Depends: ros-noetic-nav-msgs but it is not installable
                        Depends: ros-noetic-rosbash but it is not installable
                        Depends: ros-noetic-roscpp but it is not installable
                        Depends: ros-noetic-roscpp-tutorials but it is not installable
                        Depends: ros-noetic-roslaunch but it is not installable
                        Depends: ros-noetic-rosmsg but it is not installable
                        Depends: ros-noetic-rospy-tutorials but it is not installable
                        Depends: ros-noetic-sensor-msgs but it is not installable
                        Depends: ros-noetic-std-msgs but it is not installable
                        Depends: ros-noetic-std-srvs but it is not installable
                        Depends: ros-noetic-stereo-msgs but it is not installable
                        Depends: ros-noetic-tf but it is not installable
                        Depends: ros-noetic-tf2-msgs but it is not installable
                        Depends: ros-noetic-trajectory-msgs but it is not installable
                        Depends: ros-noetic-visualization-msgs but it is not installable
E: Unable to correct problems, you have held broken packages.