Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Wrong poses in RViz compared to poses defined in Moveit setup assistant

Hi,

I have created a Moveit config package using the moveit_setup_assistant, containing several poses for my 6dof arm. However, when executing these poses using:

roslaunch simple6dofarm_config demo.launch rviz_tutorial:=true

The poses are wrong, as can be seen on these two comparisons for example: Reference pose in Moveit assistant vs Reference pose in RViz And Hip left pose in Moveit assistant vs Hip left pose in RViz

What's going on ?

Wrong poses in RViz compared to poses defined in Moveit setup assistant

Hi,

I have created a Moveit config package using the moveit_setup_assistant, containing several poses for my 6dof arm. However, when executing these poses using:

roslaunch simple6dofarm_config demo.launch rviz_tutorial:=true

The ... then plan & execute (regardless of the planner apparently), poses are wrong, as can be seen on these two comparisons for example: Reference pose in Moveit assistant vs Reference pose in RViz And Hip left pose in Moveit assistant vs Hip left pose in RViz

What's going on ?

Wrong poses in RViz compared to poses defined in Moveit setup assistant

Hi,

I have created a Moveit config package using the moveit_setup_assistant, containing several poses for my 6dof arm. However, when executing these poses using:

roslaunch simple6dofarm_config demo.launch rviz_tutorial:=true

... then plan & execute (regardless of the planner apparently), execute, poses are wrong, as can be seen on these two comparisons for example: Reference pose in Moveit assistant vs Reference pose in RViz And Hip left pose in Moveit assistant vs Hip left pose in RViz

It looks like it's independant on the planner used. What's going on ?