Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

how to use the sensor_msgs/NavSatStatus ?

Hai,

I am trying to send fake gps position from mavlink to pixhawk for non_gps navigation using optical flow. im using - sensor_msgs/NavSatFix for giving lat, long & alt. http://docs.ros.org/api/sensor_msgs/html/msg/NavSatFix.html but in the documentation it is shown we can get a status of it by using sensor_msgs/NavSatStatus . http://docs.ros.org/api/sensor_msgs/html/msg/NavSatStatus.html

but i get the following error:-

error: expected primary-expression before ‘.’ token ROS_INFO("status = %d", sensor_msgs.NavSatStatus.status);

Guess I am not understanding how to use it! any help in this is appreciated!

Thanks!

how to use the sensor_msgs/NavSatStatus ?

Hai,

I am trying to send fake gps position from mavlink to pixhawk for non_gps navigation using optical flow. im using - sensor_msgs/NavSatFix for giving lat, long & alt. http://docs.ros.org/api/sensor_msgs/html/msg/NavSatFix.html but in the documentation it is shown we can get a status of it by using sensor_msgs/NavSatStatus . http://docs.ros.org/api/sensor_msgs/html/msg/NavSatStatus.html

but i get the following error:-

error: expected primary-expression before ‘.’ token
          ROS_INFO("status = %d", sensor_msgs.NavSatStatus.status);

sensor_msgs.NavSatStatus.status);

Guess I am not understanding how to use it! any help in this is appreciated!

Thanks!

how to use the sensor_msgs/NavSatStatus ?

Hai,

I am trying to send a fake gps GPS position from mavlink MAVROS to pixhawk for non_gps navigation using optical flow. im I'm using - sensor_msgs/NavSatFix "sensor_msgs/NavSatFix" for giving lat, long & alt. http://docs.ros.org/api/sensor_msgs/html/msg/NavSatFix.html but as per this page - http://docs.ros.org/api/sensor_msgs/html/msg/NavSatFix.html

And in the documentation documentation, it is shown we can get a status of it by using sensor_msgs/NavSatStatus . "sensor_msgs/NavSatStatus". as per this page - http://docs.ros.org/api/sensor_msgs/html/msg/NavSatStatus.html

but i I get the following error:-error when I use "sensor_msgs/NavSatStatus":-

ROS_INFO("status = %d", sensor_msgs.NavSatStatus.status); (this is my line of code)

error: expected primary-expression before ‘.’ token
          ROS_INFO("status = %d", sensor_msgs.NavSatStatus.status);

Guess I guess I am not understanding how to use it! "sensor_msgs/NavSatStatus", I don't get why this error is coming. any help in this is appreciated!

Thanks!