Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Qt 5 for ROS melodic

I'm wondering about the proper way to get Qt 5 for ROS melodic on Ubuntu 18.04. I searched for hours but couldn't find any recent tutorials. Last year, I developed this package where I used catkin_create_qt_pkg with qt_create and depending on qt_build and libqt4-dev. Since these packages are not available for ROS melodic, I can not compile the package anymore.

I've found and installed the following package: qt_gui, but without any hint what it does. I assume the qt_gui_cpp package installs Qt 5 and creates the bindings. Can someone give me an overview of what is needed and what these packages do? Is there a recent example for the package.xml and CMakeLists out there? I assume the source code is the same.

I installed the ROS Qt Creator Plug-in 4.9.2, but I assume this does just install a "ROS-ready" IDE without any Qt libraries, right?

Qt 5 for ROS melodic

I'm wondering about the proper way to get Qt 5 for ROS melodic on Ubuntu 18.04. I searched for hours but couldn't find any recent tutorials. Last year, I developed this package where I used catkin_create_qt_pkg with qt_create and depending on qt_build and libqt4-dev. Since these packages are not available for ROS melodic, I can not compile the package anymore.

I've found and installed the following package: qt_gui, but without any hint what it does. I assume the qt_gui_cpp package installs Qt 5 and creates the bindings. Can someone give me an overview of what is needed and what these packages do? Is there a recent example for the package.xml and CMakeLists out there? I assume the source code is the same.

I installed the ROS Qt Creator Plug-in 4.9.2, but I assume this does just install a "ROS-ready" IDE without any Qt libraries, right?

I'm also wondering about the differences between ros-melodic-qt-gui, ros-melodic-libqt and ros-melodic-qt.