Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

kinect v1 problems

Hi, I have a kinnect v1 connected to my desktop pc running lubuntu 16.04 I've installed freenect-launch and openni-launch package. I run roslaunch openni_launch openni.launch depth_registration:=true or roslaunch freenect_launch freenect.launch depth_registration:=true

on a second terminal I run rostopic hz /camera/rgb/image_raw and start getting 30 hz measurement on a third terminal I run rostopic hz /camera/depth_registered/image and once I get to measurement message I get "no new messages" on both, 2nd and 3rd terminal. I don't get any message on 1st terminal, but I don't get any messages. I have to close all laucnhs unplug kinnect and replug, then relaunch everything, but the same test get the same result.

Is there a way to test my kinnect cammera on linux or windows? I would like to know if it is a sensor problem or if it is a driver problem.

Thank

kinect v1 problems

Hi, I have a kinnect v1 connected to my desktop pc running lubuntu 16.04 I've installed freenect-launch and openni-launch package. I run package.

I run

roslaunch openni_launch openni.launch depth_registration:=true

or

roslaunch freenect_launch freenect.launch depth_registration:=true

depth_registration:=true

on a second terminal I run

rostopic hz /camera/rgb/image_raw /camera/rgb/image_raw

and start getting 30 hz measurement on measurement. On a third terminal I run run

rostopic hz /camera/depth_registered/image /camera/depth_registered/image

and once I get to measurement message I get "no new messages" on both, 2nd and 3rd terminal. I don't get any message on 1st terminal, but I don't get any messages. I have to close all laucnhs unplug kinnect and replug, then relaunch everything, but the same test get the same result.

Is there a way to test my kinnect cammera on linux or windows? I would like to know if it is a sensor problem or if it is a driver problem.

Thank