Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

No message recieved from pcl/NormalEstimation nodelet

Hello,

I'm trying to run simple example with kinect and normal estimation, I'm running a simple launch file:

<launch> <include file="$(find openni_launch)/launch/openni.launch"/>

<!-- Launch nodelet manager -->
<node pkg="nodelet" type="nodelet" name="nodelet_manager"  args="manager" output="screen"/>

<!-- Normal Estimation -->
<node pkg="nodelet" type="nodelet" name="normal_estimation" args="load pcl/NormalEstimation nodelet_manager" output="screen">
    <remap from="~input" to="/camera/depth_registered/points"/>
    <rosparam>
        # -[ Mandatory parameters
        k_search: 0
        radius_search: 0.015
        spatial_locator: 0
    </rosparam>

</node>

</launch>

but I'm getting "No message received" if I try to subscribe /normal_estimation/output topic in rviz, even though rostopic echo /normal_estimation/output show that messages are published.

No message recieved from pcl/NormalEstimation nodelet

Hello,

I'm trying to run simple example with kinect and normal estimation, I'm running a simple launch file:

<launch>
 <!-- Launch openni grabber -->
<include file="$(find openni_launch)/launch/openni.launch"/>

openni_launch)/launch/openni.launch"/>
<!-- Launch nodelet manager -->
<node pkg="nodelet" type="nodelet" name="nodelet_manager"  args="manager" output="screen"/>

<!-- Normal Estimation -->
<node pkg="nodelet" type="nodelet" name="normal_estimation" args="load pcl/NormalEstimation nodelet_manager" output="screen">
    <remap from="~input" to="/camera/depth_registered/points"/>
    <rosparam>
        # -[ Mandatory parameters
        k_search: 0
        radius_search: 0.015
        spatial_locator: 0
    </rosparam>

</node>
</launch>

</launch>

but I'm getting "No message received" if I try to subscribe /normal_estimation/output topic in rviz, even though rostopic echo /normal_estimation/output show that messages are published.