Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Working with large bag files

Hi,

I'm running into issues playing large rosbag files (over 50 Gb which exceeds my RAM size) consisting of several chunks using launch file.

It seems that the file is processed sequentially in chunks, and reading a single chunk from SSD takes some time (I see disk read speed jumps in htop) which is very noticeable while playing the whole file. Are there any known solutions to this?

I have tried the following:

  • Increasing queue parameter. Does not seem to have any effect
  • Change play rate rate. Did not help too.
  • cat $file >/dev/null helped for smaller bag files (< 20 Gb)

Thanks for your help!

Working with large bag files

Hi,

I'm running into issues playing large rosbag files (over 50 Gb which exceeds my RAM size) consisting of several chunks using launch file.

It seems that the file is processed sequentially in chunks, and reading a single chunk from SSD takes some time (I see disk read speed jumps in htop) which is very noticeable while playing the whole file. This results in glitches every few seconds. Are there any known solutions to this?

I have tried the following:

  • Increasing queue parameter. Does not seem to have any effect
  • Change play rate rate. Did not help too.
  • cat $file >/dev/null helped for smaller bag files (< 20 Gb)

Setup info:

  • OS: Linux Ubuntu 16.04 LTS
  • ROS: kinetic

Thanks for your help!

EDIT: add setup info

Working with large bag files

Hi,

I'm running into issues playing large rosbag files (over 50 Gb which exceeds my RAM size) consisting of several chunks using launch file.

It seems that the file is processed sequentially in chunks, and reading a single chunk from SSD takes some time (I see disk read speed jumps in htop) which is very noticeable while playing the whole file. This results in glitches every few seconds. Are there any known solutions to this?

I have tried the following:

  • Increasing queue parameter. Does not seem to have any effect
  • Change play rate rate. Did not help too.
  • cat $file >/dev/null helped did not help even for smaller bag small files (< 20 Gb)

Setup info:

  • OS: Linux Ubuntu 16.04 LTS
  • ROS: kinetic

Thanks for your help!

EDIT: add setup info