Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

No matching device found for gmapping

Hello everybody!

my name is Antonino and I work as a teacher in a Secondary School in Spain and I want to teach to my students how to use ROS.

my students using ROS

I have a Turtlebot 3 burger and we use it without problem but now we are trying to do the same things with a Turtlebot 2 and we are having some problems.

The Turtlebot 2 has an Astra camera and I have no problem when we do this.

roslaunch astra_launch astra.launch

rosrun rviz rviz

But, when we try to create a map we get this error:

No matching device found.... waiting for devices. Reason: std::__cxx11::string astra_wrapper::AstraDriver::resolveDeviceURI(const string&) @ /tmp/binarydeb/ros-kinetic-astra-camera-0.2.2/src/astra_driver.cpp @ 741 : Invalid device number 1, there are 0 devices connected.
[ INFO] [1557657651.767909049]: Using plugin "static_layer"
[ INFO] [1557657651.786272922]: Requesting the map...
[ INFO] [1557657654.437115202]: No matching device found.... waiting for devices. Reason: std::__cxx11::string astra_wrapper::AstraDriver::resolveDeviceURI(const string&) @ /tmp/binarydeb/ros-kinetic-astra-camera-0.2.2/src/astra_driver.cpp @ 741 : Invalid device number 1, there are 0 devices connected.

I execute this commands:

roslaunch turtlebot_bringup minimal.launch

roslaunch turtlebot_navigation gmapping_demo.launch

We have added export TURTLEBOT_3D_SENSOR=astra in the .bashrc file.

Could you help me?

Thank you in advance!

Regards,

Antonino

No matching device found for gmapping

Hello everybody!

my name is Antonino and I work as a teacher in a Secondary School in Spain and I want to teach to my students how to use ROS.

my students using ROS

I have a Turtlebot 3 burger and we use it without problem but now we are trying to do the same things with a Turtlebot 2 and we are having some problems.

The Turtlebot 2 has an Astra camera and I have no problem when we do this.

roslaunch astra_launch astra.launch

rosrun rviz rviz

But, when we try to create a map we get this error:

No matching device found.... waiting for devices. Reason: std::__cxx11::string astra_wrapper::AstraDriver::resolveDeviceURI(const string&) @ /tmp/binarydeb/ros-kinetic-astra-camera-0.2.2/src/astra_driver.cpp @ 741 : Invalid device number 1, there are 0 devices connected.
[ INFO] [1557657651.767909049]: Using plugin "static_layer"
[ INFO] [1557657651.786272922]: Requesting the map...
[ INFO] [1557657654.437115202]: No matching device found.... waiting for devices. Reason: std::__cxx11::string astra_wrapper::AstraDriver::resolveDeviceURI(const string&) @ /tmp/binarydeb/ros-kinetic-astra-camera-0.2.2/src/astra_driver.cpp @ 741 : Invalid device number 1, there are 0 devices connected.

I execute this commands:

roslaunch turtlebot_bringup minimal.launch

roslaunch turtlebot_navigation gmapping_demo.launch

We have added export TURTLEBOT_3D_SENSOR=astra in the .bashrc file.

Could you help me?

Thank you in advance!

Regards,

Antonino

No matching device found for gmappingSecondary School teacher in trouble. Help needed

Hello everybody!

my name is Antonino and I work as a teacher in a Secondary School in Spain and I want to teach to my students how to use ROS.

my students using ROS

I have a Turtlebot 3 burger and we use it without problem but now we are trying to do the same things with a Turtlebot 2 and we are having some problems.

The Turtlebot 2 has an Astra camera and I have no problem when we do this.

roslaunch astra_launch astra.launch

rosrun rviz rviz

But, when we try to create a map we get this error:

No matching device found.... waiting for devices. Reason: std::__cxx11::string astra_wrapper::AstraDriver::resolveDeviceURI(const string&) @ /tmp/binarydeb/ros-kinetic-astra-camera-0.2.2/src/astra_driver.cpp @ 741 : Invalid device number 1, there are 0 devices connected.
[ INFO] [1557657651.767909049]: Using plugin "static_layer"
[ INFO] [1557657651.786272922]: Requesting the map...
[ INFO] [1557657654.437115202]: No matching device found.... waiting for devices. Reason: std::__cxx11::string astra_wrapper::AstraDriver::resolveDeviceURI(const string&) @ /tmp/binarydeb/ros-kinetic-astra-camera-0.2.2/src/astra_driver.cpp @ 741 : Invalid device number 1, there are 0 devices connected.

I execute this commands:

roslaunch turtlebot_bringup minimal.launch

roslaunch turtlebot_navigation gmapping_demo.launch

We have added export TURTLEBOT_3D_SENSOR=astra in the .bashrc file.

Could you help me?

Thank you in advance!

Regards,

Antonino

No matching device found. Secondary School teacher in trouble. Help neededtrouble

Hello everybody!

my name is Antonino and I work as a teacher in a Secondary School in Spain and I want to teach to my students how to use ROS.

my students using ROS

I have a Turtlebot 3 burger and we use it without problem but now we are trying to do the same things with a Turtlebot 2 and we are having some problems.

The Turtlebot 2 has an Astra camera and I have no problem when we do this.

roslaunch astra_launch astra.launch

rosrun rviz rviz

But, when we try to create a map we get this error:

No matching device found.... waiting for devices. Reason: std::__cxx11::string astra_wrapper::AstraDriver::resolveDeviceURI(const string&) @ /tmp/binarydeb/ros-kinetic-astra-camera-0.2.2/src/astra_driver.cpp @ 741 : Invalid device number 1, there are 0 devices connected.
[ INFO] [1557657651.767909049]: Using plugin "static_layer"
[ INFO] [1557657651.786272922]: Requesting the map...
[ INFO] [1557657654.437115202]: No matching device found.... waiting for devices. Reason: std::__cxx11::string astra_wrapper::AstraDriver::resolveDeviceURI(const string&) @ /tmp/binarydeb/ros-kinetic-astra-camera-0.2.2/src/astra_driver.cpp @ 741 : Invalid device number 1, there are 0 devices connected.

I execute this commands:

roslaunch turtlebot_bringup minimal.launch

roslaunch turtlebot_navigation gmapping_demo.launch

We have added export TURTLEBOT_3D_SENSOR=astra in the .bashrc file.

Could you help me?

Thank you in advance!

Regards,

Antonino

TB3+Astra: No matching device found. Secondary School teacher in troublefound

Hello everybody!

my name is Antonino and I work as a teacher in a Secondary School in Spain and I want to teach to my students how to use ROS.

my students using ROS

I have a Turtlebot 3 burger and we use it without problem but now we are trying to do the same things with a Turtlebot 2 and we are having some problems.

The Turtlebot 2 has an Astra camera and I have no problem when we do this.

roslaunch astra_launch astra.launch

rosrun rviz rviz

But, when we try to create a map we get this error:

No matching device found.... waiting for devices. Reason: std::__cxx11::string astra_wrapper::AstraDriver::resolveDeviceURI(const string&) @ /tmp/binarydeb/ros-kinetic-astra-camera-0.2.2/src/astra_driver.cpp @ 741 : Invalid device number 1, there are 0 devices connected.
[ INFO] [1557657651.767909049]: Using plugin "static_layer"
[ INFO] [1557657651.786272922]: Requesting the map...
[ INFO] [1557657654.437115202]: No matching device found.... waiting for devices. Reason: std::__cxx11::string astra_wrapper::AstraDriver::resolveDeviceURI(const string&) @ /tmp/binarydeb/ros-kinetic-astra-camera-0.2.2/src/astra_driver.cpp @ 741 : Invalid device number 1, there are 0 devices connected.

I execute this commands:

roslaunch turtlebot_bringup minimal.launch

roslaunch turtlebot_navigation gmapping_demo.launch

We have added export TURTLEBOT_3D_SENSOR=astra in the .bashrc file.

Could you help me?

Thank you in advance!

Regards,

Antonino