Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

rviz qtCore missing in melodic

Hey there,

I just installed the melodic desktop version on my ubuntu 18.04 machine. If I try to roscore, rosrun rviz rviz I get the following error:

/opt/ros/melodic/lib/rviz/rviz: error while loading shared libraries: libQt5Core.so.5: cannot open shared object file: No such file or directoryde here

If I then do:

ldd /opt/ros/melodic/lib/librviz.so | grep Qt

I get:

libQt5Widgets.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5 (0x00007f9093ff4000)
libQt5Gui.so.5 => not found
libQt5Core.so.5 => not found
libQt5Gui.so.5 => not found
libQt5Core.so.5 => not found

Does anyone know how to solve this error?

PS: rqt_image_view also does not run:

 rosrun rqt_image_view rqt_image_view
Traceback (most recent call last):
  File "/opt/ros/melodic/lib/rqt_image_view/rqt_image_view", line 16, in <module>
    plugin_argument_provider=add_arguments))
  File "/opt/ros/melodic/lib/python2.7/dist-packages/rqt_gui/main.py", line 59, in main
    return super(Main, self).main(argv, standalone=standalone, plugin_argument_provider=plugin_argument_provider, plugin_manager_settings_prefix=str(hash(os.environ['ROS_PACKAGE_PATH'])))
  File "/opt/ros/melodic/lib/python2.7/dist-packages/qt_gui/main.py", line 338, in main
    from python_qt_binding import QT_BINDING
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/__init__.py", line 55, in <module>
    from .binding_helper import loadUi, QT_BINDING, QT_BINDING_MODULES, QT_BINDING_VERSION  # @UnusedImport
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 271, in <module>
    getattr(sys, 'SELECT_QT_BINDING_ORDER', None),
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 117, in _select_qt_binding
    raise ImportError("Could not find Qt binding (looked for: %s):\n%s" % (', '.join(["'%s'" % b for b in binding_order]), '\n'.join(error_msgs)))
ImportError: Could not find Qt binding (looked for: 'pyqt', 'pyside'):
  ImportError for 'pyqt': libQt5Core.so.5: cannot open shared object file: No such file or directory
Traceback (most recent call last):
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 108, in _select_qt_binding
    QT_BINDING_VERSION = binding_loader(required_modules, optional_modules)
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 150, in _load_pyqt
    _named_import('PyQt5.%s' % module_name)
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 130, in _named_import
    module = builtins.__import__(name)
ImportError: libQt5Core.so.5: cannot open shared object file: No such file or directory

  ImportError for 'pyside': No module named PySide2.QtCore
Traceback (most recent call last):
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 108, in _select_qt_binding
    QT_BINDING_VERSION = binding_loader(required_modules, optional_modules)
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 182, in _load_pyside
    _named_import('PySide2.%s' % module_name)
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 130, in _named_import
    module = builtins.__import__(name)
ImportError: No module named PySide2.QtCore

rviz qtCore missing in melodic

Hey there,

I just installed the melodic desktop version on my ubuntu 18.04 machine. If I try to roscore, rosrun rviz rviz I get the following error:

/opt/ros/melodic/lib/rviz/rviz: error while loading shared libraries: libQt5Core.so.5: cannot open shared object file: No such file or directoryde here

If I then do:

ldd /opt/ros/melodic/lib/librviz.so | grep Qt

I get:

libQt5Widgets.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5 (0x00007f9093ff4000)
libQt5Gui.so.5 => not found
libQt5Core.so.5 => not found
libQt5Gui.so.5 => not found
libQt5Core.so.5 => not found

Does anyone know how to solve this error?

PS: rqt_image_view also does not run:

 rosrun rqt_image_view rqt_image_view
Traceback (most recent call last):
  File "/opt/ros/melodic/lib/rqt_image_view/rqt_image_view", line 16, in <module>
    plugin_argument_provider=add_arguments))
  File "/opt/ros/melodic/lib/python2.7/dist-packages/rqt_gui/main.py", line 59, in main
    return super(Main, self).main(argv, standalone=standalone, plugin_argument_provider=plugin_argument_provider, plugin_manager_settings_prefix=str(hash(os.environ['ROS_PACKAGE_PATH'])))
  File "/opt/ros/melodic/lib/python2.7/dist-packages/qt_gui/main.py", line 338, in main
    from python_qt_binding import QT_BINDING
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/__init__.py", line 55, in <module>
    from .binding_helper import loadUi, QT_BINDING, QT_BINDING_MODULES, QT_BINDING_VERSION  # @UnusedImport
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 271, in <module>
    getattr(sys, 'SELECT_QT_BINDING_ORDER', None),
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 117, in _select_qt_binding
    raise ImportError("Could not find Qt binding (looked for: %s):\n%s" % (', '.join(["'%s'" % b for b in binding_order]), '\n'.join(error_msgs)))
ImportError: Could not find Qt binding (looked for: 'pyqt', 'pyside'):
  ImportError for 'pyqt': libQt5Core.so.5: cannot open shared object file: No such file or directory
Traceback (most recent call last):
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 108, in _select_qt_binding
    QT_BINDING_VERSION = binding_loader(required_modules, optional_modules)
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 150, in _load_pyqt
    _named_import('PyQt5.%s' % module_name)
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 130, in _named_import
    module = builtins.__import__(name)
ImportError: libQt5Core.so.5: cannot open shared object file: No such file or directory

  ImportError for 'pyside': No module named PySide2.QtCore
Traceback (most recent call last):
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 108, in _select_qt_binding
    QT_BINDING_VERSION = binding_loader(required_modules, optional_modules)
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 182, in _load_pyside
    _named_import('PySide2.%s' % module_name)
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 130, in _named_import
    module = builtins.__import__(name)
ImportError: No module named PySide2.QtCore

dpkg -l | grep qt5

ii  libqt5concurrent5:amd64                    5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 concurrent module
ii  libqt5core5a:amd64                         5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 core module
ii  libqt5dbus5:amd64                          5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 D-Bus module
ii  libqt5designer5:amd64                      5.9.5-0ubuntu1                               amd64        Qt 5 designer module
ii  libqt5gui5:amd64                           5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 GUI module
ii  libqt5help5:amd64                          5.9.5-0ubuntu1                               amd64        Qt 5 help module
ii  libqt5network5:amd64                       5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 network module
ii  libqt5opengl5:amd64                        5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 OpenGL module
ii  libqt5opengl5-dev:amd64                    5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 OpenGL library development files
ii  libqt5positioning5:amd64                   5.9.5+dfsg-0ubuntu2                          amd64        Qt Positioning module
ii  libqt5printsupport5:amd64                  5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 print support module
ii  libqt5qml5:amd64                           5.9.5-0ubuntu1.1                             amd64        Qt 5 QML module
ii  libqt5quick5:amd64                         5.9.5-0ubuntu1.1                             amd64        Qt 5 Quick library
ii  libqt5sensors5:amd64                       5.9.5-0ubuntu1                               amd64        Qt Sensors module
ii  libqt5sql5:amd64                           5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 SQL module
ii  libqt5sql5-sqlite:amd64                    5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 SQLite 3 database driver
ii  libqt5svg5:amd64                           5.9.5-0ubuntu1                               amd64        Qt 5 SVG module
ii  libqt5test5:amd64                          5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 test module
ii  libqt5webchannel5:amd64                    5.9.5-0ubuntu1                               amd64        Web communication library for Qt
ii  libqt5webkit5:amd64                        5.212.0~alpha2-7ubuntu1                      amd64        Web content engine library for Qt
ii  libqt5widgets5:amd64                       5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 widgets module
ii  libqt5xml5:amd64                           5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 XML module
ii  pyqt5-dev                                  5.10.1+dfsg-1ubuntu2                         all          Development files for PyQt5
ii  python-pyqt5                               5.10.1+dfsg-1ubuntu2                         amd64        Python 2 bindings for Qt5
ii  python-pyqt5.qtopengl                      5.10.1+dfsg-1ubuntu2                         amd64        Python 2 bindings for Qt5's OpenGL module
ii  python-pyqt5.qtsvg                         5.10.1+dfsg-1ubuntu2                         amd64        Python 2 bindings for Qt5's SVG module
ii  python-pyqt5.qtwebkit                      5.10.1+dfsg-1ubuntu2                         amd64        Python 2 bindings for Qt5's WebKit module
ii  qt5-qmake:amd64                            5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 qmake Makefile generator tool
ii  qt5-qmake-bin                              5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 qmake Makefile generator tool — binary file

rviz qtCore missing in melodic

Hey there,

I just installed the melodic desktop version on my ubuntu 18.04 machine. If I try to roscore, rosrun rviz rviz I get the following error:

/opt/ros/melodic/lib/rviz/rviz: error while loading shared libraries: libQt5Core.so.5: cannot open shared object file: No such file or directoryde here

If I then do:

ldd /opt/ros/melodic/lib/librviz.so | grep Qt

I get:

libQt5Widgets.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5 (0x00007f9093ff4000)
libQt5Gui.so.5 => not found
libQt5Core.so.5 => not found
libQt5Gui.so.5 => not found
libQt5Core.so.5 => not found

Does anyone know how to solve this error?

PS: rqt_image_view also does not run:

 rosrun rqt_image_view rqt_image_view
Traceback (most recent call last):
  File "/opt/ros/melodic/lib/rqt_image_view/rqt_image_view", line 16, in <module>
    plugin_argument_provider=add_arguments))
  File "/opt/ros/melodic/lib/python2.7/dist-packages/rqt_gui/main.py", line 59, in main
    return super(Main, self).main(argv, standalone=standalone, plugin_argument_provider=plugin_argument_provider, plugin_manager_settings_prefix=str(hash(os.environ['ROS_PACKAGE_PATH'])))
  File "/opt/ros/melodic/lib/python2.7/dist-packages/qt_gui/main.py", line 338, in main
    from python_qt_binding import QT_BINDING
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/__init__.py", line 55, in <module>
    from .binding_helper import loadUi, QT_BINDING, QT_BINDING_MODULES, QT_BINDING_VERSION  # @UnusedImport
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 271, in <module>
    getattr(sys, 'SELECT_QT_BINDING_ORDER', None),
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 117, in _select_qt_binding
    raise ImportError("Could not find Qt binding (looked for: %s):\n%s" % (', '.join(["'%s'" % b for b in binding_order]), '\n'.join(error_msgs)))
ImportError: Could not find Qt binding (looked for: 'pyqt', 'pyside'):
  ImportError for 'pyqt': libQt5Core.so.5: cannot open shared object file: No such file or directory
Traceback (most recent call last):
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 108, in _select_qt_binding
    QT_BINDING_VERSION = binding_loader(required_modules, optional_modules)
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 150, in _load_pyqt
    _named_import('PyQt5.%s' % module_name)
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 130, in _named_import
    module = builtins.__import__(name)
ImportError: libQt5Core.so.5: cannot open shared object file: No such file or directory

  ImportError for 'pyside': No module named PySide2.QtCore
Traceback (most recent call last):
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 108, in _select_qt_binding
    QT_BINDING_VERSION = binding_loader(required_modules, optional_modules)
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 182, in _load_pyside
    _named_import('PySide2.%s' % module_name)
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 130, in _named_import
    module = builtins.__import__(name)
ImportError: No module named PySide2.QtCore

dpkg -l | grep qt5

ii  libqt5concurrent5:amd64                    5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 concurrent module
ii  libqt5core5a:amd64                         5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 core module
ii  libqt5dbus5:amd64                          5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 D-Bus module
ii  libqt5designer5:amd64                      5.9.5-0ubuntu1                               amd64        Qt 5 designer module
ii  libqt5gui5:amd64                           5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 GUI module
ii  libqt5help5:amd64                          5.9.5-0ubuntu1                               amd64        Qt 5 help module
ii  libqt5network5:amd64                       5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 network module
ii  libqt5opengl5:amd64                        5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 OpenGL module
ii  libqt5opengl5-dev:amd64                    5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 OpenGL library development files
ii  libqt5positioning5:amd64                   5.9.5+dfsg-0ubuntu2                          amd64        Qt Positioning module
ii  libqt5printsupport5:amd64                  5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 print support module
ii  libqt5qml5:amd64                           5.9.5-0ubuntu1.1                             amd64        Qt 5 QML module
ii  libqt5quick5:amd64                         5.9.5-0ubuntu1.1                             amd64        Qt 5 Quick library
ii  libqt5sensors5:amd64                       5.9.5-0ubuntu1                               amd64        Qt Sensors module
ii  libqt5sql5:amd64                           5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 SQL module
ii  libqt5sql5-sqlite:amd64                    5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 SQLite 3 database driver
ii  libqt5svg5:amd64                           5.9.5-0ubuntu1                               amd64        Qt 5 SVG module
ii  libqt5test5:amd64                          5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 test module
ii  libqt5webchannel5:amd64                    5.9.5-0ubuntu1                               amd64        Web communication library for Qt
ii  libqt5webkit5:amd64                        5.212.0~alpha2-7ubuntu1                      amd64        Web content engine library for Qt
ii  libqt5widgets5:amd64                       5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 widgets module
ii  libqt5xml5:amd64                           5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 XML module
ii  pyqt5-dev                                  5.10.1+dfsg-1ubuntu2                         all          Development files for PyQt5
ii  python-pyqt5                               5.10.1+dfsg-1ubuntu2                         amd64        Python 2 bindings for Qt5
ii  python-pyqt5.qtopengl                      5.10.1+dfsg-1ubuntu2                         amd64        Python 2 bindings for Qt5's OpenGL module
ii  python-pyqt5.qtsvg                         5.10.1+dfsg-1ubuntu2                         amd64        Python 2 bindings for Qt5's SVG module
ii  python-pyqt5.qtwebkit                      5.10.1+dfsg-1ubuntu2                         amd64        Python 2 bindings for Qt5's WebKit module
ii  qt5-qmake:amd64                            5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 qmake Makefile generator tool
ii  qt5-qmake-bin                              5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 qmake Makefile generator tool — binary file

dpkg -S libQt5Gui.so.5

libqt5gui5:amd64: /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
libqt5gui5:amd64: /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5.9.5
libqt5gui5:amd64: /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5.9

rviz qtCore missing in melodic

Hey there,

I just installed the melodic desktop version on my ubuntu 18.04 machine. If I try to roscore, rosrun rviz rviz I get the following error:

/opt/ros/melodic/lib/rviz/rviz: error while loading shared libraries: libQt5Core.so.5: cannot open shared object file: No such file or directoryde here

If I then do:

ldd /opt/ros/melodic/lib/librviz.so | grep Qt

I get:

libQt5Widgets.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5 (0x00007f9093ff4000)
libQt5Gui.so.5 => not found
libQt5Core.so.5 => not found
libQt5Gui.so.5 => not found
libQt5Core.so.5 => not found

Does anyone know how to solve this error?

PS: rqt_image_view also does not run:

 rosrun rqt_image_view rqt_image_view
Traceback (most recent call last):
  File "/opt/ros/melodic/lib/rqt_image_view/rqt_image_view", line 16, in <module>
    plugin_argument_provider=add_arguments))
  File "/opt/ros/melodic/lib/python2.7/dist-packages/rqt_gui/main.py", line 59, in main
    return super(Main, self).main(argv, standalone=standalone, plugin_argument_provider=plugin_argument_provider, plugin_manager_settings_prefix=str(hash(os.environ['ROS_PACKAGE_PATH'])))
  File "/opt/ros/melodic/lib/python2.7/dist-packages/qt_gui/main.py", line 338, in main
    from python_qt_binding import QT_BINDING
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/__init__.py", line 55, in <module>
    from .binding_helper import loadUi, QT_BINDING, QT_BINDING_MODULES, QT_BINDING_VERSION  # @UnusedImport
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 271, in <module>
    getattr(sys, 'SELECT_QT_BINDING_ORDER', None),
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 117, in _select_qt_binding
    raise ImportError("Could not find Qt binding (looked for: %s):\n%s" % (', '.join(["'%s'" % b for b in binding_order]), '\n'.join(error_msgs)))
ImportError: Could not find Qt binding (looked for: 'pyqt', 'pyside'):
  ImportError for 'pyqt': libQt5Core.so.5: cannot open shared object file: No such file or directory
Traceback (most recent call last):
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 108, in _select_qt_binding
    QT_BINDING_VERSION = binding_loader(required_modules, optional_modules)
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 150, in _load_pyqt
    _named_import('PyQt5.%s' % module_name)
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 130, in _named_import
    module = builtins.__import__(name)
ImportError: libQt5Core.so.5: cannot open shared object file: No such file or directory

  ImportError for 'pyside': No module named PySide2.QtCore
Traceback (most recent call last):
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 108, in _select_qt_binding
    QT_BINDING_VERSION = binding_loader(required_modules, optional_modules)
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 182, in _load_pyside
    _named_import('PySide2.%s' % module_name)
  File "/opt/ros/melodic/lib/python2.7/dist-packages/python_qt_binding/binding_helper.py", line 130, in _named_import
    module = builtins.__import__(name)
ImportError: No module named PySide2.QtCore

dpkg -l | grep qt5

ii  libqt5concurrent5:amd64                    5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 concurrent module
ii  libqt5core5a:amd64                         5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 core module
ii  libqt5dbus5:amd64                          5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 D-Bus module
ii  libqt5designer5:amd64                      5.9.5-0ubuntu1                               amd64        Qt 5 designer module
ii  libqt5gui5:amd64                           5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 GUI module
ii  libqt5help5:amd64                          5.9.5-0ubuntu1                               amd64        Qt 5 help module
ii  libqt5network5:amd64                       5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 network module
ii  libqt5opengl5:amd64                        5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 OpenGL module
ii  libqt5opengl5-dev:amd64                    5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 OpenGL library development files
ii  libqt5positioning5:amd64                   5.9.5+dfsg-0ubuntu2                          amd64        Qt Positioning module
ii  libqt5printsupport5:amd64                  5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 print support module
ii  libqt5qml5:amd64                           5.9.5-0ubuntu1.1                             amd64        Qt 5 QML module
ii  libqt5quick5:amd64                         5.9.5-0ubuntu1.1                             amd64        Qt 5 Quick library
ii  libqt5sensors5:amd64                       5.9.5-0ubuntu1                               amd64        Qt Sensors module
ii  libqt5sql5:amd64                           5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 SQL module
ii  libqt5sql5-sqlite:amd64                    5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 SQLite 3 database driver
ii  libqt5svg5:amd64                           5.9.5-0ubuntu1                               amd64        Qt 5 SVG module
ii  libqt5test5:amd64                          5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 test module
ii  libqt5webchannel5:amd64                    5.9.5-0ubuntu1                               amd64        Web communication library for Qt
ii  libqt5webkit5:amd64                        5.212.0~alpha2-7ubuntu1                      amd64        Web content engine library for Qt
ii  libqt5widgets5:amd64                       5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 widgets module
ii  libqt5xml5:amd64                           5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 XML module
ii  pyqt5-dev                                  5.10.1+dfsg-1ubuntu2                         all          Development files for PyQt5
ii  python-pyqt5                               5.10.1+dfsg-1ubuntu2                         amd64        Python 2 bindings for Qt5
ii  python-pyqt5.qtopengl                      5.10.1+dfsg-1ubuntu2                         amd64        Python 2 bindings for Qt5's OpenGL module
ii  python-pyqt5.qtsvg                         5.10.1+dfsg-1ubuntu2                         amd64        Python 2 bindings for Qt5's SVG module
ii  python-pyqt5.qtwebkit                      5.10.1+dfsg-1ubuntu2                         amd64        Python 2 bindings for Qt5's WebKit module
ii  qt5-qmake:amd64                            5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 qmake Makefile generator tool
ii  qt5-qmake-bin                              5.9.5+dfsg-0ubuntu1                          amd64        Qt 5 qmake Makefile generator tool — binary file

dpkg -S libQt5Gui.so.5

libqt5gui5:amd64: /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
libqt5gui5:amd64: /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5.9.5
libqt5gui5:amd64: /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5.9

I have a guess: May it be that the name is simply false? I have no libQt5Gui.so.5 however I have a libQt5Core.so :

grep libQt5
libQt5Concurrent.prl              libQt5Qml.so.5.9.5
libQt5Concurrent.so               libQt5Quick.so.5
libQt5Concurrent.so.5             libQt5Quick.so.5.9
libQt5Concurrent.so.5.9           libQt5Quick.so.5.9.5
libQt5Concurrent.so.5.9.5         libQt5Sensors.so.5
libQt5Core.prl                    libQt5Sensors.so.5.9
libQt5Core.so                     libQt5Sensors.so.5.9.5
libQt5DBus.prl                    libQt5Sql.prl
libQt5DBus.so                     libQt5Sql.so
libQt5Designer.so.5               libQt5Sql.so.5
libQt5Designer.so.5.9             libQt5Sql.so.5.9
libQt5Designer.so.5.9.5           libQt5Sql.so.5.9.5
libQt5EglFSDeviceIntegration.prl  libQt5Svg.so.5
libQt5EglFSDeviceIntegration.so   libQt5Svg.so.5.9
libQt5EglFsKmsSupport.prl         libQt5Svg.so.5.9.5
libQt5EglFsKmsSupport.so          libQt5Test.prl
libQt5Gui.prl                     libQt5Test.so
libQt5Gui.so                      libQt5Test.so.5
libQt5Help.so.5                   libQt5Test.so.5.9
libQt5Help.so.5.9                 libQt5Test.so.5.9.5
libQt5Help.so.5.9.5               libQt5WebChannel.so.5
libQt5Network.prl                 libQt5WebChannel.so.5.9
libQt5Network.so                  libQt5WebChannel.so.5.9.5
libQt5OpenGLExtensions.a          libQt5WebKit.so.5
libQt5OpenGLExtensions.prl        libQt5WebKit.so.5.212.0
libQt5OpenGL.prl                  libQt5WebKitWidgets.so.5
libQt5OpenGL.so                   libQt5WebKitWidgets.so.5.212.0
libQt5OpenGL.so.5                 libQt5Widgets.prl
libQt5OpenGL.so.5.9               libQt5Widgets.so
libQt5OpenGL.so.5.9.5             libQt5Widgets.so.5
libQt5Positioning.so.5            libQt5Widgets.so.5.9
libQt5Positioning.so.5.9          libQt5Widgets.so.5.9.5
libQt5Positioning.so.5.9.5        libQt5XcbQpa.prl
libQt5PrintSupport.prl            libQt5XcbQpa.so
libQt5PrintSupport.so             libQt5Xml.prl
libQt5PrintSupport.so.5           libQt5Xml.so
libQt5PrintSupport.so.5.9         libQt5Xml.so.5
libQt5PrintSupport.so.5.9.5       libQt5Xml.so.5.9
libQt5Qml.so.5                    libQt5Xml.so.5.9.5
libQt5Qml.so.5.9